Large X8 crashes every flight

I am building an X8 that I need to pick up, carry and set down 50 lbs. I have been stuck in the tuning phase for 2 months now because I can’t keep it in the air long enough to auto tune or get any kind of idea how it flies. When it is unladen, if I try stabilize mode, it either goes to the moon or crashes. I tried putting a curve, expo and several other things on the throttle then abandoned stabilize mode so I didn’t have to worry about thrust.

I thought an auto mode would be better so I could just tell it to either, climb, descend or hold position. This was a disaster too. It went crazy, started bouncing in alt hold, and came back towards us. I stepped between it and the kids (who are no longer allowed around it) and ended up with six stitches in the leg.

I really think the poshold, loiter or althold are my answers because it will behave differently when it has the weight but I can’t get it to hover. I added a laser range finder hoping this would help but it still bounces and ultimately crashes. The latest crash broke some props, an arm and damaged the frame.

I am new and this is my first build. I just learned how to get the logs this morning. I am so scared to fix and fly this thing again. From what I can see, the motors might be off balance, there is interference and some GPS error. Can someone please help me? I’ve tried to do this on my own so I could learn but these crashes are dangerous and expensive.

About the vehicle;

Flight controller = pixhawk 2.4.8

Ardupilot 4.0.7

Escs = Tmotor F55A pro 2, 4-in-1 (times 2)

Motors = KDE 4215 XF 465 kv motors (times 8)

Props = 1855 carbon fiber (times 8)

Frame = custom made 8 inch by 3 inch carbon fiber octagon

Batteries = 5200 mAh 4S lipo times 2

Lidar = TF Luna 8 m range

It is, roughly, 4 feet from prop to prop and stands about 2 feet off of the ground.

Here is the log;

Size (kb) 2955.873046875
No of lines 38397
Duration 0:01:57
Vehicletype ArduCopter
Firmware Version V4.0.7
Firmware Hash 0bb18a15
Hardware Type
Free Mem 0
Skipped Lines 0
Test: Autotune = UNKNOWN - No ATUN log data
Test: Brownout = GOOD -
Test: Compass = FAIL - Large change in mag_field (589.27%)
Max mag field length (2623.29) > recommended (550.00)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = FAIL - ERRs found: CRASH GPS_GLITCH
Test: GPS = UNKNOWN - join() takes exactly one argument (2 given)
Test: IMU Mismatch = NA -
Test: Motor Balance = WARN - Motor channel averages = [1199, 1131, 1209, 1139, 1201, 1128, 1208, 1140]
Average motor output = 1169
Difference between min and max motor averages = 81
Test: NaNs = FAIL - Found NaN in CTUN.DSAlt

Test: OpticalFlow = FAIL - FAIL: no optical flow data

Test: Parameters = FAIL - ‘MAG_ENABLE’ not found
Test: PM = GOOD -
Test: Pitch/Roll = UNKNOWN - ‘BarAlt’
Test: Thrust = GOOD -
Test: VCC = UNKNOWN - No CURR log data

Here’s a link to the video of this incident;

Any help would be appreciated. I should have started with something lighter and smaller but I am committed now and have a lot invested in it. Thank you in advance.

Auto Analysis is out of date and mostly useless. Video’s don’t offer much. Post a link to a .bin flight log.

Thank you for the quick response. It will be a few hours before I have access to my computer again. I had some issues uploading the .bin file.

You can’t upload it directly here. Place it in a Cloud service and post a link to it. Before even looking at it did you follow the Initial Tuning guidlines here and/or use the Alt>A Mission Planner plug-in to configure? This is done pre-1st flight…
Initial Tuning

Yes sir. I tried to learn as much about it as possible before I took off. The first couple of steps where a disaster as it is severely overpowered. I hope you are able to access this bin file


Message in a private group or channel.
This link will only work if you are a member.

How about Dropbox

Looks like default parameters to me…

One problem is the Vcc (5volts) to the flight controller - it’s too low and will eventually cause bigger problems. It’s not necessarily the cause of your present issues though. You’ll need about 5.20 volts.

Motor outputs are low at this stage, add some dummy payload. Maybe after stable flight you’ll get a better feel for how much payload is needed, if at all.
Rear motors, M2, M4, M6, M8 are throttled back, as if the front motors are not producing any thrust even though they are increasing output.

Desired Pitch and Roll almost move opposite to actual pitch and roll, although there’s not much data to go on…

My first guess is motor order, direction and maybe prop fitment is wrong.

Next job before flight:
Make sure the battery voltage monitor is working perfectly for voltage and current, then set
and press Alt A while connected to MissionPlanner, enter your prop size and battery type, accept all that it offers.
Go to the RC calibration page
Roll, Yaw and Throttle input should cause the green bars to move in the same direction as the RC sticks.
Pitch input should cause the Pitch green bar to move in the opposite direction to the stick!

  • Pull back on the stick (down) = green bar goes UP
  • Push forward on the stick (up) = green bar goes DOWN

Think of the nose of a plane. If you need to, reverse the output of your transmitter pitch channel.

And this is optional, but will smooth out your RC input:

MOT_SPIN_ARM is at 1 (100%). Fix that. I’m guessing you didn’t run Mission Planners Motor Test? Start back at the beginning.

I run motor test every time before I fly it consistent with this pictureX8 Motors. All motors spin how this picture shows. Is this pic wrong?

Thank you for looking at it.

No, that’s good. But you need to set the Initial Tuning parameters before 1st flight. OK, too late for that but do it now. Also, set MOT_SPIN_ARM to default (.1) or 0 if you don’t want them to spin. And read this for other settings:
Motor Range

Dshot1200 isn’t the best place to start with a big Octo. You may want to just set it to PWM until you get it flying. You have configured the main outputs anyway so that’s what you are getting. No Dshot on those outputs.

What is this crafts take-off-weight (with battery)?

I was wrong about the motor numbering and outputs. I hadn’t checked or realised it was a Quad X8.
So the issue with the motor outputs is the CCW motors 1,3,5,7 are throttling up to counteract a physical yaw bias with motors 2,4,6,8. Arms or motor mounts could be twisted.

Also check your RC calibration, remove all transmitter trims and just redo it anyway. Your pitch channel is not properly centered.

I did change flight controllers between this step but also switched the micro sd. I guess it didn’t keep the parameters. The takeoff weight right now is 12 lbs. thank you guys for the guidance.

The props on the bottom motors do face up on an X8, correct? I read that somewhere, here, while I was building it. So if you flipped it upside down to install them, you would feel like you were putting them in upside down?

Why would I not be getting the desired 5.2? I chose the 3DR power module option. Should I try something else?

Correct about the props.
Measure that input voltage at the flight controller - some of them have been known to report the Vcc incorrectly. If it really is low as per the logs, then exercise caution.
Almost all 3DR power modules in recent times are cheap copies with a minimum parts count.
It will be OK for testing, don’t run down your battery and don’t fly too high or far away in case that low voltage causes a brown-out of the flight controller.

Look very carefully at the angles of all the props in relation to each other and the “plane” of the frame.

Thank you guys. Once I rebuild it, I will start from the beginning and reconfigure everything. Is there a better alternative power module? I hated this one from the beginning. Had to switch nearly every wire around after testing voltage in order to get it to work.

In your country:
You could select the Classic Power Module, and it comes with the correct cable:
MRC0213 6-Pins DF13 to JST-GH cable for PixHawk.

or the Power Zero which will be better but it may require you to make up a cable