Large Vehicle Mag Calibrate Failed to Execute


I have a rover that weighs a few hundred kgs so it is impossible to calibrate the compass by rotating the rover.
I an trying to calibrate the compass by clicking the Large Vehicle Mag Cal button when I enter the heading the says failed to execute.
Any ideas how to solve this?


Not sure if this helps you but it autopilot requires a 3D GPS fix for the command to execute.

Thanks I have tried with both 3D fix and RTK fix and still I cannot calibrate it.

I am not much help in that case. I have only used this command with copter code.

Take the FC out, attach temporarily the GPS in the same relative position, supply it so that all elements are supplied, and do the calibration.

I have tried calibrating the compass a few times, both around the metal parts where it will be fitted and away from the metal parts.

What parameter does the large vehicle mag cal change is it the AHRS_CUSTOM_YAW?

When I had a compass on my mower, I always used the the Compass Learn feature. It is described here: Advanced Compass Setup — Rover documentation (

Bullet 5 describes the method I used to trigger it. I set a channel switch on my remote to option 62 on the tuning page which allows me to flip the switch when I have my vehicle in manual and out in the open ready to “learn”. I have the Messages tab open in Mission Planner. When you flip the switch on (you can flip it right back off), it triggers the learning mode. Drive your vehicle around in crazy patterns and circles until you see the “Compass Learned: Finished” message.

I see that this method is not recommended but that is what I always did and it worked well for me.

The original introduction of this feature was introduced and discussed here: Testers needed for in-flight compass learning - Blog - ArduPilot Discourse