Landing Gear and Gimbal not working on AUX ports?

@alainlive, @Roman_Kirillov,

I’ve just tested landing gear on a Pixhawk1 and it appears to work. I haven’t tested the gimbal yet. This doesn’t mean that there is no problem of course, just that I haven’t been able to reproduce it.

If you have a parameter file or log file that would be great. If not I’ll keep investigating on my own…
I went back to 3.5.5 to test the operation of the gimbal, so maybe a problem in 3.6 RC1?
Thank you for your excellent work

@rmackay9 I was trying to get the landing gear working with a Pixhawk 1 last week. I found that it worked on my 3DR pixhawk 1 (circa 2016) but when I tried to get it working on a new pixhawk 1 (v2.4.6) sold by Mrobotics, it didn’t work.
Here is the site where I bought the pixhawk. Not sure what would be different that could cause this issue.

OK, thanks for that info. I tested on my mRobotics Pixhawk1 (same as in the link) but clearly we’ve got a few people who can’t get it working so we must have an issue. I’ll check some of my other boards, surely one of them won’t work.

By the way, I actually experienced this issue on Copter 3.5.5. Here are the settings I was using. Unfortunately I don’t have access to the quad at the moment to get you a PARAM file. Here is what I remember.
CH7_OPT = 29

when I changed this to have the landing gear on servo 8, it worked. One other interesting thing is that I tried it in the SITL and it didn’t work. Servo 9 always shows 0. when I set servo 8 function to 29, it shows the SERVO in the mission planner status page to have a PWM value according to the gear position.

Hope this helps.

Thanks Bill. I’ll keep poking around with my boards.

By the way, the issue with the Servo9 output is because by default we use Mavlink1. If the SERIALx_PROTOCOL is set to “2” (for mavlink2) then it’ll appear I think.

Ok. The SERIALx_PROTOCOL fixed the issue in the Sim. That isn’t mentioned anywhere in the landing gear setup wiki. I’m not familiar enough with the hardware to know why that would affect the aux ports.

Looking back at my set up for my 3DR pixhawk, the SERIALx_PROTOCOLs were all set to 1. And I got the landing gear to work on channel 9 in that Pixhawk with a Copter 3.5.5 software load.

1 Like


the servo9 output thing is just a display issue… in that we can only send the value to the GCS if mavlink2 is used. The landing gear itself will work regardless of what SERIALx_PROTOCOL is set to.

Landing gears does not work when the ESC is in Oneshot125 mode (for example, when in normal mode it works)… I think the reason is that AUX’s also start working in Oneshot125 mode but not in PWM.

So I’ve just tested on my Pixhawk 1, setting MOT_PWM_TYPE = 2 (OneShot125) and the landing gear attached to AUX OUT 1", aka “SERVO9” and it seems to be working. I can see with a servo analyser that it’s properly outputting pwm values of 1750 and 1250 depending upon the ch7 input switch position.

… so I’m still unable to reproduce this problem which is a bit annoying… I’m sure it’s a real problem but I just can’t reproduce it.

Landing gear and gimbal is working on my Octo chibiOS rc-2. Cube using servo 9 and 10.

1 Like

I guess your landing gear is still not working? which hardware are you using? Any chance you could give me a dataflash log file? … and have you tried getting the landing gear working with Copter-3.5.5? Doing this would help confirm that it’s an issue in 3.6 and not just a general setup issue.


sorry, that file has gone missing, I guess I waited too long before downloading it.

I was wondering if you could confirm that the landing gear is still not working with -rc2?

OK, haven’t heard back from anyone so I think this issue is resolved. Tridge suggested this morning in the dev call that it could be related to the BRD_PWM_COUNT and new checks that we’ve added in 3.6 to ensure the board isn’t configured to use a single pin for two purposes (i.e. Relay and PWM output).