LAND mode sent my drone flying straight up

Hi, this was my first flight attempt after setting up my copter.

I took off on stabilize, I was able to hover around 1m from the ground. I then wanted to land the copter, so I proceeded to switch to LAND mode, but instead of going straight down, it flew straight up. I am using a rangefinder, but from what I could see in the logs, it is working correctly and was set up in the right orientation (downwards).

I’m pretty new to this, anyone can give me an insight as to what might be going on?



that is correct.

There is a few things going on.
Stability and oscillations, motor outputs frequently going to minimum.
That means when trying to maintain altitude the motor outputs can only effectively go up.
Also the Rangefinder. You can see when the barometer altitude is increasing rangefinder alt even goes down for a bit, then stays fairly steady at a low altitude.
So you will have to revisit the rangefinder, or disable it entirely until you’ve completed tuning.

Try changing these paramaters which might suit your small copter a bit better

INS_HNTCH_ENABLE,1  // set this then refresh params to see the rest

DHSHOT600 will be more than enough, and fits in better with loop rates and seems more reliable with some ESCs.
Now just hover in Stabilise and try AltHold, some gentle pitch and roll if possible.
Let’s see that log file.

I saw the betacopter thing too and wondered what it is. It seems a fork of standard ardupilot, but is maybe not recent. Maybe olliw42 set it up for some testing??
How did you land there and decide to use it?
I would change to latest stable Arducopter firmware right away.

EDIT some more

" If you want to make best use of your STorM32 gimbal and want 2020-ish capabilities, then you may want to chose BetaPilot (BetaCopter/BetaPlane). This fork of ArduPilot is specifically designed for the STorM32 gimbal controller, and provides the best range of functions. For details see Using STorM32 with BetaPilot."

I wouldnt have thought you’d be using a storm32 controlled gimbal with a 7inch copter, but I guess it’s possible. This implies lots of video work, and I think you’d want to be using latest stable firmware for reliability and current fixes, rather than having an extra gimbal feature or two.

1 Like

Thank you very much for the suggestion. I’ll change the parameters and give it another shot. My drone is small but is a little heave for it’s size (~1kg). Would this change anything?

Regarding what Betacopter is and why I decided to use it:

BetaPilot (Betacopter) implements the latest MAVLink standard and in particular the STorM32 MAVLink2 mount type (MNTx_TYPE = 83)

I am using a STorM32 gimbal controller board for my build, and I wanted to take full advantage of the features it offers. The BetaCopter build that I’m using is forked from ArduCopter 4.3.5-rc1

Just because I have it at hand and because I might be missing something due to my lack of experience (first drone ever), here are my electrical schematics

There have been significant improvements in gimbal support, potentially making Olli’s project obsolete. It’s worth looking into the recent gimbal support/changes, at the very least, since there are also significant other improvements to the codebase at large.

New Logs .

Here is what I did:

  1. Started in Stabilize Mode
  2. Moved around (I did noticed that my pitch was backwards, but I believe the roll was ok)
  3. Selected Alt Hold mode (it rised again)
  4. Switched back to Stab and landed manually

correct Logs
I’ll try it again with the latest Ardupilot build and disabling the RNGFND for now as recommended.

In that log there is no mode change.
Stability seems as bad as earlier.
I would definitely update to latest stable Arducopter firmware and disable the rangefinder since it’s readings do not match actual altitude at all.

The rangefinder is outputting a low altitude value and when you switch to an altitude controlled mode, like AltHold, Loiter, RTL or Land the desired altitude is assumed to be the current baro altitude (higher than rangefinder altitude) so the copter starts rising to make rangefinder altitude meet the desired altitude.

Enable the rangefinder later after all tuning is sorted out.

1 Like

I think you’ll have to add some dummy payload to bring the hover throttle up to a reasonable level.
The payload must be highly secure and not add to vibrations at this stage. Even if the dummy payload is only half the weight of the camera and gimbal.

1 Like

Here is my latest logs (latest Ardupilot, disabled RNGFND).

More Logs

In those logs hover throttle is still default and it’s not learning because the actual throttle is too low and motors are still bouncing off minimum output, the copter is way overpowered.
You will have to add some payload, try to get a steady hover, then examine logs to see what that throttle value is and manually set the hover thrust value.
Only then will further tuning work properly.