Kakute F7, RC7 and RC8 option boxes are greyed out

Subject says it all…latest versions of MP and the APJ file (May 3rd).

Any ideas?



Kakute F7 only has 6 outputs on the board.
Kakute F7 additional servos has some tips for how to potentially gain some more.

I think the op is referring to inputs. In Mission Planner (latest beta) on the Extended Tuning page the drop down boxes for RC7 Opt and RC8 opt are greyed out and show “Do Nothing”, even if RC7_OPTION and RC8_OPTION are set to some non-zero value manually on the Full Parameter page. I am seeing this too.


So you are saying I can actually enter a value in the full parameter list (see below) and it will work? I’m specifically looking to enable autotune. Thanks…

P.S. Question…if I use autotune as a flight mode (instead of a CH7/8 option), and then land without changing the flight mode and disarm, will the new tuning values be saved? Or do I have to use a CH7/8 option?

CH7_OPT: Channel 7 option

Select which function is performed when CH7 is above 1800 pwm

0 Do Nothing
2 Flip
3 Simple Mode
5 Save Trim
7 Save WP
9 Camera Trigger
10 RangeFinder
11 Fence
13 Super Simple Mode
14 Acro Trainer
15 Sprayer
16 Auto
17 AutoTune
18 Land
19 Gripper
21 Parachute Enable
22 Parachute Release
23 Parachute 3pos
24 Auto Mission Reset
25 AttCon Feed Forward
26 AttCon Accel Limits
27 Retract Mount
28 Relay On/Off
34 Relay2 On/Off
35 Relay3 On/Off
36 Relay4 On/Off
29 Landing Gear
30 Lost Copter Sound
31 Motor Emergency Stop
32 Motor Interlock
33 Brake
37 Throw
38 ADSB-Avoidance
39 PrecLoiter
40 Object Avoidance
41 ArmDisarm
42 SmartRTL
43 InvertedFlight
44 Winch Enable
45 WinchControl

And something else…the CH6 mix/max boxes are greyed out as well. And…I’m not seeing a place to enter those values in the full parameter list?

Yes, I just configure everything with the full parameter list and haven’t had any problems with the Kakute F7. Just be sure to click “write params” after making changes.

Regarding saving auto tune results, sorry I’ve never done that so I don’t know.

If you’re on 3.7 I believe the min/max values for tuning are TUNE_MIN and TUNE_MAX.

Thanks Anthony. Much appreciated.

Can you see whether this fixes the problem (don’t fly it - it’s just a quick build off a hacking branch which probably has unknown bugs in it): arducopter.apj (803.0 KB)
If that fixes it I’ll push a change upstream.


So you are saying flash the APJ, check the problem, and then I would reflash my current APJ to get back to flying condition?


Yes please. Save your params to a file first though. They shouldn’t get wiped, but better to be safe.



James…nope…no fix…thanks though. Also, for anyone looking at my PIDS (Eachine 250, 2-Blade 5030 props, 3S 1500mah Turnigy battery, 564gm AUW), it flies with those PIDS, but I have yet to get the tuning right