Kakute f7 Mini Problems (Or just problems w/ my build..)

I had a copter w/ an omnibus nano. I removed it an installed a kakute f7 mini w/ no other changes.

I’m having a lot of trouble with it.
It leans a lot and gets frequent EKF errors.
It also gets frequent GPS errors which it didn’t before. Some of which doesn’t appear to be valid (like after downloading parameters it will suddenly get GPS and EKF errors)
And it sometimes completely goes ‘crazy’ where the copter trace in MP is jumping around, HUD spinning, etc.

It also appears to be vibrating more… I never had higher than 10-15 in the vibe logs before with the omnibus, and now it’s going up to 30-40. It’s basically hard mounted, with rubber inserts in the holes (m3 to m2 size rubber grommets), but so was the omnibus. I have the filters tuned well, and the post filter FFT is flat. I don’t know if a bad IMU would make it appear to be vibrating more, or if it somehow really is.

My concern is the leaning, and the times where the position trace in MP is jumping around, hud spinning.
I had a flight today w/ the leaning, and then after landing it started jumping around, so I’ll upload that log.

Leaning might be hard to diagnose, because you don’t know exactly when it is happening. I had a short flight around my house and landed in my driveway to wait for GPS signal. It had already started leaning to the left while I was landing on my driveway. It does it frequently during the flight, too, but not sure if you can tell. I guess look for a consistent right roll input from my TX.
And then after landing I turned on log disarmed so you could see the copter going crazy, while in reality it’s sitting stationary on a table.

I started thinking maybe the IMU is bad in this flight controller.
I try not to ping any of the busy set of core developers here, but @rmackay9 said to post a log and he or someone could take a quick look. At least tell me if it’s a bad IMU or if I need to look for other issues.

Thanks a lot!

This sounds a bit like the issue we had with the Nano a few revisions ago with the IMU instability during flight

Something odd with that log. When I tried to extract the parameters it only shows a few lines. This is also true in the data table in the log browser screen. Perhaps a memory problem with added features? Total WAG there!

1 Like

It is exactly like the issue w/ the nano’s… Only much worse.

And at that time, and still actually, I have a couple nanos that don’t lean badly… The two I use daily. While I have 3 others that I tried to use in the same copters, and they lean quite badly. So I have been thinking this entire time it is just a hardware issue w/ the omnibus nano’s.

But now this Kakute f7 is doing the exact same thing… But more than my worst nano.

That log, the only odd thing on my end is I took a flight, landed and disarmed. Then when I noticed the trace in MP going all over the place, I quickly enabled log disarmed. So the disarmed part got appended to the already ended flight log.
Hmm, but I just looked at all my auto generated param files, and they are all the same… Only a few lines.

I can upload my parameters… be right back…

I was thinking this might be a symptom of the problem but I don’t know if they are related. The quad I had the Nano in crashed into many pieces and I haven’t re-built it.

Alright, here’s a parameter file.

Worth mentioning, last year one of the possibilities we threw around was the loop rate. And I do have my loop rate at 800 on this one. But, I tested that… I put my loop rate back to 400, and dshot down to 300, and it still did it.
I thought maybe a power supply issue, and added a big capacitor to the 5v rail.

And also, sometimes I boot this kakute f7, and right off a fresh boot, it’s leaning badly, and if I try to arm in that state, get an immediate crash/disarm.

NewCopter2020.param (20.0 KB)

There is a huge amount of noise on the X accels at high throttle. If you tried to fly this in an EKF mode I think you would crash. The AZBias also goes off the charts:

The noise is not visible on either Y or Z axis - dumb question, but are you sure that there isn’t something knocking into the side of the FC? The gyros don’t show this noise at all.


There’s not. I went through everything. Tried both tighter and looser screws holding the FC down. Checked every wire. They’re all tiny wires w/ silicone insulation, so quite flexible. Plenty of space around the wires. Plenty of space between the FC and the camera board below it.
I tested all 4 motors one at a time and logged the vibrations. One was worse than the others but new prop fixed it and the log above is post new prop. I do still have suspicions about a bad bearing that might only start vibrating at certain speeds… But I could not get it to do it on the ground with the motor test at various outputs. And like I said, this copter was flying fine a few days ago w/ an omnibus nano, so I doubt it’s a motor.

As @andyp1per says the vibration levels could be the problem. The vibe message shows vibration levels are high (but not incredibly high) but the clipping numbers are very high which means the IMU is hitting it’s limits.

Vibration levels:

I think a physical problem is the most likely but there are two other possibilities I can think of:

  1. the vibration levels are really high but we can’t see this in the logs because the INS_ACCEL_FILTER parameter has been set very low which hides this. I suspect that the notch filter could also be set so as to hide the vibration.
  2. an AP code problem which leads to the maximum range of the IMU being lower than it should be. i think this is unlikely though because we use the same driver on all the flight controllers and we would certainly notice this on the pixhawk, cube, etc.

If the vibration readings are real, then yes, that’s something I need to figure out. One motor is working slightly harder than the others and I don’t know why… and I might have heard what sounded like bearings whining. So, I guess I’ll start there.
I’ve just gone through a bunch of logs from my omnibus nano on this same frame/motors, and it never clips. Never spikes above 15. I don’t understand why there is such a huge difference. This is a copter I’ve flown almost every day for the past year. Only change is the new flight controller.

Could a faulty IMU cause erroneous readings? I’m imagining something in the MEMS flopping around more than it should w/ the normal amount of vibrations, but I don’t know if that’s actually possible.

And, the leaning issue starts before the vibrations… Like I said, that first section of the flight, it starts leaning pretty badly by the time I fly around the corner of my house and land to get GPS reception. Before line 20 in the log.
And the other issues like when I just boot up and the copter thinks it is leaning while it’s actually level.

I guess I need to figure out the vibrations before we worry about the other things, though.

thank you for taking a look.

1 Like

Thanks Andy and Dave, too.
I’ve quadruple checked the wires and mounting and all, and really don’t see anything that would cause extra vibrations. I’ll swap the motor later tonight.
And otherwise I already ordered another Kakute Mini, so that will certainly rule out an issue w/ this board.

I’ll update the thread after I’ve tried all that.

Tridge also suggested that it could be related to the INS_FAST_SAMPLING parameter being “0” but I’ve checked the parameter file listed above and it is “1” so this doesn’t appear to be the issue.

1 Like

One thing I found on my KakuteF7Mini was that the power the BEC could supply was much lower than rated. Holybro advertise 1A and privately they have said the components should go up to 1.5A, but when I tried powering my RunCam off the board all manner of strange things started happening - dshot failure for example. It would be worth checking what current draw you are getting as the omnibus is better in this regard I think.

Thanks. I am powering a vtx, but not the camera. I’ll do some testing.

Also, you might have noticed this, but it appears to have two 5v rails… The left side of the board has a couple on the bottom and one on top for the camera, and they are not connected (or at least not zero resistance) to the couple on the right side of the board, by the GPS connectors, etc. At low voltage, the GPS side cuts out first.
In general, it works pretty well on 2s… Putting a 220uf cap on the 5v video side rail lets it keep the VTX powered down to about 5.3v. W/out the cap it cut out around 5.9v.

Man, I hope you find the issue… I have 3 of this FC waiting for an assembly… :confused: I think this is a power issue, as someone said before.

I went through everything last night… Secured every antenna, better secured the GPS. Anything that could possibly wiggle was tightened completely.
It made a tiny difference, but not much. Then I started removing components to see if they were the issue. Removed VTX, removed GPS. Took the sides off my frame and had basically only the flight stack on an X frame. Same issue.
At that point the copter was mostly taken apart. So, I just unsoldered the rest, and put the old omnibus nano back on it. Took a flight. Perfectly fine.

Here are graphs from each. Hovered w/ the kakute. Held it in my hand and gave it full throttle. Then you can see it clip thousands of times. Then removed the kakute. Put the omnibus on it, and did the exact same flight. Hover, Held in hand and full throttle, hover, land.

I uploaded the wrong log which made the omnibus look a LOT better!. Heh, this is the hard mounted comparison. I guess the important thing is when I give it full throttle on the omnibus one, it barely increases the vibes. No clipping. The only time the omnibus clips is when I land hard on my floor.

This one is comparing it to a different copter w/ soft mounted omnibus nano… Kyosho gel and double sided tape. Same motors and props.

New kakute mini should arrive later this week, so I’ll try that next.

Do you have fast sampling enabled?

On both the kakute and the omnibus.

The omnibus has a MPU6000 which doesn’t support fast sampling. See if switching it off helps on the Kakute?

Oh, thanks, I hadn’t noticed the different IMU. I’ll have to put the kakute back in the copter…
Or actually, I can probably see this on a bare FC… If I tap the omnibus I’d get 1 or 2 clips. If I tap the kakute, I’d get thousands of clips as it is now.
My wife seems to think it’s cleaning day so I’m tied up w/ that for a while, but will try this later.

1 Like

Alright, re-installed the kakute.

YES, with fast sampling disabled, I get no clipping. No EKF errors. No “vibrations compensation”.

Vibes don’t look as good as the omnibus, but are manageable, and well under what they were with fast sampling enabled. I could believe the difference here is due to the different rubber grommets or some other issue w/ my build. Not crazy like it was w/ fast sampling enabled.