Kakute F7 IBUS receiver not working


I am trying to migrate my drone that used iNav to ArduCopter. I have a Kakute F7 board, and Flit10 Receiver. It uses iBus as the RC Protocol. I have tried multiple configuration but I just can’t get the FC to see RC Inputs.

I’ve tried configurations from all this page.

This is the receiver:

Could it be telemetry as well?

Is that Rx Fport capable? I assume nor so follow the standard config for this board:

The problem is that the receiver is connected to the TX pin, because I was using the following configuration:

I can bypass the telemetry module, but it would still be connected to the TX pin (the cable is soldered).

I want to know if there is any configuration that would make this work? More specifically the serial6_options

I have something like:

Hi, if you take the code in the pull request: 16545 on ardupilot.
you need to set only one thing: SerialX_options: 37 (IBus telemetry).
It is confirmed working with Flybus I6x and IA6B receiver.

for the flysky I6 and I6X there are optimized firmwares to show the telemetry. Look to the github of qba667

Thank you for the info. I understand now that the pull request for IBUS telemetry and the being able to use IBUS as an RC-Input while connected to the TX pin are different. But would you happen to know which SERIAL6_OPTIONS flag will allow my configuration to work?

What hardware are you using? (Receiver/transmitter?)

Receiver is connected to the serial 6 TX pin through the telemetry module.

FC: http://www.holybro.com/product/kakute-f7-v1-5/

Receiver: https://www.amazon.com/usmile-Telemetry-Compatible-Diversity-Quadcopter/dp/B07BTWPKXC

Transmitter: https://www.amazon.com/Flysky-FS-i6X-Transmitter-FS-iA6B-Receiver/dp/B0744DPPL8

I have used this same hardware configuration with iNav, but I was not able to get the PID tuning stable, so I decided to try ArduCopter