Servers by jDrones

Kakute F7 - can't get buzzer to work

Subject says it all. Didn’t work on 3.6 either. I’ve checked the wiring several times…also tried 3 different buzzers (all of which worked on a Pixhawk).

I do hear a very faint buzz, when, for example, changing flight modes with my ear pressed right up against the buzzer…so SOMETHING is going on.

Thanks…

Buzzer works on my KakuteF7 Mini. The voltage supply is a lot less on the Kakute than a Pixhawk, so if you are using a pizeo buzzer you will likely struggle - use a magnetic buzzer.

Andy…is this (link below) what you mean by “magnetic buzzer”?

After more research, (check me) it seems like Pixhawks use “passive” / piezoelectric buzzers (which act kinda like a speaker) that are controlled by PWM signals (and can play many tones), while the Betaflight-type boards are meant to use “active” buzzers which only use voltage (and no PWM), and only play ONE tone.

So by “magnetic” do you mean “active”?

Thanks…

I have active magnetic buzzers which still play a tune. I think AP can use either, the only thing is that the active ones appear to play a continuous tone at startup. So I’m sure those will work, how well is anyone’s guess.

OK Andy…thanks.

I bought a bag of them from Amazon…I’ll report back.

how do you have the buzzer wired?

Hey @andyp1per, I am experiencing this situation you’re mentioning above. Buzzer plays a continuous tone at startup then does the traditional Arducopter start up tone. Do you know if there’s a way to avoid that?

Not found one - but let me know if you do

It has to do w. the state of the buzzer GPIO pin while in the bootloader.

@davidbitton any suggestion?

let me see what I can figure out. I THOUGHT this was fixed in the Kakute F4 BL, but I don’t see it. it’s a bit over my pay grade, but I’ll try.

Ohhh, so the bootloader is probably also responsible for the continuous beeping

It is the bootloader; kinda, sorta, but not really. Something must set the pin low on startup, which triggers the buzzer. I need to find where that happens so the buzzer pin is set high.

Here is the fix https://github.com/ArduPilot/ardupilot/pull/14632

It would be good if this fix is applied to the Omnibus F4 Pro too, as it displays the same startup/bootloader tone …

Ok, are you able to verify for me?

Any idea if the non-Pro version will also show the behaviour?

I can solder mine up to test if so.

Can someone with this problem on a Kakute verify the fix for me if I do them a build? It works for me.

Hello I got this type of buzzer and I no longer have this problem on my kakute F7


1 Like

Andy I’ll be working on my Kakute-based frames next week…thanks for the fix.

Servers by jDrones