Kakute F7 AIO v1.3 Unflyable (Solved)

I flash Arducopter 4.0.0 and the Quad is unflyable. In motor test 3 of the 4 motors run together and 1by it self. The mapping it’s right as i think but is very weird the behavior. I can’t figure it out. Any advise about what is going on? Th2019-12-31 21-40-39.log.param (19.2 KB) at a log from a small run holded in my hands.

2019-12-31 21-40-39.bin (564.3 KB)

There’s nothing useful in this log - most outputs are flatlined. Are you sure you are uploading the right log?
For instance all RCOUT are 0, ThO is zero

I think because it’s a Motor Test log. But yea, no value to be found.

I didn’t notice that it was nothing to check in that log so i share another one.
Thank you andy1per and dkemxr

I don’t see any immediate issues with the parameters or the log but if 3 motors spin together during the motor test then that’s very bad and it won’t work.

We have another (different) report of an issue with the motor outputs here: New Kakute F7 AIO v1.5 Motor 3 does not work,

I just tested on a KakuteF7-AIO with Copter-4.0 and your parameters with a logic analyser and motor test. It all worked fine.
I suspect you have ground issues. Are your ESC grounds properly connected to the board?

Hi tridge, in my case I made sure that the ground are correctly connected from the FC to the ESC.

do the motors work correctly with any previous ArduPilot firmware? If so, what version and can you send a log showing it working with another version?
The logic analyser test I did does show that it is working correctly, and the symptom of multiple motors starting is a classic sign of ground issues, so I really think that is very likely to be the cause.

1 Like

The first version it was the 4.0.0 rc2 and now the official. It is very helpful you test it in a kakute aio with my parameters and work fine. So now I need to check the grounding. I will inform you soon. Thank you tridge and rmackay9. I very much appreciate!!!

So,after soldering and unsoldering again and again finaly the Kakute start to behave properly. tridge has right about groung issues. Very tricky to found the couse. Thank you again tridge!!!


Great news that it’s working! Txs for the followup

Thank you rmackay9!!!