Kakute f7 AIO and arducopter 3.6

Has anyone made LED pin work? Looks like ArduCopted supports WS leds now, I was wondering if it’s possible to hook one up to LED pin.

can anybody please guide me to connect a LED to F7.

You can enable the LED pin the hwdef.

I put them in for a octocopter build, should work for WS leds also. Note that the only way to use WS leds is via scripting currently and the KakuteF7 does not have enough flash for scripting.

Thank You sir.

Doesn’t it work like a standard LED on Pixhawk by default?

I think that is the idea but your results might vary, its still very new,

Probably strange question, but… Is there much difference in having 2Mb flash vs 1Mb?
It looks like STM32F745VG processor on Kakute F7 board is fully pin-compatible with STM32F765VI at the first glance and I was wondering it it’s worth it trying to desolder original processor and solder another one. Obviously definitions would need to be changed, but it should not be much, should it?


You can see : https://q.com/flash-ardupilot-kakute-f4-f7-fc/

I use this how to the first time. After you can use MP


There are some features that currently are not supported with 1MB. LUA scripting is one.

I have Holybro Kopis 2 v1 (according to the label) which has TX from the receiver to RX Serial Port #4, unlike later versions of Kopis you refered to that have SBUS on Port #6. Betaflight came installed and Inav was also installed with no issues. Arducopter however will not recognize the radio on Serial Port 4 is there program changes that need to be made for arducopter to recognize the radio or does the TX jumper need to be moved to port 6.

1 Like

Hello @Paul_Atkin1,

I have just flashed successfully the Arducopter 4.0.3 for Kakute F7 mini, also could connected it with Betaflight but I can not do with Mission Planner. I also change some value of the baudrates but it does not work! Could you or anyone experience this before?

Does it connect with QGroundControl? If so update Mission Planner to latest Beta.

I thought there just was an error on the firmware downloaded. When I repeated the same steps, it works like a champ!

Fellow flyers of the Kakute F7!
I have been tinkering around with this board for about a year now. I have a taranis 9D Plus and I run the R9M 900MHZ Long Range setup.
I can get telemetry through Yaapu and through the 3 wire setup now. LED pin only works with Betaflight at this point. I have tried and tried in Mission Planner. There is a Pixhawk or Pixfalcon I2C breakout board and a LED board you can get and hook up through that and it will work with the SDA /SCL pads / pins depending on if you have the AIO or not.

Telemetry settings were tricky, but the S Port cable connects to T6 next to the back 5v and the back ground pins.
Alt Brd Config needs to be set to 1 which can be done when you install the dev firmware on your Kakute F7.
Serial 6
Option 7
Protocol 23
Baud 57
Let me know if this helps.

set servo5 as option 121 nft set your lens count to the quantity of leds set your led type to NEOpixel connect your input wire to M5 on your FC, + to 5v - tG and buz to neg buz terminal. reboot you should get tones and leds

I wish to go back to Betaflight. On 2 boards. Both boards will go into DFU and it will accept firmware. Unfortunately when then applying 16v power and trying to use the board the green LED barely lights and the blue activity LED doesn’t light. But if I apply power through USB it’s fine.

I’ve tried different cables, firmware loaders (Emu and Inav), 4 in 1 ESC’s and 2 computers to no joy. Is there a way to clear the board to remove any remnants of Ardupilot that may be stopping me?

Ardu is good on bigger copters but on small racers it’s not for me.

My boards are the Kakute F7 AIO V1.5 and the Kakute F7 mini V2.

Hello Guys.

Im working on with my board Kakute F7 AIO V1.5 and I’m wondering if someone was able to run some range finder sensors ? Like lidar / optical flow or ultrasonic.
I’ve seen info about board limitation but not sure if they are not working in 100% or there is some way to make them work Im thinking about arducopter 4.1 ?


@Solid open a new thread, and try our custom.ardupilot.org server.

Thanks for feedback. I will do that.
About custom.arupilot.org , is there any guidance how to use it ? I mean which of those modules are mandatory to be used, and which optional ?

Open a new thread. And you will get answers