Servers by jDrones

Kakute f7 AIO and arducopter 3.6

Hi all
Currently I use pixhawk and mro piercer for my tarot t960 and tarot 650.
I plan to build small quad (150 mm) and I want to use kakute f7 aio as fc.
Can anyone know how to load arducopter firmware to kakute f7 ?
Can I use MP or another tool?
Regards

there is a ton of info about it here:

i built a model that works and flies well. you need most recent dev build to make it work - a bug to support SD card on F745 is not in the last RC yet.

make sure you understand that a flash into arducopter may not be easily reversible. i interacted with holibro on this - they say some boards were ‘affected’ and top of the thread shows how to flash it back manually with a special tool.

you need first to get a arducopter_with_bl.hex file from here:
http://firmware.ardupilot.org/Copter/latest/KakuteF7/

and flash it into the kakute with the betaflight tool. MAKE SURE! to flash a file having ‘with-bl’ in it!!!
as if you flash in without ardupilot`s boot loader - it will require reflash back to betaflight to do any other flash and depending of board version it may be tricky - as some boards after that flash lose an ability to get into DFU upon pressing the flash button.

then you can get your fork of the code from latest master and deal with hwdef file in there to make custom kakute builds. latest build above will probably still be based not on my adjusted hwdef that has all 6 motors and 6 uarts with buzzer working, but should be operational enough.

my hwdefs for kakute F7 and F7 AIO will be there - https://github.com/utkinpol/ardupilot. good luck.

also, for small quad params may be a challenge - you can use this as a starting point, as default params will end up with severe oscillations on a small quad.
https://drive.google.com/file/d/1hcPm_uvaDlCNY2b69ornsG1-zk6-EAlq/view?usp=sharing

also, mount it on rubber bobbins or foam. having gyro on thin foam helps a ton, but, not 100%.

also, for complete reference - use this:
https://drive.google.com/file/d/14UwTmoE1t85-pEunnwae-qpA3l6awPMY/view?usp=sharing

Hi Paul
Many thx. I will try with latest rc7.
regards

Hi Paul,

I have a Kakute F7 and flashed it with Ardupilot but now need to revert to Betaflight. As you stated, it’s not a simple task. Please advise where I can download the ‘special tool’ mentioned in your post to hopefully flash the Kakute F7 from Ardupilot back to Betaflight. Many thanks.

hi, try to trace this thread from the top - there is something in there about the process. search for @Huibean posts.

also, newer current kakute f7 aio boards to flash back fine as holibro fixed something in the design and it goes back into the DFU mode even with a ardupilot bootloader flashed into it.

I just purchased a Kakute F7 and although will test it with Betaflight first I want to eventually try loading Arducopter. My question is regarding the motor numbering as they are different between the 2 softwares.

Betaflight

  1. Back right CW
  2. Front right CCW
  3. Back left CCW
  4. Front left CW

Arducopter

  1. Front right CCW
  2. Back Left CCW
  3. Front left CW
  4. Back right CW

If I wire the connections from the FC to the ESCs using the Betaflight mapping will I have to redo the connection for Arducopter or is there a way to change it in the configuration ?

You can change it in the configuration.

Thanks @wicked1and so if I run the motor wires following the betaflight mapping I believe that I will need to make the following changes when I move to Arducopter.

SERVO1_FUNCTION change from 33 to 36
SERVO2_FUNCTION change from 34 to 33
SERVO3_FUNCTION change from 35 to 34
SERVO4_FUNCITON change from 36 to 35

http://ardupilot.org/copter/docs/common-rcoutput-mapping.html

There’s an easy ‘initial setup’ page for it in MP now. You simply select the servo number, and then there’s a drop down box to choose which motor is connected. But otherwise, yes, you could make those changes in the full parameter list, too.
It works great! I’ve had to use it a few times now while trying different 4in1 ESC’s, which all have a different layout.

After testing a Kakute F7 board (not the AIO version) works with Betaflight I went ahead and installed ArduCopter 3.7-dev. I then saw issues reported with moving back to Betaflight and although I want to stay with ArduCopter I gave it a try and sure enough it failed to enter DFU mode and so I can’t flash the firmware. I don’t want to go back to Betaflight but won’t this issue also stop me from flashing a later version of the ArduCopter firmware ?

to be very specific - a new version of AIO board should let you to flash .hex file with betaflight - to get into arducopter. then, if you press DFU button it WILL go to DFU and you can flash betaflight again. and vice versa, as many times as needed.

i suspect if you do this - if you flash first the .hex file and THEN go to MP software and flash .apj file from it - after that you get to the point of no return.

the symptom of the old board - if you press DFU button - there is no device in windows at all that would appear. like you did not connect anything. there is still a way to recover from it - search the beginning of the thread here: https://gitter.im/ArduPilot/ChibiOS
at almost very top, 3-5 months ago. there was a reference to instructions of what hardware needed and how to do it.

Thanks Paul, I believe that although I just recently purchased this Kakute F7 (non AIO, marked V1.2) board that it must be one without the fix from Holybro as when I plug in the USB with the DFU button depressed I don’t see any window’s device appearing.I have only flashed the ArduCopter hex file using the Betaflight configurator and not attempted to flash with MP.

I traced that gitter thread as you suggested and see that a ST-LINK V2 STM8/32 programmer/simulator is needed to correct this problem and involves some delicate soldering of wires to the board. As previously mentioned I want to stay with ArduCopter and have no need to revert back to Betaflight but my main concern was updating the ArduCopter firmware when later versions become available.

Can I now update the Ardupilot firmware from now on using MP even thoughI can’t revert back to BetaFlight or do I need to get DFU mode working to also update to later ArduCopter versions?

Yrs you can flash .apj file from MP if you flashed correct hex file _withbl.hex. use latest build from master.

I just bought f7 fc as well and i was able so far to flash it back to betaflight.

I did flash with the latest _withbl.hex file so sounds like I will be ok as long as I stay with ArduCopter. Is the F7 board you just purchased also a non AIO Kakute and if so does it have any version numbering?. Mine is marked V1.2

I do not think it had any version. It was from getfpv.com - a stack combo "“Holybro Kakute F7 - Tekko32 BLHeli32 4-in-1 ESC - Atlatl HV V2 Stack”

I had an AIO board sent to me by holibro and it also flashed back and forth until i fladhed it from mp a million times. Not sure why it would ruin it. But it did. As i also do not need betaflight on it - i do not care. This new F7 i will only flash with .hex to preserve switchability.

@Spitfire apologies if I’m telling you something you know already, but you need a different set of drivers for DFU to allow you to flash back to Betaflight - the Zadig ones worked fine for me. Is that possibly the issue?

(Mines an AIO, so not quite identical , I admit)

Thanks @jon_hfd, I tried that but I don’t see the STM BOOTLOADER listed in Zadig after connecting it to the PC with the button pressed. Also the green LED is on solid and the blue LED is off.

@Spitfire I’ve got to admit, mine wasn’t pain free. I had to delete the hidden devices and re-install the STM drivers before they showed up in Zadig. I’ve just checked now in Betaflight, and for some reason it doesn’t look like DFU is working - although not 100% sure, as I don’t actually want to re-flash at the minute, but when I plug in with button pushed it’s coming up with an error message of USB device not recognised.

hmm. ok.

first you need to flash arducopter in. for that you need to install betaflight utility first and learn how to flash betaflight.

then you go and get the latest compilation of the arducopter from this link - you get a file named ‘http://firmware.ardupilot.org/Copter/latest/KakuteF7/arducopter_with_bl.hex
from
http://firmware.ardupilot.org/Copter/latest/KakuteF7/

then you go into betaflight and flash this file as a custom firmware.

then you go to the arducopter faq and study that:
http://ardupilot.org/copter/docs/common-optional-hardware.html

also you look at the kakute f7 betaflight instructions on how to connect it. use RCIN soldered to R6. GPS can go to any other UART - 1, 2, 3, 4. 3 is fine. t3/r3 are serial3. set it in arducopter options per faq.

this is my working config: owl10_17.param (18.6 KB)

Thanks for the fast respond.

I am able to acces it from ardupilot, but the GPS doen’t work with your config too. And I am a bit confused were I solder the compass to

Servers by jDrones