Kakute F4 with 7" freestyle / long range frame

I assembled and tuned 7" LR copter:
kakute F4 AIO
external M8N gps and compass mounted about 1.5" from FC/PDB
spedix 30A blheli S
2206 motors 1700 kv
7x3 props, 3 blade
4s 6000 mah (or 3000 mah)
850g (or 650g) TOW
hover current: 8.5A (or 6A)

Used autotune (0.075 aggr) and tuning process from arducopter pages, flies mostly Ok. Problems:

  1. Flies mostly Ok, but once in a while enters into oscillations, probably dominated by yaw movement, starts to draw high currents and becomes very difficult to control and land. After landing it has “bad compass health” message and does not rearm, needs reboot.
  2. Autotune produces high accel limits, ~220000 for RP, and 100000-200000 for yaw. Is that normal?
  3. Kakute F4 FC does not have SD card, so I don’t have flight log. Any way to get around this?
  4. Yaw acro expo (ACRO_Y_EXPO) parameter is integer and rounds to 0 or 1 once I write it. So no yaw expo really available.

Thank in advance for any feedback

Can you post your settings?

For some reason ATC_ACCEL_Y_MAX from autotune comes out same as ATC_ACCEL_P_MAX, suspicious

07_28_2019_60hzTuned_aggr0075.param (20.3 KB)

What flight mode are your oscillations in? I would be tempted to raise ATC_RAT_PIT_FILT, ATC_RAT_RLL_FILT and INS_GYRO_FILT all to 80 - I think these smaller copters generally need more control bandwidth.

Also try and figure out which axis is causing the oscillation

High accel limits are fine on smaller copters

Thank you for your reply.
Copter oscillated in loiter and acro modes, not sure about other modes since I didn’t use them much. I set frequency filter according to this page:
It instructs to set INS_GYRO_FILTER = 80 for 5" and = 40 for 10", I have 7", so I set it to 60Hz. ATC_RAT_PIT_FILT ATC_RAT_RLL_FILT should be INS_GYRO_FILTER/2 according to the page. Also keep in mind that my hover/cruise prop speed is ~6000-7000 RPM (100-120hz), I thought INS filter hz should be kept away and below prop speed. At some point I tried 80hz INS_GYRO_FILTER, and it would also be prone to oscillations. Interestingly when it happened last time is acro mode, oscillations would manifest at lower throttle when I tried to descend and go away at cruise throttle. Most flights do not have any oscillations no matter what I do, but once they start, they normally tend to stay there. It seems that they start around yaw axis. I also tried t lower yaw accel limits from autotuned from 200000 to 100000 with no conclusive improvement. I suspect that autotune erroneously saves pitch accel limit into yaw, I will try to tune yaw in separate autotuning session.

Yeah but your MOT_THST_HOVER of 0.1562973 leads me to believe this is a pretty powerful copter where the extra control bandwidth may be necessary to keep things steady. In general I think the more power/weight you have the more headroom the attitude controllers need to correct otherwise errors can magnify much more quickly than they would on lower powered copters with more mass.
Also I am surprised at how much lower your roll and pitch P values are compared to yaw.

Ok, I will try to increase filter hz. Did you suggest to set both INS and ATC filters to 80 hz? Do you think suggested by the tuning guide ATC_* = INS_*/2 relation is not a hard rule?
Can you give more explanation about “more headroom the attitude controllers need”? What does it mean in terms of settings or tuning?
Yes, I agree, it is slightly overpowered. I thought about going to 3S, but it will reduce available battery WH the way I build them, and since it is long range build it is last resort. Also I have 2.7 kg 650 copter with pixhawk that has hover throttle at ~0.18, and it never had any problems of this kind.
Thank you for your advise