Jitter on racer

I put a Pixhawk on a eachine racer, 5" props and 11" prop to prop on the diagonal. It weighs about 900 gm with a minimum config (3300 3S Lipo).

With all the preliminary config it’s antsy but flyable but has a small jitter in roll/pitch. I’d say like 5 Hz.I can hear the jitter in the motors and barely see it visually, but overall it feels “touchy”.
P & I on roll and pitch are around 0.15. I’m thinking of lowering that to about 0.13. I have a binary log get it here… WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free (We Transfer)

Look at those outputs oscillate!

Drop the Rate P&I values to .07
And these are way off:
PSC_ACCZ_I,1.5 (make it 0.50)
PSC_ACCZ_P,0.75 (make it 0.25)

This looks too high also:
MOT_SPIN_MIN,0.15 read the Wiki for setting motor ranges.

1 Like

Start with these, they wont be perfect but should be flyable


You can copy/paste those into a text file (notepad) and save as a .param file then load them all at once via the MissionPlanner full parameter list - there’s a “load from file” button.

Do a flight with just hover in AltHold and some movements just to test pitch and roll. Then we can check and adjust that Harmonic Notch Filter.

1 Like

Ah cool. The load param only changes the information listed in the file. Good to know. Hadn’t ever tried that Thanks.

I change those plus the P & I gains mentioned?

Shawn has those covered. His values should be a good.

Dave beat me to it, but he’s right of course.
Although you can use my complete list (it’s near enough to Daves suggestions) and use his


actually - what battery do you have? Is it 3 cell LiPo?

Are your ESCs capable of DSHOT (BLHELI32) ?

1 Like

As you advance graphing the RCOuts can be very useful. Although I suspect they will be good after setting the parameters suggested. You want them to look something like this at Hover (tuning a 5" today as it happens):

1 Like

Yes a 3S 3300 mAH.
Not sure about the ESCs. I flew this drone about 3 yrs ago and I can’t find any docs on it anymore. Eachine changes their models every month or so LOL.
The ESCs are circular, built into the motor mounts, No markings I can find.

It’s dark outside now, Will try out the params tomorrow! I’m on EDT but in Chile. (Winter here)

I was just checking on those ESCs in case you can switch to using DSHOT, but it doesnt sound like you could.

For the battery related settings, use these:

BATT_FS_LOW_ACT,2  //  or 3

If they give you any trouble, dont change them, but check your voltage monitor calibration.
It’s good that you are already using the sag-compensated voltage.

Shoot, wanted to test today but couldn’t get the GPS to give me home. In the the short flight of the log file above (from the last flight), my GPS was taking a long time to let me arm. There were a number of errors. Don’t know if there’s enough in the log to give hints as to what is wrong! In that one it never went blow 1.5 HDOP. nor more than 6 satelites.

It’s a small drone so everything is all in one place. The 4 outputs of the Pixhawk channels pass just in front to the GPS,That’s probably the closest of any signal. The GPS is 1.6" above the PD board which I don’t think really has any electronics. All ESCs ar under the motors which are all at least 4" away. Power is supplied by the Power Module through the Pixhawk!

Here’s a log (pre-arm) from today. The GPS GCrs signal looks terrible. I can’t get below 1 HDOP I get at least 6 satellites

It wasn’t fantastic the last day of flight, but at least allowed me to arm. Since then nothing. I don’t see anything in the changed parameters that should prevent arming… but it’s like night and day.

Pre arm

What did you base those Arming check changes on?
What actual version of Pixhawk is this?

I’m using 4.3.7. It’s been over 4 yrs since I’ve played with this stuff, so to tell you the truth I dn’t remember how it calculates “Home”. For the moment, HDOP of 2 min is set and min 6 sattelites. I see a good position on the map, but HDOP struggles with bettering 2.

I have the fence set to “Reasonable limits. 300m radius and 150m altitude” If I block the fence requirement it arms much more easily.

I see that, asking about the Pixhawk Flight Controller.
You simply don’t have good position. What GPS module is it?

It’s the 3DR GPS module. I’ve used them before quite a bit without much problem, not sure if the parameters are more demanding now on the Pixhawk firmware or if it’s just my physical set up. I’m going to set it up on a pedistal. It’s a small drone so a pedistal might get it further away from interference.

That’s probably an out of date NEO-7 module. If so replace it with an M8 or an M10.

BTW-Setting this lower doesn’t help. GPS_HDOP_GOOD,200
It might say you have a 3D fix on the Hud sooner but the positional data will still be bad. The 3D fix message actually doesn’t tell you very much. Seeing this is what’s important:
Do you gave Telemetry on your Transmitter?

Yeah, I set it a 2 temporarily to try to get it in the air to test my latest tuning parameters. If it fails I shouldn’t be more than a meter or so from the ground.

Unfortunately I don’t have telemetry, the drone is quite small. I could try.

I’ve got about 6 of these GPSs from before, ordering an M10 ugh!

I meant RC base telemetry. What RC System do you have?

I’ve got a Taranus with Dragonlink… Unfortunately I have to send my Dragonlink in for a modification, So for now I have to use my Futaba without any telemetry!

Are there M8 or M10 modules “Plug and Play” for pixhawk or do I have to make the cables? If there are where can I get them? I’m live in Chile. LOL, I can’t just go “into town” to pick one up.

There are some M8N modules with those cables. A Google search for “pixhawk m8n” shows them. I think not for M10 Modules.