It does not finish making autotune pixhawk 2.1

I’m doing autotune to a 600mm quad.
Pixhawk 2.1 cube.
Tmotor MN4006-23 380Kv.
Helices 15.5
It does not finish doing the autotune in 23 minutes of flight.
They can tell me what I’m doing wrong.
It will be by vibrations.
Here I leave the flight log
Thank you and sorry for my bad imgles.

No flight log but for a first autotune I do them individually.Roll first,then pitch,then yaw.Once it’s done one full tune a three way autotune should finish in a few minutes.I think my third or fourth autotune took around 6-7 minutes.

I already uploaded the log.
I have also tried to do one by one the autotune.
But same result.

The logs weren’t showing earlier.

Although it says autotune is engaged as a flight mode nothing actually happens.Most of the time that is because the throttle is not exactly centred.Your throttle was just above 50%.Whether it’s enough to stop it engaging I can’t say.Dead zones etc will have an effect.

The autotune starts doing it.
It seems as if it started and stopped in an infinite loop.
Hopefully someone who understands more than I see something in the log.
Thank you very much for your help.

It says it went into autotune but it didn’t actually do anything.Here’s a graph of your roll and pitch against my roll and pitch during an autotune.

In the third part of my graph it was actually autotuning yaw but I left that out for scale purposes.

I think you were maybe 1 or 2 PWM points over dead centre on the throttle (including dead zone) so it wouldn’t engage.

So you didn’t see it do any of this.This is what autotune looks like.

Make a movement in roll and then a correction in yaw to position towards the wind, this repeated in a loop.

Be like this for 23 minutes.

That’s wrong.Try again with the throttle exactly centred.This is from your log showing your throttle was outside the dead zone ( +/- 15 ) so autotune would not trigger.Your’s was at +30.

What is the parameter to increase the zero zone of the accelerator.
I think it will be the best solution until I discover why my accelerator is not centered.

Hola Juanjo,

Are you sure you deselect yaw and pitch in parameter list, set alt-hold as the flight mode for autotune in order to make only roll axis? And you say this takes more than 20 minutes!!! There is something we are missing here

RC3_DZ, 30.

I just noticed - do you have a sprung centred throttle ? If no then you need to redo the radio calibration and lower the throttle all the way for the final write.The throttle trim should be very close to the lowest throttle figure (1101) not at the mid point (1506).Also check that you have no trim applied on the radio itself.

RC3_MIN, 1101
RC3_TRIM, 1506
RC3_MAX, 1980
RC3_DZ, 30

Did you mount your PH 2.1 on a vibe plate by chance?

I do not understand the question.
Sorry for my bad English.
It means if I mount pixhawk 2.1 on anti-vibration platform?
If mounted on an anti-vibration platform.
Why do you ask that?
Many vibrations in the log

Today I did the auto-adjustment and the problem was the station.
But very bad result autotune.
In pich 0.18 and roll 0.03.
I put manually rolls at 0.18 to make it stable.
After flying in loitering with 18 satellites and 0.7 hdop hera very unstable.
I do not know what to do.

The vibrations are fine.Well within limits.

More autotunes.It should get better and better.I don’t know why you had a bad value saved.A log of the new flight would help.

I suffered the same autotune problem where it wouldn’t finish or give bad results, it was due to a vibration plate I mounted the autopilot to.

My Vibrations were perfect as well no vibe issue. It had something to do with the additional vibration isolation.