Issue regarding bendy ruler

I am using a millimeter wave radar for forward object detection and it is working fine for object detection in manual mode where it stops when it detects an object in the front.

My intent for the project is for the drone to be able to detect and avoid obstacles in autonomous mode. I found out about bendy ruler. But when I check my parameter list I can’t seem to find OA_ parameters.

I am using a pixhawk and copter4.0.2

How do I work with OA_Parameters

Thanks in advance

If the guide here: isn’t working for you, you may need to update your GCS software to the latest version. Also make sure you don’t have the 1MB bug on your Pixhawk (ie you need Pixhawk1 firmware, not Pixhawk1_1M).

PFA my .param file for your reference

pl.param (17.3 KB)

How do I check if my pixhawk has 1MB problem?

Long story short, if you have enabled oa_type: 1 and after rebooting you can’t see the rest oa_** params, while you have installed the latest firmware,
Then you have the aforementioned problem.

well my problem is I cant see OA_type in the parameters list to start with.

Make a last effort by uploading beta latest firmware from MP, then check your params for OA_type.
If it’s not there, then your FC doesn’t have room for it

thank you so much I will check. but just one question, how do i find if my pixhawk has one of the older revs of cpu

Which Pixhawk do you have? You can easily check available memory with QGroundControl on the firmware tab as per the attached.

Note: This check in QGC may not be definitive. Checking on this… It’s not actually. I confirmed that a Pixhawk with the 1Mb bug shows as having 2Mb flash in QGC. What’s shown below is incorrect.


thank you very much dave.

so my board says Flash size: 2080768. I installed copter V 4.0.2 stable and still cant find OA_type parameter in my parameter list.

Ok, now that we ruled out that.
Do you have prx_ enabled?. Iam asking because I haven’t used your kind of sensor before. Maybe that’s need to be enabled first, before oa_ works

There would be an OA_TYPE parameter regardless of whether the prx_enabled is active.

In the Mission Planners messages screen it shows as fmuv2 right? This is why. I have a Pixhawk that is identified as fmuv2 when default loading firmware. I’m sure it does not have the bug so I force load fmuv3 from the “all options” menu and things seem to work fine. This topic came up a few weeks back and it was advised to use Pixhawk1 instead of fmuv3. Pixhawk1 includes fmuv3 plus a few other options in the hwdef.

I have another older PIxhawk and if I try this approach it produce odd errors (from pre-arm-System check I believe) and randomly disconnects from USB. This unit must have the 1Mb bug.

I’m going to edit my post above because QGC reports this one also has 2Mb so maybe this check is not definitive. I have inquired in the QGC thread.

I could not find in the parameter list. My parameter file is attached in this thread above

Right. What does it show here in the messages screen?


fmuv2 00500031 33355110 35303335

Right, so this is fmuv2. It’s defined as having 1Mb flash and HAL_MINIMIZE_FEATURES.


If you believe your Pixhawk has 2Mb flash then you can load the Pixhawk1 version and all will be well. But I corrected my post above because QGC apparently is not reporting this accurately.

I tried loading the firmware from ardupilot website but could not download it nor could i upload it onto my FC

You can either download the Pixhawk1.apj file and use load custom firmware or use the All Options menu in Mission Planner as per the attached image.