Servers by jDrones

Is my pixhawk faulty?

The pixhawk arms ok but the motors beep when I increase the throttle but won’t run, yet they run ok when connected direct to the receiver. I have the pixhawk powered by a power module with the bec’s wire removed from motor plugs. I have reset the esc’s.
I have the motors setup for skid steer, throttle left on pin 1 and throttle right on pin 3. I have it set to 2 paddles. Rover version is 3.5.2.
I am going nuts over this problem, any help would be appreciated.

I am also getting bad logging error

Beeping motors indicate there is no signal being recognised by the ESC.
Have you pressed the hardware arming switch?
Do the ESC lines have the earth and signal connected?

Yes I pressed the arming switch and armed using the arm/disarm tab from the hud that works fine.
I have also changed the SD card and the bad logging error has gone.
To test the motors I set the servo1 to ground control and servo3 to throttle and changed pilot _steer to 0 and can run the motors OK one at a time on channel 3, so there is nothing wrong with the esc’s and motors.
Just wondering now if Pilot_Steer_Type should be set to 0? with servo1 set to throttle left and servo3 set to throttle right, I am about to try it.
This did not make any difference.

PILOT_STEER_TYPE set to zero, the most common configuration, will provide steer and throttle inputs on RC chan1 and RC chan 3 respectively with default mapping. Set your transmitter up as you like to do this. Did you run the Motor Test function in Mission Planner? “Test motor C” should cause the left wheel to run forward, “Test motor D” should cause the right wheel to run forward if it’s configured correctly.

I have PILOT_STEER_TYPE set to zero.
When I do a Motor Test on the left C and right D motors, they both still beep and the pixhawk light flashes fast red, blue, and green. I don’t know what this means, I can’t find any reference for it.

I have the left stick controlling the throttle (up and down) and the right stick controlling the direction ( left and right). The green bars in servo outputs indicate that it is correct.
When I push the left stick (throttle) up both ch1 and ch3 go up and when I push the right stick left or right the green bars go up on one of the channels and down on the other. so that is working how I would expect.

I have managed to get the motors to run.
After arming the pixhawk I have to move the aileron stick to the extreme right and then to the extreme left and the motors run. I have reduced the trim on both servo1 and servo3 to 1150 from 1500 and the motors ran as expected. The one problem I see is that when I disarm, the motors still run, is there another setting I need to adjust?

Thank you for your help.
I have got it sorted and the motors running as they should.
Now just got to get it to run straight while in auto mode.

Servers by jDrones