IRlock and TFmini+, problem with bad lidar health

Building a test rig with Cube, IRlock and TF mini + in order to test precision landing and simple altitute control with lidar and i seem to be having a problem.
Since i am using both my telemetry ports for other functions i decided to go with Serial 4(GPS2) to have my TFmini+ but i keep getting a bad lidar health message.
i have checked the GUI and send the command to have the TFmini+ on Pix mode but for some reasson it still does not work. Setup if as per wiki concerning all other parameters.
I even tested on telemetry2 and still have the same issue.
Also noticed that when i send commands on the GUI i dont get any response, but i do get readings.
My second TFmini on my other frame (and Pixracer) seems to be working just fine straight out of the box.
Any ideas?

TFMini+ cannot work in Ardupilot on Serial connection at the moment. Only on I2C port.

When did that change.
I have always used it on a serial port. But I confess I am in the process of a new build with the TF Mini and latest Arducopter…so perhaps something has changed.


TFmini or TFMiniPlus?
First working on Serial, second on i2c only in Ardupilot

TfMini…is what I am using.

On my other copter and also on a rover i decided to start testing with,it worked on both with the serial provided connection.
My problem with i2c is that the moment i connect, i cant see measurements as also my IR lock stops working. seems there is a conflict, but i cant find info on how to set different address to IR lock, only on TFmini and no matter what i tried i get the same results.

Update. (@Benewake1)
It seems the particular Tfmini+ even though it worked and seems to be programmed on the benewake GUI, when on the Copter it does not work and gives me the bad lidar info. Most likely it has something to do with the already given commands that i cant seem to correct, not even with a new firmware.
For this reason i took the one installed in the rover and by simply plugging it into the GPS2 port serial, it worked instantly.
I have emailed Benewake to help me reset and find out what was the problem.
Thank you all for you input and be sure that TFmini+ also works over serial on copter.