Iris+ seem to have changed his controls since updates

I tried everything , I’m depressed.

Bought a Iris+ drone in the end of year 2014 .

My drone isn’t acting like it was when props off in 2015. When I bought it , it was graduating correctly the throttle even in LTR mode if no props. Now , it’s like a three speed inconsistant thing. Only stabilize mode seems to act pretty normal without props and in the past , it wasn’t like this. I got no major errors when trying to arm but … I don’t feel it safe. Sometimes it seems to stutter un LTR mode … stuttter between a " lift off " and not . It’s jerky.

The thing is that arducopter changed so much I have the impression it is no more compatible with my Iris+ . It has a Iris+ ac34 profile , I’ve done all calibrations and it shows correct . Compass without error , good frame … everything like I’ve always done.

How can I know it won’T go away when liftoff ? Stabilize mode seems well graduated in throttle but I’m no sure as I never used it . All I know is my loiter seems very strange compared to before when no props and I’m afraid to loose it.

Is it possible that in the past , Arducopter was turning the commands in mode STD when it detected no props and that now , it is simply not accelerating in a smooth way until it detects the drone is climbing ? I’m pretty sure ltr mode was smooth on the throttle even without props. Not it’s acting crazy . Every mode depending on GPS seems to act very strange . Some are talking about the fact it would be normal cause these modes are cord-like modes … relying on telemetry to detect movement . As the drone doesn’t feel air resistance , it would simply not act normally ?

Even my ESC test is smooth and seems perfect while doing ESC calibration but … I feel it’s not acting normal in GPS modes . How can I test with minimum risks ? Can I juste … use ropes to retain the legs in case it does try to fly away ? I don’t feel confortable with that . … there is a risk the rope gets into props with air succion. I’m just stucked. Would like to have a room made in marshmallow but I’m in appartment .

3dr has wiped their Youtube channel very very usefull in the past and is deleting all infos on the product . I hate this company. There is no video showing how each mode would react without props and why … if it is normal as some says. I don’t feel it normal . Is it just a new way to fly ? Like in LTR , motors are not smooth when you pull up the throttle until it lift off ? It just lift off without graduating throttle … like from slow to medium ? Why my ESC test is perfectly smooth and only stabilize mode seems to act normally then ?

I don’t feel it is normal. I tried to roll back to arducopter firmware 3.2.1 ( the original that I had ) but again , the proposed settings for iris+ is for AC34 in mission planner ( not AC32 ). … so what can I do to test it like it was when I bought it ? When I try older versions of Mission Planner , the profile box is not clickable so I can’t load Iris+ AC32 profile , there isn’t any profile showing.

This drone and this company is a bunch of problems and they give no cues. … like they just want to make money.

I’m totally unable to find all files from stock version and test it with the same software I had in 2015…

I was flying a couple of times with that during a year without problems and then … it changed like this. I’d have error messages if it wouldn’t be ok and my prearms check are set to ALL .I don’t understand why it changed like this . Is this a motor issue ? They are used but turning equally and are smoothly graduating in ESC test . I don’t feel like it’s a problem.

Help please . If you got a cue .

I have an IRIS copter and I am running as well as several other people here are running the current version of the firmware. While I admit the way the copter starts up and the way mid throttle works is different then the version you started with once the unit gets in the air it flies normal.

You can’t test the unit with no props on the ground in the different modes. This confuses the IRIS because it wants to control the aircraft and you have tied its hands. The only way to test it is with props on and in the wild.

One of the things I don’t like about the IRIS+ is that they hide the Stabilize mode which is necessary when testing and gaining control of the copter when it is out of control. Testing in Position Hold is not safe.

I like my IRIS copter and has been a great investment.