"invalid comport or in use" problem


I’ve a problem connecting with the telemetry on Mission planner.
I’ve got it working on APMPlanner so I think my device is well configured on a Com3 port.
I’ve tried to have the same settings of the telemetry rates:

But I’ve always have an invalid comport when in “Sik radio” I load the settings:

and when I try to connect to the board, I have this message:

Thanks for your help.

What baudrate are you trying to use? The sik radios are normally set for 57.6 baud.

yes I’m using 57.6 baud and I’ve got it working on APMPlanner. But impossible on Mission Planner.

I assure you it does work in Mission Planner. How are you determining what com port to use?

I’m sure it can work but I can’t figure out why it doesn’t do right now on mine.
I’m using com port 3, which was automaticly set when I plugged the “antena”. But I’ve tried others such as the 10.
I’ve just tried again with APM and that’s ok but not Mission planner.
Could that be the settings in Config / planner / telemetry rates.
What do you think they should be?

First plug in the SIk radio and open mission planner and write down all the com ports that are listed. Then remove the sik radio from USB and then see what port disappears from the Mission Planner list. That one that disappears when the SIK radio is unplugged is the correct com port.

I appear to be having the same issue with my pixhawk and radio system. Did you ever find out what the problem was?

I actually have this same error in MissionPlanner with Sik radio on newer computers. My old laptop is fine, but I have a MS Surface PRO and another high powered laptop that can’t connect in MissionPlanner due to this max baud rate message. The kicker is that QGroundControl connects with no issues, so I know I have good drivers for the Sik radio, and I know I have the correct COM port and baud rate settings. I’ve even tried rolling back a few versions of MissionPlanner that I know work elsewhere, still no dice.

given you have tried older MP’s could i ask what version of dotnet you have installed.

im wondering if it has to do with that.

also what chipset is on the sik radio? FTDI? or something else?

I think I may have stumbled on the issue through some other similar looking issues. Issue #1754 eventually pointed to a post in this forum from November '17: New Dell PC with Windows 10 Home - MP Doesn’t see the serial ports and crashes.

That post links to the CP210x drivers page, but specifically circles a driver download that is one version older than what I’ve installed on my two newest systems - in fact, the latest driver released in November 2017, which came after any previous computer I’ve installed that driver on. I won’t be able to test it until tomorrow, but maybe there’s something odd in that latest “Windows 10 Universal” driver that doesn’t agree with MP? I’ll reply to this thread after I try it and see if that’s the fix.

I finally solved same problem changing driver with older version
I installed version instead of version 10.1.1


Thanks, installing the older drivers seemed to work

Super. It works with the older drivers.

Not to beat a dead horse, but I tested this morning and the 6.7.5 version fixed the issue for me as well.

I had some trouble uninstalling the 10.1.1 driver just from the normal ‘Uninstall Programs’ in Windows, but it worked once I plugged in the Sik radio, went to Device Manager, right-clicked on the Silicon Labs com port and told it to uninstall the device driver and all files. After a quick reboot of the laptop I was able to get a telemetry connection with MP again.

just an open question, where did you get your radios from? the genuine ones all have ftdi. so just want to get info for if I see this issue again and can point people in the correct direction

I’m new to pixhawk (upgrading from APM 2.6). But I have been having “Invalid comport or in use” message when trying to Load Settings. So I followed all the advice and rolled back from driver 10.1.1 to 6.7.5 successfully but no joy. I still have invalid comport after fresh restart and MP startup. Where do I go next? Hate to put the APM board back on. Heard too many good things about PixHawk. But I would have though Telemetry would be easy .

Bought my 915 Telem from Amazon:

YKS 3DR Radio Telemetry Kit 915Mhz Module Open Source for APM 2.6 2.8 Pixhawk RC Quadcopter

I’ve been fighting this same issue all (explicative deleted) afternoon and thanks to this thread I fixed it by installing older drivers.

I had this problem with 3 different aircraft with radios that were bought from different vendors at different times.

What chaps my behind is the fact that yet again MS in their infinite wisdom (NOT) gave us Win10 users an update that broke our stuff.

At this point I’m wondering if all of the trouble I’ve had in the past several days flashing OSDs wasn’t caused by this same “update,” and as soon as I finish dinner I’m gonna find out…

La version du pilot à résolu mon problème de télémétrie
Merci a tous

I got the same issue. I think its the version 6.7.6 which doesn’t work. I can not download the 6.7.5 version.

1 Like

I am having the same problem! Are there any new solutions to this problem?