Integration of Pixhawk 4 and Marvelmind indoor GPS

Hello everyone,

we are about to develop an autonomous flying drone using Marvelmind indoor GPS and the Pixhawk 4, but we have some problems with the integration of Marvelmind indoor GPS and Pixhawk 4. The Marvelmind works without big problems, but we never get the message "3D Fix" when integrating it into the Mission Planner.
We tried several integration options:

  1. A first attempt was the integration according to the following link:
    We have only made these settings in the parameter list and with the Hedgehog we use the Marvelmind protocol in the Marvelmind to send the GPS signal. After we have made all the settings, we receive the message "GPS: No GPS" in the HUD.

  2. Second, we have tried the integration according to the following instructions:
    We have used the attached parameter list and use NMEA 1803 in the Marvelmind to send the GPS signal. The NMEA messages are also enabled.
    Here we get the message "GPS: No Fix" in the HUD. However, any slight changes to the parameters, as indicated in some forums, will not help to get the message "GPS: 3D Fix".

For the wiring we have tried the options on the Pixhawk 4 via the Telem1 or the UART & I2C as well as the GPS connection. But we don’t know which is the right alternative? We suspect it, via the GPS module.

We have tried a lot and don’t know what else to do to get “3D Fix”. Do you have any experience with the Pixhawk 4 and the integration of the Marvelmind GPS with the Pixhawk 4? Does anyone have any ideas about what we’re doing wrong or what we can try out to make progress?

Best regards,

The current code does not work very well. It is not a fault of your setup.
If you have some EKF skils, I could use some help fixing it.

Hello Amilcar, we’re also having similar results not being able to integrate MM, we are doing a workaround trying to inject position from an onboard computer, but if you could shed some light as to what to modify in the EFK that would be great!


Take a look at the file:

I suggest you to check this discussion VISION_POSITION_ESTIMATE not appearing in QGroundControl
There is a a way to publish a pose in an indoor environment, and by pass the “3D fix” issue trigger through Mavlink (by setting a “home position”). Maybe it can help if you use a companion computer.