Servers by jDrones

Installing Arduplane on YRrc Mini Pix4

Hi everyone! Can someone tell me if it is possible to install Arduplane on YRrc MiniPix4 board (image)

I’m trying to install from Mission Planeer and I can’t.

Cheers!!
Merry Christmas and Happy New Year!

I’ve not come across that board before. Do you have a data sheet or manual for it?

No i don´t! The board originally features an arducopter version. I managed to connect to the board successfully using mission planner and installed arduplane.
After installing arduplane, I can’t connect the board with mission planner.

There’s really not much we can do to help without knowing the details of the board, unfortunately. Best bet would be to find the original firmware and flash it back. At least that way we could get some details to try to figure it out.

I remember coming across that FC awhile ago. Which Firmware target did you flash?

Hardware:
FMU Processor : SMT32f407(32bit Arm Cortx-M7 168Mhz)
Sensor:
Gyroscope: ICM-20689
Accelerometer: ICM-20689
Barometer: MS5607
Compass: IST8310
Support for three at most, 1 x Compass with built-in, 2x External support two at most.

1 Like

Hi!!!
I don’t exactly remember the original firmware of the board.
First, I was able to successfully connect the controller to mission planner, with the original firmware. Then when installing Arduplane 4.07, I couldn’t reconnect.

Try platform F4BY and Arduplane v4.0.7.

That target will be looking for an MPU6000.

I also have the same question as the OP.

I have tried flashing the F4BY firmware with some success. Most functions seems to work, but I can’t access Serial port 2 and 4. The other serial ports seems to work fine. Any ideas on how to get them to work with adjusting settings in MP or is the pin mapping somehow different?

I had to set the SR2_ Parameters manually. For some reason they were all 0Hz.
https://ardupilot.org/copter/docs/parameters.html#sr1-position

Hi! I have tried F4BY and Arduplane v4.0.7 but MP MP still does not recognize the board. I think it may be a problem with COM port.

I had a problem with the COM port driver on Win7 and Mini PX4 YRrc and ArduCopter v4.0.5. On Win10 I had no problems with detection on the COM port. I connected with radio telemetry without any problems.

I think this is best description for this YRrc FC.

Not really a F4BY and not exactly a mini PIXhawk…but finally make it work…

Servers by jDrones