Indoor optitrack with drone

Hi guys,

im new here and i would like to ask help about optitrack and indoor flight.

I read through the article https://ardupilot.org/copter/docs/common-optitrack.html and try to mimic the progress.

The skyviper v2700 is the drone flying in Loiter mode that i pick for the experiment.

I flash the drone configuration with mission planner and then double check with APweb. This part should be fine.

In the NatNet Sdk of the public class of SampleClientML, the ip address of pc is added to mStrLocalIP and mStrServerIP. At the same time i change the ip address of drone.

In motive, i set the local interface of streaming pannel as pc ip address. i also try set local interface as the ip address of drone and loopback . But all these setting doesn’t work in the end.

After the data streaming is on then run the NatNet sample, the mission planner still indicates that “need 3D fix” and “fence requires”. The NatNet sample shows that the data already sent out.

Usually the message shows the the drone need GPS data when in guided or auto mode to take off. But in setting we already disable GPS and compass which it means that the optitrack data have not transmit to drone.
missionplanners

I still dont know which part is incorrect.
Any feedback would be greatly appreciated. Thank you in advanced.