Incorrect power system?

I just say something really weird on my flight yesterday. It was a short flight, since there was not a lot of battery left. The copter started yawing. And then it throws a potencial thrust loss error. It was very hard to control it in loiter, so I landed in stabilise.

This is the log from then.

Then today, I tried to replicate that. I did get a similar resoult. The copter didn’t get any error. But the copter soon became very unstable. I recently switched from plastic 12x4.5 props, to 12x5.5 carbon fiber props.

This is the log from today. When I checked, the motors appear to run at around 1700 in loiter. Is this normal? The copter hovers at 40% in stabilise and even in loiter, it is the same, as it was indicated in the osd. If you are using UAV log viewer, it was near the end of flight, and you can see it when I switched to stabilise.

I am running a 2,1kg copter with 4s 10000mah battery, with 12x5.5 carbon props. Then I have multistar 3508 580kv motors.

Also, when I tried 4s 2600mah, that did not happen, but the flight time was around 5min.

What ESCs do you use ?

I use a Hakrc Blheli 4 in 1 50 amp esc.

And I have it setup to use the normal esc mode.

There is an issue with your MOTOR3, it looses sync, or prop is loosen.

I checked, the prop is on tight, meaning, the motor must be losing sync. Other than calibrating the esc, is there anything else I can try?

Edit: I tried callibrating esc, still, when looking at the logs, the motor 3 is acting out of sync still…

Either a bad esc or a bad motor, to make it sure change swap motors and check again. If the error moves with the motor then it is it, otherwise it is the ESC.

(Also worth to check motor/esc wiring, power and signal)

My guess would be it will be a faulty motor. I have noticed the M3 runs hoter than others.

Is there any way to test the esc health using the blheli suite?

After more then a year and tens of flights, I can only blame uncommanded yaw on BlHeli ESC entering thermal throttling. There’s no other logical explanation.
It only happened three times. Two were severe, once after some violent flying in stabilize, second after encountering heavy wind-gusts in auto. Upto 8 uncommanded yaw spins were logged.
Third was just a single uncommanded 360 degree spin at one of the waypoints. Log analysis and physical inspection proved one skewed motor during transport, forcing two motors on higher effort to compensate.
I’m using individual ESCs. Your 4-in-1 is probably more prone to overheating.

1 Like

I know this thread as opened a log time ago, but I didn’t wanted to open a new one. I have finaly decided to get the drone out of storage, after some other projects. So the first thing I did was check the issues that were seen last, only to find, that the last time, motor 3 had potencial thrust loss, but now I think that motor 2 would have it?

Since it dropped down to 1484, while the others remained at around 1700. I wanted to check which motor to swap with another, to see if it is the esc, but now I am not sure, this would more likely be cause by bad esc rather than motor?

Here is the log.

I wanna make sure, before I start ordering new parts.

Could not see any major thrust issues in that log.
Your tuning needs work and maybe motor alignment and frame integrity.
Some wiring or GPS location issues need sorting.

I agree with the tunning, since it was a bit wobly, but motor alignment is good, so is frame integrity. Not sure, why it got so many GPS errors though. Probably due to low sat count.
It was in loiter, when it started going to the side, so I am not sure, why it is shown as stabilise.

Agree with Mike, other than GPS glitches nothing of interest to see in that log. If you do plan on running Auto Tune at some point fix the aggression value. It’s wildly out of range. Not sure how you managed that actually. If you meant it to be .075 I would suggest using default .10 instead.

I see, it was a lot more, I put in 0.075 with a dot, but the dot then got removed for some reason. I put it back to 0.1, and will try later on to tune it again.

You may want to update Mission Planner to latest Beta. It’s possible if you used a “,” instead of a “.”, like our Germans friend do there could be trouble with the latest stable version of Mission Planner. Not sure if this is your issue but update it anyway.

So I did tune the quad today, saved, then went to fly some more. In that flight, I definetly had potencial thrust loss, I got multiple messages about it, when the battery was a little less than 3.8 per cell. So I checked, and in the logs it says it is MOTOR 3(if I am right), so I will try switching 2 motors.

Yes the log definitely indicates motor 3

But I can see a few other problems for you to fix before more flying

MOT_THST_HOVER=0.2926635 and MOT_SPIN_MIN=0.3
MOT_SPIN_MIN is way too high, test and set something like 0.13
Use the MissionPlanner motor test to check how low the motors will reliably start, and set that as MOT_SPIN_ARM, then add about 0.03 and set that as MOT_SPIN_MIN.
Some BLHELI ESCs and motors will start to spin at extremely low RPM, almost like a stepper motor, so you wouldnt want to go that low. Set something believable like 0.09 for MOT_SPIN_ARM if you have to.

Set these correctly
These values suit 4 cell Lipo, you can use the MissionPlanner plugin via Alt A on the keyboard to easily choose a different battery type and cells.

And in BLHELI suite I would advise to reset all to defaults then
Low RPM Power Protect=Off
Low Voltage Protect=Off

In fact you’ve got some other settings at defaults that suits 10inch props, which is probably OK after Autotune has made some adjustments, but I think you’ll benefit from starting over with the ALT A plugin values that are offered, then run Autotune again.

I can’t find MOT_SPIN_MIN and MOT_SPIN_ARM param, and when I try them from setup at motors, it says that they are missing?

Are you looking in the full parameter tree?

From your parameter file:

For some reason, it didn’t want to show them, until I plugged in the battery.

So I did all the above, and also changed to Dshot 600, which I am surprised wasn’t already on. Right now, none of the motors go out of sync (I think), but I will try a few more times.