I need your help with "Large Vehicle MagCal"

Hello, I need your help with “Large Vehicle MagCal”.
So far I have always used the usual method to calibrate the compass by spinning and swiveling the helicopter in all directions.
However, it is not fun to twirl a 10 kg scale helicopter around in the air.

Therefore I tried the function “Large Vehicle MagCal”.
The helicopter is equipped with a Pixhawk mini4 and an external compass/GPS module. The internal compass is disabled. I always do it this way.

I have aligned the helicopter with an analog compass with the nose exactly to the north (360 degrees / 0 degrees). Then I entered “0” in the input field under the function “Large Vehicle MagCal” in the setup menu and saved the value.

Gladly I went to my model airfield and switched from “AltHold” to “Loiter”. The heli went into a sideways tilt almost immediately. Only by quickly switching back to “Althold” and countersteering could I catch the heli again.

At home in my garden I have now aligned the heli once again with the analog compass exactly on north. And have entered in the function “Large Vehicle MagCal” again “0” degrees and saved. Afterwards the Mission Planner showed me under the value “Yaw” however a value of 6.58 degrees.
Shouldn’t the value “Yaw” now also show “0” degrees?

For the test, I now entered the value “354” degrees under the function “Large Vehicle MagCal”. And the value of “Yaw” changed to “359.43”.

Hence my question:
Do I have to correct the value “Large Vehicle MagCal” in my case (nose aligned to the north) as long,
until the “Yaw” value is almost at “360” degrees?
Would my compass now be calibrated well enough?

I would be very happy about some more explanatory words than in the wiki.

What I also noticed during my garden setting attempts:
I had all the rotor blades disassembled and could also run up the motor and observe what happened to the “Yaw” value. The moment I switched from “Disarmed” to “Armed”, the “Yaw” value increased by about + 0.40 degrees.
At this point the engine was not yet running!

As the engine ramped up, the “Yaw” value continued to increase, up to almost 7 degrees. After switching off the engine, the value decreased by these 7 degrees. The compass/GPS module is mounted about 3 cm above the drive belt for the tail rotor.

Running drive belts sometimes generate an electrical voltage.
After this observation, I tentatively positioned the compass/GPS module further away from the drive belt (about 6 cm) and tried again.

Now the “Yaw” value changed only by switching from “Disarmed” to “Armed” by about +0.40 degrees. However, little changed when starting up the engine.

Now I wonder, was the wild reaction when switching to “Loiter” a miscalibration the cause or the displacement by the running drive belt.

Thanks for your help.



I am sad that I have not received a single response to my question.

Apparently no one uses the “Large Vehicle MagCal” function.
I also find little posts and information about this function.

I’m sorry that you haven’t received any help on this. This is somewhat out of my swim lane. I would suggest that you move it over to Copter 4.1 topic. It will get more users reading it that may have experience with this.

Good luck.


Hi Bill, thank you very much for your attention.

I have already contacted the copter forum.

Where I had primarily asked here, where the telemetry value “Yaw” comes from. Therefore, from which sensor is the value “Yaw” determined. Is it the magnetic compass sensor or the GPS sensor or a mixture of both.

Someone in the developer community must have written the wiki for compass calibration. This writer should be able to answer my question.

Somehow strange, I would think compass calibration problems must occur quite often.

Thanks for your support anyway.



1 Like

Hallo Heribert,

I used many times the “Large Vehicle MAgCal” and it works really fine!
You just place the Heli facing the North for instance and check it with your mobile phone, send the command and thats it. If you have not issues with your compass hardware it must work without giving any issues. At least this is what I do with my small aircrafts and never had issues. Later during the flight I send the command to calibrate the compass, very easy!

When your Heli is not moving it can only rely on the compass. After you start moving it takes the data from the GPS. You will see a message on the sreen saying something like " Yaw Alignemt Complete" this happens the moment you start moving. I think autopilot is doing some sensor fusion and looks the GPS has more weight compared to the Compass.

I dont think that you had issues with the Compass when you switch to Loiter. Most probably you did not have GPS quality and that is the reason for your tilt. As said I never had issues with the Compass, but experience many times when there are GPS glitches or not enough GPS satelites, the Heli moving away saying goodbye to me :smiley:
Take good care for the Heli vibrations and only switch to loiter witjh good sky view.

Hallo Pedro, sprichst Du Deutsch?

Thank you for your many responses.

As already described, the helicopter (750 size Agusta 109 with four-blade rotor head and 9.5 kg) has a belt drive for the tail rotor.

Before the first flight I had the external compass/GPS (the internal compass is deactivated) mounted about 4 cm above the running belt. And I had calibrated the external compass/GPS with the function “Large vehicle calc” and an analog compass.

During the first flight in Loiter I then had the effect that the helicopter immediately became “crazy”.

I then simulated a flight in my garden with disassembled rotor blades and observed how the value “Yaw” changed. When the motor was run up, the “Yaw” value changed by 7 degrees.

Now I mounted the compass/GPS higher above the belt, about 14 cm. After that, the “Yaw” value only changed by about 0.5 degrees during a simulated flight.

With this change I did a test flight again yesterday and switched to “Loiter”. This time the helicopter did not go crazy. However, it started “toilet bowling”. With circles getting bigger and bigger. I switched back to “altHold” after a short time.

Afterwards I calibrated the compass again in the conventional way, by swinging the whole helicopter back and forth. This was exhausting, but it worked. However, I have not yet come to a new test flight, because the weather was too windy.

I do all the test flights at our model airfield. there we have free GPS visibility.
In the log readable, I always had enough GPS satellites. Therefore, it should not be a GPS glitch.

You write that you first calibrate the compass on the ground with the “Large vehicle” function and then give the command to calibrate the compass in flight. Can I understand this in such a way that you try “Loiter” only after you have calibrated the compass in flight? If yes, this would mean that you do not try Loiter directly after the “Large vehicle” calibration?

Beste Grüße wo auch immer Du herkommst.


This doesn’t necessarily mean it’s a compass issue. It could be for tuning as well.

Hi Heri,

Ich lebe in Baden-Württemberg

You are putting focus and effort on the compass believing it has an issue and from experience and gut feeling says you don’t😁. I have flown a faulty compass (no patience to change it) and autopilot was complaining in the telemetry, but no dramas happening to the attitude in loiter.
I would not waste time swinging that fellow up and down, just send the large vehicle command and that’s it, you are fairly ready to fly. What you can do next is to program in your remote a channel to start the Compass_Learn when you are flying for instance in stabilize mode( don’t do it in loiter) Just go around flying in stabilize mode and press the button, autopilot will start the calibration and finish in a couple of seconds.
Have a look to the EK3_SCR1_YAW try changing to 3 to have the GPS and compass as fallback. But normally I have 1 just compass.

Disagree, many satellites doesn’t mean you have good quality. It has to do how the satellites are dispersed in the sky. Like you on the airfield normally I see more than 15 most of the time, but some days the reception is not that good some glitch’s even happen and I experience several times small flight always. Could be that the satellites are to low in the horizon, it depends on the day hour. But the issue only observed in loiter mode! I never fly in loiter for that reason except when I take my 450s far away and I loose the orientation as they are small, then I turn the loiter to make it stop :sweat_smile:

Maybe I am wrong but I can’t see a correlation between your leans and the compass. If you do the Large vehicle calibration and you don’t have magnetic fields close to disturb it should be fine to go directly to loiter.

I would be careful here, I read a lot guys commenting bowl effects and correlating with compass, but that was never my cases, they where all related to 1st place bad mechanic calibration and 2nd as Bill said poor tuning!
Bad mechanic calibration = more vibration = leans = crash

Frohe Ostern,

@bnsgeyer , @Pedro_Claro

I think you are both right, at least about my last test flight. The “toilet bowling” probably comes from the tuning that has not yet been done.

The “crazy” behavior during the “Loiter” in the first test flight was probably the combination of a) disturbances by the electrical charging of the drive belt and b) the not yet performed tuning.

I am also flying a Logo600Se (which will later be used in an AS350 Scale fuselage). Here I first mounted the Holybro compass/GPS module directly on the aluminum tube of the tail. Again, it was not possible to get a reasonable “loiter”. I then mounted the module on the supplied mast with about 10 cm distance to the belt (on the tube) and after that the “loiter” worked. However, the heli was already tuned at this time.

First, many thanks to both of you for your good advice.

@Pedro_Claro Pedro, I like to use loiter for my scale helicopters. The many parameters allow me to tune the flight characteristics as true to life as possible. This makes the flights look very similar to the real thing.
In addition, with a large scale helicopter you like to fly in a large aerea. This also makes it look more like real flying. At this I have already lost two helicopters (before I started to use FCs), because I did not recognize the flight position in the distance exactly.
Switching back and forth the modes in an emergency situation often doesn’t work, because you have the famous second of shock. That is often a few seconds and that is already too long. Therefore I start in “Stabilize” and then switch to “AltHold” and then to “Loiter”.
This fits well for me. But everybody is different there.

I now concentrate first on the tuning of the tail of my Agusta 109. This is always particularly difficult for me.
@bnsgeyer Bill, this is where a few more example log pics on the wiki would be very useful to me.

The swashplate is usually easier for me to tune. With the P and D rates you only have to turn up until they oscillate and then halve, that can be easily explained.

When there are calm days again, I will continue with the tail tuning.

Thanks a lot.



Were you going to use autotune? I am not the best at tuning the tail but I used the autotune and it definitely did a good job. after finishing autotune, It does move back and forth a little but I think that could be a mechanical linkage problem as I have noticed some slop in my linkages. What is nice about the autotune is that there is no guessing as to where the instability is. Therefore it is able to tune better. when I tried manual tuning previously, I was only guessing thinking that some oscillation in the tail was the onset of instability when it wasn’t. I would suggest in autotune to perform the max gain only test. Then you can see the shape of the frequency sweep response and better determine a value to use for the AUTOTUNE_GN_MAX parameter.


Hello Bill,

since you started programming the Autotune, I’ve been waiting with anticipation for the “stable” version.

Of course, the “beta” version is usually already very safe. But I mostly fly expensive and elaborately built scale helicopters. There you want to exclude even small risks.

At the moment I only have a Logo 600 SE mechanic without fuselage, but it is equipped with a 750€ expensive 3-blade rotor head and already tuned manually. When the “Stable” Verson of 4.2. is rolled out, then I will try the autotune with this mechanic first. And of these, the tail first.

There will certainly be more questions about the autotune, at the moment I start with it.
Therefore, keep ready for me. :wink:

Thanks a lot for your help.

I certainly understand that.

Always standing by to answer questions. :grinning:

1 Like

I also have an issue with using the Large Vehicle MagCal. I think we are using Here compass.
Arducopter: 4.1.5

“The command failed to execute.”
Rover users encountered it before.

A question more than a comment; couldn’t you use Magfit as an alternative to Large Vehicle Mag Cal? Its what I use for Multirotors and it worked well for a Rover also. Straight forward to implement and it covers Compass Motor Interference also.

Magfit, what is that? Where is the guide or document and steps?

Using the tool in MAVExplorer is easy.

Note: I don’t have a Trade Heli so not sure it’s suitable. It’s why I posted it as a question.

I have never used it but I am almost certain that Tradheli does not use the compass motor interference feature that is available to multicopters. So that part of it will not be useful for Tradheli.