Servers by jDrones

I need to map a Kill switch for an IC plane to AUX 3


(Evan) #1

I have a plane that is using all 8 main servo outputs.

One of the AUX channels, not 5 as I am using that for RPM, needs to control an optical ignition kill switch for my motor. I have tried to go into the parameters and use RC9-11 and setting them to RCIN7 and RCIN8 but it still doesn’t work. I have changed the BRD_PWM_COUNT from 2 through 6 trying all of the above and it still will not work.

I am ripping my hair out here and would really appreciate if someone could help me out.

Thanks


(Paul harris) #2

Would like to know this as well as I can’t get the AUX out on any of my Pixhawks to work


(Evan) #3

Agreed, I am trying to test my settings with a servo and cannot get them to function.


(Paul harris) #4

According to this video it should be quite easy

No matter how many times I tried I cannot get anything to respond when connected to the AUX pins on my Pixhawks.

I ended up going around it the long way

I use a 10 channel RX in PWM mode, connected to the pixhawk with a PWM/PPM converter which takes care of the first 8 channels for the Pixhawk to use and then connect my servos direct to Channels 9 & 10 on the RX.

A bit Heath Robinson buy at least it works

Unlike trying to persuade the Pixhawk to pass channels 9 & 10 to the AUX Pins

Has anyone actually managed to get a servo working on the Aux pins, just to confirm it should be possible, or has the option been removed or broken in the latest updates.

Paul


(Evan) #5

I just got my switch to work on AUX 2. I am able to toggle an engine kill switch.


(Paul harris) #6

Care to share how you did it.


(tridge) #7

The key is to know that there are RCIN functions for RCn_FUNCTION for every RC input. See docs here:
http://ardupilot.org/plane/docs/parameters.html#rc10-function-servo-out-function
So if you set RC10_FUNCTION to 57 then channel 10 output (which is AUX2) will be copied from RC input channel 7.
This allows you to copy any rc input channel to any output channel.
Cheers, Tridge


(Paul harris) #8

Thanks for the link

I tried those settings and now have

RC10 set to 57 which has servo on AUX2 working controlled by Channel 7
RC11 set to 58 which has servo on AUX3 working controlled by Channel 8

No setting gets servos on AUX1 & AUX4 working

Channel 9 & 10 on the Radio also not controlling any thing although I can see on the radio that they are working and do work if I set the RX to PWM and connect servos to Ch 9 & 10 directly

Could someone confirm that the latest version of Aduplane supports more than 8 channels, just in case that is the issue, although they are shown in Mission Planner so should be there.

So getting close, but something still amiss.

Paul


(WickedShell) #9

If you are on plane 3.6 the AUX outputs wont move unless the safety switch has been pressed and the aircraft is armed.


(Paul harris) #10

Safety switch is pressed and Pixhawk is armed.

As said above Aux 2 & 3 is now working but getting nothing on Aux 1 & 4

Plus only able to use channels 7 & 8 and need channels 9 & 10 to also work so that all 4 Aux outputs can be used, if they can that is.


(Evan) #11

Have you gone to BRD_PWM_COUNT and changed that so that everything is servo and not relay?


(Paul harris) #12

Yep changed that to 4 and also tried 6 as well, with no luck either.

Can anyone confirm that with a 10 channel RX connected via PPM I should be able to use channels 9 & 10 to control servos connected to the AUX pins

Starting to think the documentation which says it can be done is wrong.

Thanks

Paul


(WickedShell) #13

Can you post your parameters?


(Evan) #14

Not trying to ignore you but I will post my parameters when I am at work next. But the RC_nFUNCTION is what you need to set. In my case my issue was how I was powering my optically isolated switch. For some reason it doesn’t like using power from the same BEC. So I had to add an ignition battery and an autopilot battery in order to rectify the problem. This is most likely due to the switch moving the ground wire. Also make sure you aren’t plugging into an AUX port that could be set up as a relay switch.


(garrett_min) #15

After Diagnostics w/ different verified failing configurations of UBECS, X8R, Pixhawk & RCXEL.
Failure is RCEXEL Ignition Module RPM Connector @ AUX5 on PIxhawk Servo Rail connected.
Passed RCXEL LED on Pixhawk RC9 Passthrough w/ RCXEL RPM connector removed from AUX5.

Pixhawk Plane 3.7.1 w/ Both RCXEL RPM & RCXEL RX Connector

Fails RCXEL RPM on Aux5
Fails RCXEL LED on/off on RC9_OUT

Fail same result not switching LED @ 2 x UBEC w/ 6.2V & 5.2V on PIxhawk Servo Rail & Opto Switch - IN/OUT.
Next test will be Pixhawk PPM/PWM output or conversion to Opto-Switch Receiver Input.

http://discuss.ardupilot.org/t/rcexel-gas-optical-ignition-kill-switch-fails-while-servos-pass/16324


(Adnan) #16

07-Sep-2017

Hello Friends: was struggling on this issue and found some useful tips in this discussion. All is working now for me but I believe this wiki require an update. I am using copter3.5 and following is a brief summary for my solution.

1/ understanding of AUX OUT pins and mapping of RC Output chanels
2/ understanding of SERVOx_FUNCTION in MP–>CONFIG/TUNING–>Full Parameter List
3/ V.IMP. (but not an ardupilot issue): enable 16 channels from RX (in my case it is Frsky X8R), such that all channels can be track in MP–>Radio Calibration screen. I followed this youtube video.

Thanks,


(Mga Gam) #17

hola
este tema es fastidioso, si alguien ya logra controlar la salida aux con el canal 7 u 8 por favor no dude en comunicarse