I have had two 2.6 boards die in the last two weeks, why?

  • I use USB to mission planner with the same cord I charge my phone with
  • I never connect USB power and LiPo power at the same time
  • I always click “Disconnect” from mission planner before unplugging the USB cable
  • I always disconnect any power before adding/removing wires to the ArduCopter

My kk2 controllers work fine with everything. What am I missing? What could possibly be going wrong? I accept that this could be a strange coincidence but I seem to be the lowest common denominator.

** EDIT **

Bizarre twist - I decided I would try to plug in USBASP to my mac to see what would happen. There was a POP and I saw smoke trickling up from the board. At this moment I knew it was toast.

I plugged the micro usb cord back into the board just out of curiosity and guess what? It worked! I fired up mission planner and that worked too. What in the world is going on here??

I think on these boards there is a fuse that connects the power to the APM board and you may have blown that. Perhaps you have a short on your PWM outputs or something.


Perhaps, something definitely shorted / blew. What blows my mind is that only after things blew up did the board start working again…

You Blew up a capacitor, probably for filtering a power supply, so it will be subtle.

The most likely reason for a board to blow this time of year is static electricity.

That sounds about right. My battery is not even plugged in and this is what I hear in the mission planner over and over:

  • System MAV001 has low battery
  • voltage warning 3.4 volts

I assume it’s because of the “incident”. Is there any way to get around this? Probably not a good idea to fly with the current scenario.

** EDIT **

I did a “test flight” with no props. Everything is acting exactly how it should. I held the UAS up and tipped in on different axis to hear the appropriate motors spin up. No wonky acceleration or anything like that. Later today I’ll try it out in the real world to see what happens.

This ArduCopter isn’t even a week old so I filed a return with Amazon which was approved. Once the new APM box get’s here I’ll return this one just in case.

** Flying Update **

It flies fine. It sounds like the APM just permanently thinks the battery is low but since I’ve disabled any of the low battery fail safes it’s flying. I have a low-voltage alarm anyway so I’ll hear it if anything happens. I’m going to chalk this up as a win! Thanks for the help folks.