I crashed, need help

Hi guys, I just auto-tuned and flying attitude seemed more dialed in. I got hit by some medium level winds and copter would not stop wobbling, so I had to disarm and crash.

Here’s my log: https://www.dropbox.com/s/ue251xnlf9e3wje/2019-02-25%2012-40-20.bin?dl=0

Any help would be appreciated.

slightly to improve pida alt hold. Mean vibration. Throttle pids possible weak (maybe too large). So when looking at HDOP, we in Europe probably have better with Galileo.Super stable power supply voltage. Model has hit the wall? He made 3 compasses! I think that improve damping of the controller (loose wires, anti-vibration bed). First of all tuning pid althold, throttle. What are your engines and propellers - large propellers and small kv engines. You can send pidas (external tuning) - maybe something will appear more.

4x T-Motor MN3508-380KV
15" APC props

The copter started wobbling, so I brought it down to about 5 ft and disarmed. I’m not sure why I have 3 compasses, I’m just using Pixhawk 2.1 Cube & Here GPS.

Here are the pids:

So it probably flew OK with default parameters before Auto Tune? Did you set the Rate Pitch/Roll filters to 10Hz manually? I ask because I had a quad of similar size (motors and props) and it flew pretty well on default parameters. Your D terms are double what I had and I left the filters values at 20Hz. On bigger craft 10Hz works well.

3 mags because the Pixhawk has 2 plus your external one. Typically you would disable the internal ones but if you are not getting compass inconsistant or other EKF errors it could be OK. I don’t think it’s repsonsible for this in any case. I suppose you have reason to use Yaw 90 for compass orient?

Yeah, it flew okay with light wind. I mainly hovered lightly. I auto-tuned inside and this usually does the trick pretty well. I did change to 10Hz, as per the suggestion on the Auto Tune tutorial. This is a pretty big craft at 680mm, it’s given me so many more issues than my iNav 450mm flame wheel. Also - yes: yaw 90 because of compass orientation.

@rolyexpress Based on your pids from autotune, I would change back to 20hz.

However, you mentioned you tuned inside? I would never do this unless it’s a very large room like a gymnasium because the air circulation in a room can create very different pids (more aggressive) than outside. Then when you fly outside, the pids can overshoot and cause the fatal wobble you encountered.

Your answer was super helpful. I’ll try 20Hz and re-tune on a low wind day.

Previously I had tuned in a big hardware shed with good results. After that I auto-tuned outside with 5 mph winds / loiter mode and the tune was worse, so I dumped it. This time I tried to tune inside a different place which I thought was bigger and this is what happened.

well you also have some mechanical issues to resolve… 2 of your motors are working much harder than the other 2

also i would try first at 10hz, sorry if that wasn’t clear

i’ve tuned in windy conditions before and still came out with a very good tune