Servers by jDrones

I can arm and disarm but engines never stop?


(Dave) #21

Yes, this is what I don’t understand either. With throttle and steering mixed by the skid steer config it’s not clear to me how this would work.

OK, this might work. 1st set MOT_PWM_TYPE to (0) if it isn’t already. Then set the servo limits and trim as shown in the attached. Min and Trim to 1500 and max to 2000 or whatver the max is shown in the radio calibration screen.

And again use a switch for arming not rudder stick.


(ahmet omer ozgen) #22

Thank you for the replies. Good morning.

Once I’ll come back to home from uni, I’ll try this im the evening.
Mine was on min 800. I’ll make it 1497 then

Also, I was calibrating the compass with telemetry because i didn’t have such a long usb cable?
Would that work too?

Can you refer me to a guide on how to do the settings on the rc radio. I want to make the 3 way switch to go in modes Auto Manual and Loiter. Since there are other switches i want to assign arm and disarm as well. Right and left stick to arm/disarm isn’t really great.

Thabks


(Dave) #23

Calibration via telemetry is the preferred way. I don’t know anything about that radio I use a Taranis and OpenTx but you can find a user manual online. By default the flight mode channel for Rover is channel 8. Here is a guide on how to setup mixing for modes:
http://ardupilot.org/rover/docs/common-rc-transmitter-flight-mode-configuration.html#common-rc-transmitter-flight-mode-configuration


(ahmet omer ozgen) #24

Thank you. I’ll re calibrate stuff while esc’s are working (but motors unplugged). Boat is around 5kg and a meter long. It is really hard to fix it and click the button lol.

I’ll dig the manual. I’m so new to the rc world. It is very complex. Thank you for the help. I’ll call the local rc shop to ask about a reverse capable shaft with props. Try to change them. I won’t use reverse and I’ll set min pwm to 1497. But having an option is nice.

Thanks


(David Boulanger) #25

It may just make wider turns particularly when moving very slow. I would test this but my boat is halfway through a refit and not ready for the water yet.


(ahmet omer ozgen) #26

Qick question.

My rc receiver in the boat is connected to the pixhawk via 1 cable(turnigy 9x ia8) on the first port for Sbus/ppm

ESC’s are conencted to the pixhawk.

Should i add to more cables from Rc receiver to Pix hawk for 2 motors?


(Dave) #27

No. Sbus is carrying all channels.


(ahmet omer ozgen) #28

thanks. I will now recalibrate everything on the balcony with no electronics near by, over telemetry.

later i’ll try the reverse thing. (last time i switched their places(right prop to left, letft to right) maybe now on their own shafts reverse will not make them spin off. I’ll try it in 30 mins


(ahmet omer ozgen) #29

Hello. I don’t know what i did wrong.

I calibrated the external compass. At the outside the flash light is green. When moved indoors it says bad ahrs.

problem is. Now no matter what i do, i can’t control the motors thru RC transmitter.

parameters here:

1.param (13.3 KB)

:frowning: :frowning:

I will take the boat to university tomorrow. Prof wants see my progress. And next week I’m supposed to go on a field test with Auto mode.

I couldn’t test the boat on my bathroom for prop spin off test. Because i could’nt manipulate the esc’s with my Rc Transmitter.

Even with Odroid and ESC’s turned on gps looks quite stable at the outdoors. How ever i could’nt calibrate the pixhawk’s compass :frowning:


(David Boulanger) #30

Is it armed and in manual? You may indoors get all sorts of problems with the compass and GPS.


(ahmet omer ozgen) #31

Yes. even if it’s fully on SAFE armed, RC sticks makes no movement.
I can see the pwm signal on the radio section of the Mission Planner tho.

I made it 800 pwm min 1500 trim 2000 max

if the trim is set below 1400 engines start runnig slowly. beyong 1600 they start moving slowly. (reverse and forward i suppose)

Port engine is reversed wired(same in the original design i guess). Starboard is normally wired(+,- from the ESC)

Yesterday i was able to control the servo outputs over my RC.

Maybe i need to do some setup inside my RC radio?

I should at least make the manual mode working all right. So that i can test the prop spinning in reverse in my bath tub

Thank you.

Btw in my thesis I’ll give credit to you and to Mr. Dave and Mr. RMackay! Because you really help me out!

Thank you.


(ahmet omer ozgen) #32


(David Boulanger) #33

really you should not have to do any adjustments with the radio usually.


(David Boulanger) #34

You may want to try setting ARMING_REQUIRED to 0. BRD_PWM_COUNT is 2 and you are using outputs 1 and three so I don’t know if that is a problem. Cruise throttle , although not a problem for manual, is only 5.


(ahmet omer ozgen) #35

Thanks I’ll change them asap.

I use 1 and 3 because of skid steering.


(ahmet omer ozgen) #36

yes. it works well in manual mode now. thanks. I’ll do the bath tube test now.

how ever i can’t disarm it :slight_smile:


(David Boulanger) #37

Well I think this proves you were not arming the system before. That was kind of the purpose.


(ahmet omer ozgen) #38

Well it was arming. but now it is auto arming and i can’t disarm at all now.

:frowning:

Prop test failed. when on reverse, props spin off.

Problem 2: The shafts carry water in the boat.

I think i should buy a brandnew set of sharft/prop that can do reverse and forward.

The shaft carry lotta water in the boat. that’s a big problem… :frowning:


(ahmet omer ozgen) #39

Okay. when armed, after some point the servo out puts seen as 0. as if ESC stopped working.

there may be a power surge. I need a crocodile to ensure the wire isn’t moving(usid lead acid batt.)

One more thing. Only one prop spinned off. its midnight here. too much noise lol.
tomorrow morning i will test the props again.

I think ESC’s are fine.

Lidar is working really good!!

And i need to charge the battery as i have used it much and its only 5ah.

Now i have secured the prop really tight…

Ill try reversing tommorrow.

ps: i turn on the ESC’s after turning on the pixhawk. this may the issue with inconsistency.

I really need to solve the water intake issue.

after everything is stable in Manual I’ll test it on my big open pool. and report it here. I have a pair of extra props in case anything goes wrong.

then ı’ll test the automode on sunday hopefully.

btw: when i change the parameter of ARMING_REQUIRE to 0. it auto arms and i can’t disarm at all.

and i really need to learn how to assign a switch in the RC for ARM/DISARM rather than the thr stick right and left(very inconvenient)

thank you for all the help. I have some hope finally that the boat will make it in automode with collusion avoidance .


(Dave) #40

Set ARMING_REQUIRE to (1), ARMING_RUDDER to (0) then configure a switch of your choice on the Radio. Let’s say it’s switching channel 7. Then set RC7_OPTION to (41).

I don’t follow much of anything else you posted other than the boat takes on water. A lead acid battery? Really, why? Maybe it’s too heavy for the boat and that’s why it’s taking on water.