HTTP Protocol for MAVLink from GCS?

Hello all,

I have been using this HTTP gets method ( while connected to MAVLink through mission planner. I was wondering if there was a similar method for ground stations such as QGC or APM 2? (Any ground station will do, preferably Linux compatible.)

I’m able to run MP on my RPi after following this post.However connecting to the PixHawk is at a very low success rate which is why I’m looking for a similar protocol to get MAVLink data through a different ground station.

Thanks in advance :grinning:

Are you trying to proxy out the telemetry, or is your drone natively udp (or tcp)?

My drone is Native UDP

And the Raspberry Pi is your GCS?
If so, there’s a prebuilt binary of APMPlanner for the pi, although it’s not recent. You can also build QGC on the pi, or put android on the pi to get Tower and QGC through the Play Store. I’ve not tried the android path.

Mavproxy is also frequently run on pi.
Whichever software you choose you’ll need to point it to the correct UDP port, as yours isn’t the default (iirc).

I probably should have explained what I’m trying to accomplish better in the original question.

Once I plan a mission on MP, I’d like my companion computer (RPi) to be able to receive MAVLink data in .txt file format, which I can do through a python code I wrote. I’m currently able to get this process accomplished on my windows laptop through pulling data constantly from the connection in MP. Essentially, I want to do the same thing but on my Pi which requires a UDP/TCP connection there, but I can’t establish one. I’m stumped. I’ve tried MAVProxy there but keep having issues. Perhaps I’m not pointing it to the correct port.

I’m more confused now.
Pi is companion computer. Cool. Much better idea. Grab the apsync or maverick images.
Not sure why you’d want to send mavlink as txt. I’m assuming that this file is sent from your ground station to the pi, where at some point it can be digested and executed? Is that right?

Correct. I now have mavproxy working (better) than it was before. However,
I keep getting “PreArm: compasses inconsistent” repeatedly. I’m guessing
that’s an issue with my flight controller now.

Yeah. Recalibrate and check orientation of external