How to set up my raspberry 4 to communicate with QGC?

After connecting the Pixhawk and Raspberry Pi 4B, I ran MavProxy and the result was positive as follows. As for my next step, I want to link the Raspberry Pi to the program…QGC !!!

Can you provide some details what type of connection you intend to use ?
(I.e. 4G, WiFi, some form of radio,…)

“I have connected the car to the computer, which has the program, using an Ethernet cable. The issue is that the program is not detecting the car at all. Even when I attempted to configure it, it still doesn’t work. What could be the problem?”

Multiple issues:

  • When connecting directly via Ethernet cable you need to have a fixed IP address configured on your computers
  • Why use Ethernet in the first place when you are most likely sending data later via some sort of serial port / device ?
  • In the RPi you’ll need to setup a permanent command to start sending the data across to the Ground-Station.

But if you do want to use Ethernet for some reason here is more info:

The MavLink 2 is not working even though I have followed all the instructions on the website and all the numbers are correct. I don’t know where the problem is.

[UartEndpoint serial0]

[UdpEndpoint local]

The MavLink router is not functioning, even though I have prepared everything as stated on the website, and all the numbers are correct. I don’t know where the issue is.

I’m not sure what instructions you are trying to follow.

In essence once the basics are installed you just need to follow these instructions:

“The MAVLink router is not working for me, and I don’t know why, despite having made all the preparations. I use the Raspbian operating system on my Raspberry Pi 4 with Pixhawk 2.8.4. What could be the reason for this issue, and can you help me troubleshoot?”

“I use a tethered connection between the car and the computer using an Ethernet cable because I want to build an ROV (Remotely Operated Vehicle).”

There are many reasons why it may not be working for you.

I would suggest following this guide and check with serial connection first and perhaps if you want you can try WiFi. If that all works than modify it to work on ethernet.

“I have an issue. When I connected the Pixhawk to Raspberry Pi 4, the QGroundControl program couldn’t sense it, even though the connection is established. I’m using an Ethernet cable and working on a project. Should I connect to the BLE interface first? I need an answer, and thank you in advance. ROV2.”