How to read current into Cube Orange

Can someone tell me (or direct me to documentation) how to set the parameters to read the current from the “Power Brick Mini” that comes with the Cube Orange Standard Set (ADS-B Carrier Board) kit?

I have:
BATT_MONITOR = 4
BATT_VOLT_PIN = 14
and I am reading voltage.

For current,
if I set BATT_CURR_PIN=15, I get a constant reading of 0.
If I set BATT_CURR_PIN=4, I get a reading of around 61.8 amps. It is only varying about 0.3 amps. It should be reading about 7 or 8 amps I expect for my current draw.

My problem may just be BATT_AMP_VOLT, which is currently at 39.877. I cannot find what it should be.

Any help appreciated!

I got these from the defaults in the hardware definition and default params:
BATT_AMP_PERVLT 39.877
BATT_VOLT_MULT 12.02
BATT_VOLT_PIN 14
BATT_CURR_PIN 15
I don’t have a Cube Orange with me right now, but when I did last week it “just worked” ™ with the power-brick-mini, all defaults.
Pin 4 is for the Power2 connector:
BATT2_CURR_PIN 4
BATT2_VOLT_PIN 13

You would have it connected like this:

Shawn, thank you for the quick reply. I am connected like the diagram. I changed BATT_CURR_PIN back to 15 and the reading went to 0. I did a Preflight Reboot and still 0. :cry:

Do you get current readings when armed or flying? EDIT: Driving :slight_smile:
A lot of the power bricks with a current sense resistor (shunt) just dont measure anything below 3 amps, at least not with any accuracy.

I’ve got a couple of metal clad wire-wound resistors I use to generate some current draw that’s measurable. Otherwise in copters we have to do multiple flights/battery drains/charge cycles to compare what the logs say we used and what the battery charger says we used, and adjust the Amps per Volt.

That is very interesting. I am driving now (cutting grass). I don’t really know how much current I am using. I have never measured it with the servos moving. I could do that sometime in the shop with a standard DMM. I do know that I don’t normally blow the 10 amp fuse that I have in line with all my controls. I have blown it when a servo was stalled. I’m using two HiTec D845WP servos, which have a stall current of 10 amps each and a normal no-load operating current of 1.6 amps each. When I power my complete control system from a bench power supply without the servos, it pulls less than an amp. So, I guess my current draw should be in the neighborhood of 4 amps when the servos are not active.

Anyway, that’s a lot of details. I’ll experiment sometime with it in the shop.

It just seems like I should see it move off 0 every now and then.

Thanks for the help.

I have a very similar power setup as Kenny with the same Cube Orange. Same results - good voltage readout, 0 amps (always), default parameter values.

With a previous flight controller (older Pixhawk) and similar power supply, I could see 1-3 amps flowing through the power supply. I do not have all of the electronics and controls routed through the power supply, but I found that the indicated current was a good litmus test as to the stress on the whole system. I’d like to see that again.

1 Like

Those current sensors that come with the Hex autopilots don’t do a great job reading current below 5A or so.

1 Like

Thanks. That must be the problem.

I’ve confirmed that setting the voltage and current monitor to
Sensor: 7:Cube HV module
HW Ver: 8:Cube Orange
worked Ok without any modifications and gave believable current (and voltage) readings on a quadcopter.
image

Well, I have never even been to that page in Mission Planner! But, that is the way it is set, so, I guess the current is just too low. I might measure it with a DMM and see what I get. Since it is below 10 amps, I don’t think I’ll blow up my fluke - might blow a fuse… :slight_smile:

It’d be a good idea to get a Mauche sensor and BEC to give you the resolution and accuracy. That way you’ll be able to tell if servos are operating within bounds or being stressed.

1 Like

mRo also has a power module that uses a hall effect sensor from ACS as well. Single piece unit rather than the 2 piece unit that Mauch uses. Each has a purpose though.

1 Like

Thanks for these suggestions!

Even the Mauch modules with the Hall effect sensor needs a minimum to start reading.

1 Like

I have exactly the same problem and I have not found a solution, the voltmeter measures well but the ammeter measures 0.
I have been trying for 3 days and I have not given any results.

Carlos, How much current do you think you might be drawing?

I have another Orange Cube and I configure it without problem and it measures very well, I have the same parameters in this one that I am mounting now, but this one does not measure the current.
Normally I fly maximum 25 AMP Cruise 8 AMP, but this does not measure anything.
I have changed several Amps, cables even Orange Cube and I can’t do it, it must be a bug from the Autopilot Firmware.

Same problem similar symptoms, first it was working with new Cube Orange , ADS-B base, power module and Ardupilot load but was out of calibration. Attempted calibration but that failed with current reading first sticking at a value then reading 0 after several attempts at calibration. Have used multiple power bricks, ports, settings… Anyone solved this problem?