How to make Yaw, Roll and Pitch smoother

I am new to drone world,
I have successfully built my Tarot 680-Pro.
I could fly it, but my Yaw,Roll and Pitch are too sensitive, so thought to autotune.
So I did change Roll/Pitch sensitivity and on fly tried autotune.
Unfortunately my hexacopter crashed during autotune, I saw logs were dumped some Chinese language and those big files were not accessible, literally OS forced me to format my SD card to use it.
So Sorry no syslog to analyse.
Transmitter: “FrSky Taranis Q X7 ACCESS 2.4GHz 24CH Mode2 Transmitter with R9M 2019”
ESC: Hobbywing XRotor 40A-OPTO ESC
Motors: Tarot 4108 High Power Brushless Motor (380kv)
Flight Controller: PIXHAWK PX4 2.4.7
Firmware version Copter 4.0.5
Please help me what was wrong?
Any way to make drone smoother, smooth yaw like slow motion.

Post the parameter file if you don’t have a Flight Log.

My OCTO was super twitchy and I adjusted the ATC_INPUT_TC value. I used .35 and it was so much easier to control.

ATC_INPUT_TC: Attitude control input time constant

Attitude control input time constant. Low numbers lead to sharper response, higher numbers to softer response

0.5:Very Soft,0.2:Soft,0.15:Medium,0.1:Crisp,0.05:Very Crisp|

Exactly as smartdave said…
And you can also try lowering these a bit:
If they have values like 52647.9 you can just round them, like 52500 which wont make much noticeable difference. You might want to go down to 40000 (for example), maybe lower them in 10% steps.

Thanks a lot. I shall try it.
I did not get one thing, why did it crash during auto-tune? I found there are many complaining same thing.
Is team looking into auto-tune issue seriously?
Should we avoid it?

How high were you in the air? How did it crash? Without any logs the answers to these questions will help

When you performed the autotune did you go straight to .1 aggressiveness?

Height was around 40 feet, it was moving here and there checking yaw and suddenly crashed tending one side.
Should i install using platform latest fmuv4 or 5 as I have pixhawk 2.4.7

Auto Tune is a proven tool, there is nothing for the team to “look into”. It would have been something specific to your craft or the flight circumstances that caused the crash.

No, those are not appropriate for that Pixhawk. Pixhawk1 is likely the correct firmware target.

As @dkemxr says Autotune is reliable. However for me I like to start at .05 vs .1 I find the twitches a little less aggressive. Once the .05 is done, I will then do a .07 then finally a .1

Today again my hexacopter crashed that too from height

Flight Controller: PIXHAWK PX4 2.4.7
Firmware version Copter 4.0.5
Transmitter: “FrSky Taranis Q X7 ACCESS 2.4GHz 24CH Mode2 Transmitter with R9M 2019”
ESC: Hobbywing XRotor 40A-OPTO ESC
Motors: Tarot 4108 High Power Brushless Motor (380kv)
Frame:Tarot 680Pro


Can anybody have look at log and help me what was wrong.

You posted this is in 6 different threads? 7 threads and counting.

Sorry for that, i did it intentionally to get help earlier.

MrNams, there are quite a few things you need to accept, understand, remember. Keep in mind I (same for everyone else who replied) just want to help you and the following people who will read this post.

  1. You said it yourself, you are new to drones. You bought a big (really big) drone to start with. Your crashes will cost a lot, and your frustration will climb quick. I would suggest to buy a smaller cheaper platform to learn. If you say that budget is tight, then you have to find a way to practice on smaller/cheaper ones.

  2. You are new and you are making quite some errors in your approach. To say that volunteers (yep, ardupilot is open) are not really looking into something (autotune) is insulting, especially when it is highly probable it is an error from your side.

  3. You spammed to get attention, just like annoying ads. Imagine how you don’t like your tv show stopped by ads, your approach feels the same to the people trying to help you.

  4. If you find that the information is not well written or too complicated, ardupilot is not for you. Opensource, you have to accept that the money you don’t spend goes in the time you must take to read, experiment, help others (like I’m doing now), and why not, help with the docs.

I took some time to educate you, just like others did for me. Please take it in with a smile and contribute to this beautiful project. I know from experience that smiling when your 2000$ drone crashes is hard, but mandatory in this field. Challenge is the fuel.


Thanks for detailed reply, Yes now I realize I might have built small quad.
But at that time I did not imagine that I shall face such issues, my understanding was everything is in stable, and I just have to assemble and use it, but now I realize there are a lot to learn and make it.
Anyway I cant go to past to change it, now I have to make whatever in my hand i.e. Taro 680 Pro.
Yes I am studying and trying to understand various parameters and their values, their impacts etc.
I could reproduce crash with lower altitude to find root cause of my hex unstability, sharing log file as below, help from you is highly appreciated to analyze log file and tell me cause of crash

If you look at the roll from ekf2 and the roll measurement from gyro, you can see that the gyro leads the ekf corrections, which seems to indicate that the apm board saw roll oscillations that it tried to correct. Those oscillations became more and more intense,
causing your crash.

What caused the gyro to measure those oscillations?

  1. Wind hit the UAV and it did’nt manage to correct the modified attitude
  2. A component of the craft became loose and shifted the CG, making the oscillations start (loose battery maybe?)
  3. Bad gyro
    Since the oscillations seem to follow a near perfect sine wave, and the frequency of oscillations is low (4 cyles in 5 seconds = 0.8Hz), I’d bet a component became loose and your craft could not correct enough (feels like an integral error). Though since
    you say it happen more than once, I assume you tied everything well at least the second time…

With that in mind, looking at the PIDs since the correction was not handled correctly (got the params from “Create KML+gpx” button in MP from the .BIN file) , we can see that your autotune aggresiveness is set to 0.1. Like smartdave said (accurate name),
you should start with a smaller value, say 0.05.

All in all, I don’t think you followed the basic steps to begin flying.

Do this:

FOLLOW EACH LINE ONE AT A TIME. When you are done, go through it again to confirm.

Tuning Process Instructions — Copter documentation

Pilot’s preparation for first flight¶. The first takeoff of an untuned multirotor is the most dangerous seconds of the aircraft’s life. This is where the aircraft could be very unstable causing a sudden increase in power when then results in the aircraft jumping
into the air, or it may be so poorly tuned that you have insufficient control over the aircraft once it is airborne.

@charlesmarseille Tons of thanks for valuable time and detailed reply.
There is no loose as far mechanical parts, all screws are fitted with thread locked and nothing loose,
I think its issue of EKF2 that i need to study to get permanent rid of EKF2 error, that will solve my problem.

I think your understanding of EKF is flawed. Read this:
It is very technical, but grab a coffee and take the time to get a good grasp of how stability is determined.

Your problem is first that you don’t follow procedures well established before. Follow the startup guide and change parameters accordingly. By looking quickly at your params,I saw at leats 5 that were wrong. Start with this, post back when you have new flight data. keep logging everything as much as possible and post your bin file.

Thanks Just got to know about “Initial Parameter Calculator” plugin and wrote parameter generated by it

Just change INS_GYRO_FILT to 20 all the other values should be ok

@xfacta Thanks Shawn