Servers by jDrones

How to make the rover keep still for few seconds after triggering a Relay command?

Dear community,

Is there any way to let the vehicle stop for a few seconds after triggering the relay output ?
I tried to add the Condition_Delay command before the next waypoint command, but the vehicle still immediately moved to the next waypoint. Also there is no DELAY command for Rover. Thank you so much.

Best regards,
Mirko

Did you look into LOITER_TIME?

CONDITION_DELAY will only act on a DO command.

The first field of a waypoint command holds a delay so that can be used to stop the vehicle for a few seconds.

We’ve been meaning to add support for the NAV_DELAY command (issue on the to-do list is here) although it’s not totally clear to me how it could be tied to the DO_RELAY command which is a DO_ command (i.e. a command that doesn’t affect the position of the vehicle).

Scripting is another potential option but it doesn’t have the ability to control the vehicle’s position yet (i.e. can’t trigger a delay) but that is coming.

I’m try to build a rover that can take illuminance measurement on the field. So the Relay command is used for collecting data. However, the vehicle needs to stay still while it’s taking the measurement for accuracy propose. That’s why I need to the Delay Command so that the vehicle will not move immediately right after triggering the Relay command :sob:

A mission with tons of waypoint commands would do it. I know that’s painful to setup of course.

If we enabled scripting to be able to change modes then you could write a small script to switch the vehicle to Guided mode, wait a few seconds and then trigger the relay, then switch the vehicle back to Auto…

Thank you so much. But after reading the content of the link, I still have no idea how to write the script to make the vehicle keep still for few seconds after every Relay Command. Will the script conflict with the the waypoints schedule ?

@Mirko_Zhou,

The scripting is still under development so it’s not quite ready yet. Hopefully in the next month or so we will start beta testing Rover-3.6 and I hope we will include some ability to control the mode.

Until then maybe try the method of creating a mission with tons of waypoints.

I tried to add the Condition_Delay command before the next waypoint command,
but the vehicle still immediately moved to the next waypoint. Also there is
no DELAY command for Rover. Thank you so much.

Aren’t you after NAV_DELAY?

Mirko

Peter

Hi Peter. Yes, I’m after NAV_DELAY command, which is available for other vehicles such as copter. However, this command is still not available for Rover yet :frowning:

Hi Michael,

I noticed that you have implemented NAV_DELAY command for Rover. But I still couldn’t find it even after I updated the firmware to the latest one

NAV_DELAY is included in Rover-4.0.0 which should start beta testing next week. Below is a video of it in action on 3 boats:

Servers by jDrones