How to make de-transition smoother in AUTO

My manual de-transitions (FWBA-QLoit) are smooth. But my auto de-transitions are abrupt and violent with very quick pitch up followed by an abrupt stop and yaw.
This leads to unnecessary stress in the airframe and higher risk of control loss. Also this just makes for really scary de-transitions.

Adjusting the distance between WP and VTOL_LAND helps a bit but doesn’t solve the problem. I’ve tried playing with Q_TRANS_DECEL param but it does not seem to be used in AUTO.

Any help or advice would be great. Thanks

Hi Kyle,

I have seen this reported several times now. The fact that you don’t see the issue when doing manual transitions confirms why I haven’t seen it. I haven’t used AUTO mode in years so I can’t help you much.

Here is one other thread below reporting a similar issue. Perhaps it will help.

Vtol oscillate in pitch while back transition

I am interested to know as well.
I realised that my drone actually had a stopping distance of 30meters changing from fixed wing to quad from 25m/s to 10m/s
I set it to 40meters ahead of the waypoint to change to quad to prevent it moving out of place.

I assume I need to set my speed down to around 15m/s maybe around 50 meters before the last waypoint before changing to quad.

If anyone had a better solution, please do share.

Make sure that your settings are appropriate as described in the Hybrid RTL section of the WiKi. It seems to have settable parameters for proper transition control back to copter modes. If you can post a .bin file of your flight along with a description of the issue, it would provide some good data to look at.

Hybrid RTL

The final option for RTL in a QuadPlane is to fly as a fixed wing aircraft until it is close to the return point at which time it switches to a VTOL RTL as described above. To enable this type of hybrid RTL mode you need to set the Q_RTL_MODE parameter to 1.

The initial altitude that will be aimed for in the fixed wing portion of the hybrid RTL is the same as for a fixed wing RTL. You should set your rally point altitude and ALT_HOLD_RTL options appropriately to ensure that the aircraft arrives at a reasonable altitude for a vertical landing. A landing approach altitude of about 15 meters is good for many QuadPlanes. This should be greater than or equal to the Q_RTL_ALT values.

The distance from the return point at which the aircraft switches from fixed wing to VTOL flight is set using the RTL_RADIUS parameter, or if that is not set then the WP_LOITER_RAD parameter is used. The aircraft will then slow down as it approaches the return point, aiming for an altitude set by Q_RTL_ALT.

Once the return point is reached the aircraft begins to descend and land, exactly as described in the VTOL RTL mode.


If you prefer to do return to launch as a VTOL aircraft (like a multirotor would do) then you can use the QRTL flight mode. That flight mode will transition to VTOL flight and then fly at the Q_WP_SPEED speed towards the return point, at an altitude of Q_RTL_ALT.

Once the return point is reached the aircraft will start a vertical descent towards the ground for landing. The initial descent rate is set by Q_WP_SPEED_DN. Once the aircraft reaches an altitude of Q_LAND_FINAL_ALT the descent rate will change to Q_LAND_SPEED for the final landing phase.

In the final landing phase the aircraft will detect landing by looking for when the VTOL motor throttle drops below a minimum threshold for 5 seconds. When that happens the aircraft will disarm and the VTOL motors will stop.


Hi zhaowei,

Thank you for your comment. It sounds like you have lowered the airspeed on the final approach before transition back to copter mode. Do you have an example mission plan that you can post?

Cheers and welcome to the VTOL Plane forum!



欢呼,欢迎来到VTOL Plane论坛!

Hāi, zhàowēi,

gǎnxiè nín de pínglùn. Tīng qǐlái nín zài guòdù huí zhíshēngjī móshì zhīqián yǐ zài zuìhòu jìn jìn shí jiàngdīle kōng sù. Nín yǒu kěyǐ fābù de shìlì xìng rènwù jìhuà ma?

Huānhū, huānyíng lái dào VTOL Plane lùntán!

I want to make sure i’m getting this correct, will increasing or decreasing the Q_TRANS_DECEL make the aircraft transition slower over a longer distance?


That’s a good question. I am not familiar with that parameter. It sounds like what we may be looking for and I wonder if it works in both manual and AUTO transitions.

On my Fighter 4+1 VTOL, it is set to 2. On my Freeman Tilt-Rotor VTOL, it is set to 4. Both transition fine but I am not using AUTO mode.

i’ve seen Q_TRANS_DECEL before in the doc but not sure what it actually does. If it’s for the estimation of stopping distance in a coasting decel, does it mean the plane automatically selects the point of transition before reaching nav auto land wp, based on current speed? if that is the case then it will be useful to find out what that decel is in manual flight and use it for auto. I haven’t tried it myself tho.

I agree, I can’t find an adequate explanation of what it does.

The lower the parameter, the longer the transition duration/distance.


I’ve trying Q_TRANS_DECEL to 1,3 in 4.1.6 Arduplane and you have 3 times small transition.

I imagine that the result in the uav is put pitch up for transition until it reach 1.3 decal and then pitch neutral and pitch up a new time to reduce the speed.

Did anyone try reducing speed before de-transitioning? How did it go?
Something like:

*After some tests in SITL it appears any DO_CHANGE_SPEED is ignored on LAND/RTL and it always reverts to TRIM_ARSPD_CM. So I guess you’d have to set cruise speed to be the ‘reduced approach speed’ you want, and then use a change_speed after takeoff to fly the mission at whatever speed

I am also looking to make my RTL transition a bit smoother. Here is a video that shows the current behavior. I am wondering a slower Q_TILT_RATE_UP would make a difference. I have it set to 20 at the moment. ZMO Quadplane VTOL Transition - YouTube

I don’t use ArduPilot but in my previous conversions with PX4, I delayed the back transition between 4-6 seconds, depending on the airframe. This way, it would slow down enough right before stall to transition to MC mode. That basically stopped it from fighting forward momentum as it attempts to maintain the GPS position for the descent. Hope that helps.

Good luck.

1 Like

@rollys can you explain what parameter you set to add that delay? The video I posted is from a RTL in full auto mode. Thanks

As I mentioned earlier, I don’t use and not familiar with ArduPlane but a quick scan of the parameters, I found these. I don’t know if it will help. Maybe @tridge could chime in.

Good luck.