How to increase motor thrust at speed

When in forward flight it tends to lose height, but does not recover it when stopping. The log shows that the amp draw is not increasing with speed, and the voltage is not sagging unduly. Is there a setting for increasing power with pitch?

What flight mode are you using?

There is no altitude holding function in Stabilize; you will have to make the adjustment at your throttle stick. Just physics, really.

If you are flying in Alt Hold, Pos Hold, Loiter, Auto or anything that has auto altitude hold, you will need to dig into why it is dropping. This could be caused by issues with the hardware or potentially an altitude controller tuning issue. IMO, I would check your barometer and alt measures first.

What flight controller are you using? Can you post a picture? Is your barometer exposed to wind and sunlight?

Can you post a flight log that features what you’re describing?

There is a parameter for this, actually. Make sure ATC_ANGLE_BOOST = 1. If it is already set to 1 (it should be, because that is the default), then do what ekliptiko said. We will need more information, including a flight log, to diagnose the problem.

ATC_ANGLE_BOOST does equal 1, so not that. Here is the .bin file.

Increase ATC_THR_MIX_MAX or MOT_THR_MIX_MAX depending on arducopter version.

…well ive been wrong before! Thanks! I learned today. Edited my post for accuracy.

I think @Mallikarjun_SE might be onto something here:

After you have a good tune, you may wish to increase ATC_THR_MIX_MAX (or MOT_THR_MIX_MAX in Copter-3.3) to 0.9 (default is 0.5) to increase prioritisation of attitude control over throttle. This can reduce the pitch overshoot sometimes seen (especially on copters with large propellers) in AltHold if the vehicle suddenly slows after performing fast forward flight. In this situation wind catches under the propellers providing lift but also disturbs the vehicle’s attitude leading to a conflict between throttle and attitude control. The danger in increasing this parameter’s value is that if the rate gains are later raised so high that the vehicle oscillates badly it may be difficult for the vehicle to descend (because it will prioritise trying to correct the attitude oscillations and never reduce throttle sufficiently).

From the Autotune page

Thank you. I have changed ATC_THR_MIX_MAX (and_MAN) to 0.7. Hope to get out his evening to test. Will report back.

I don’t think increasing the throttle mixer is what you want. Increasing that value gives more priority to attitude control and less priority to altitude control, which is ostensibly the opposite of what you want. You may want to try reducing it, but be on the lookout for the problem that is described in the tuning guide: the drone may pitch violently if you suddenly slow down after fast flight.

I cant find any incidences of altitude loss in the log you provided.

It may just be that you’re running out of thrust.The fastest flight speed in the log had the motors go up to 1900 PWM, which is essentially maximum if you include headroom for yaw control. Go much faster, and the drone might have started sinking.

Had a quick flight last night. There was hardly any wind, which may have made a difference.
Up to about 15 mph, the altitude remained constant, but above that there was a steady drop.

You have made me think about running out of power! Never crossed my mind. Speed relates directly to pitch, so it might be better to limit the maximum pitch (tilt?) angle to keep speed within bounds. No log available from last night as I had been fiddling about with the parameters to log, resulting in a log file about 10 times the normal size.

More testing required.

Yeah, using ANGLE_MAX to limit the lean angle is an effective way to limit airspeed. Alternatively (or in addition), WPNAV_SPEED and LOIT_SPEED will limit groundspeed in Auto/Guided and Loiter modes, respectively.

I’ve set the LOIT_SPEED to 7.5 m/s, and at this speed height loss is minimal. If I need to go faster I can switch to Poshold. The main reason for wanting high speed is being caught down wind and struggling to get home. And I sometimes just like to go fast !!

Hi Andrew,
Try also setting
MOT_BAT_CURR_MAX 20 (test and increase as required)
Based on your log - there’s a current spike to about 35amps and the battery voltage sags a lot - but also the battery appears weak or not charged properly. Mostly your current draw is below 20 amps.

Try these settings for increased safety and battery life:
BATT_FS_LOW_ACT 2 (3 for SmartRTL)
BATT_LOW_MAH 1000 (or 0 to ignore - better when rebooting and reusing batteries)
-> ARMING_VOLT_MIN 11 (no point arming if failsafe is going to trigger right away)
-> BATT_ARM_VOLT 11 (name depends on which version Copter you have, see the one above)

If you get unexpected or frequent battery failsafes then maybe consider getting a better battery and charger. Check your RTL settings too in case a battery failsafe causes more damage than good trying to do a RTL into the nearest tree. Be prepared to switch to Stabilize or Althold and take control your self, but definitely land when you get a battery failsafe rather than changing the settings to allow longer flight time.

Hello, we are having exactly this issue. And have googled the hell out of it with no luck.
Our quads are very over powered with large props relative to empty mass.
Small one is 2kg AUW with 13” props on Tmotor U3 motors.
Larger one is 3kg AUW with 15” props on U5 motors
Whenever flying at speed in loiter and letting the sticks go it would pitch violently to near vertical, Both do same also very evident when flying into a strong head wind.
Our CG is slightly to the back of the FC by about 3-4cm

This on Tmotor carbon pops, changing to cheap high pitch carbon props almost eliminates this issue but they are horribly inefficient with high drag, so undesirable.

Setting ATC_THR_MIX_MAX to 0,9 helps but it is still not perfect.
What other settings may help resolve this violent pitching?

That parameter is probably still the correct solution. You can actually increase it to higher than 0.9; the value range shown in the parameters list is just a suggestion for most normal copters.

I found this in the code:

    // parameter description recommends thr-mix-max be no higher than 0.9 but we allow up to 5.0
    // which can be useful for very high powered copters with very low hover throttle

Sounds like this applies to you, so try increasing it some more.

1 Like

Thank you very much, will be testing this out today.
We have been bashing our heads on this for way too long.

Another question if you don’t mind, the FC/IMU is very close to the thrust centerline with the CG about 1,5-2cm behind it. Adding 30g to the nose levels it. Is this really necessary? Don’t want to fly 30g more than is needed.
The fascinating thing is these drones flew perfectly with the old Naza MV2 FC’s
Put the Pixhawk in and the flight is terrible.

Again thank you for helping, would never have taken that setting past 0,9 was it not for your code reading.

1,5-2cm behind it. Adding 30g to the nose levels it. Is this really necessary? Don’t want to fly 30g more than is needed.

Not necessary. It will be fine.