Servers by jDrones

How to guide: Mission Planner on Raspberry Pi

I spent a few hours today trying to get this working on a 4GB Pi4. Could not get MP to start using the mono installation as per the how-to doc, same as the one on the mono page. Ended up reflashing raspiOS and just installing mono using sudo apt install mono-complete which then let MP start up. Can’t seem to connect to a flight controller though, so not sure what’s going on.

I’m also trying to build a pi-based GCS but can’t see this working as a reliable solution right now. Thinking of switching to a latte panda or jetson instead.

Hi, have you looked at https://github.com/OpenHD/Open.HD/wiki might be an option for you. Will give you a few options for a ground station and also the possibility to control some outputs

Update on the Data screen map tearing (smearing) on Raspian beta 64bit:

Prefetching the map data has resolved the map tearing issue on the Data screen. I had the same issue on both the ethernet port and the builtin wifi, so the internet connection speed shouldn’t be the problem. I run 1g wired inside and have fiber connecting the house.

Maybe Michael_Oborne could explain.

Hi Patrick
Does the SD image that you recommend for the raspberry pi work with the navio 2 flight controller?
Navio 2 + raspberry pi has its own image of Emlid.
Can the Sd image that you recommend work on the ground on the raspberry pi 4 and can it connect with the raspberry pi 4 on the drone with the Emlid image?

Raspberry OS updated kernel 4.19 to 5.4
I updated all raspberry pi 4 and like, I find a much faster startup boot

On the raspbian website I am surprised to see that the new SD image with the new 5.4 kernel is only 32 bit. They unified everything into a single 32-bit image for all raspberry p models in 32-bit

What happened to the 64 bit version?

I have that claim with the emlid people.
Their documents say that once the image is installed, the system must be updated first: sudo apt-get, sudo apt-get dist-upgrade.
this updates kernel 4.19 to 5.4
Emlid does not want to update his sd image for navio 2 to the new kernel 5.4

Thanks for your help

@ kerococoec Jorge Andres Loor Velasco

Could you please move your off topic questions to another thread? It makes it difficult to follow the progress of MISSION PLANNER on the RASPBERRY PI.

Thanks for understanding …

not sure if anyone has encountered this same issue, but when I open MP on the Rpi 7" touchscreen it opens much larger than the screen and there’s no way to resize it because all the controls are off the edges. I’ve done all the usual fixes in config and resolution and nothing makes a difference. This doesn’t happen when plugged into a HDMI display so it seems like MP just opens at a fixed size regardless of the size of the display?

If I remember correctly, there is a minimum screen size for MP. I ran into this years ago trying to run it on an EeePC. Not sure what it is anymore, maybe check the docs?

2 Likes

min res as about 1000x600 ish.

so anything large than this would be ideal ie 720 is fine

any chance you can show me what you mean by tearing?

Like you get when you hold and drag but the pixels don’t get updated and smear. On release of the mouse, surrounding blocks would stay smeared while the ones around the mouse pointer would update correctly. Sometimes the window would only update one side, usually the right side only.

I’ve since prefetched, and it is working as expected. I just tried to run a clean install to get a screen shot without the prefetch, I moved the $HOME/‘Mission Planner’ folder to another name, and did a clean install of MP to a test directory. I had a few problems with no map data initially, but that has cleared up as I quit and restarted MP.

Hello,

Anyone tried Mission Planner with windows 10 on raspberryPi (https://www.worproject.ml) ?

1 Like

discord is the worst way to share this image as we cant even enter the chat as it bugs all the time and the download section not visible.

Wrong topic maybe?
Did you mean the windows 10 image?

yes the win 10 img cant be found

i am trying to go from raspian to win 10 as we feel this linux version is not reliable . not as the pc version we been using.
we are trying to make mission planner live on rspi4 however its not really fast , the joystick does not work . ( maybe a kernel issue) and when we try to connect to model it crash and closes from the mono run
any idea why?

I never experienced the problems you are mentioning and feel like, Windows 10 would be less reliable and slower on a raspberry pi4 than raspbian.

Did you make sure to follow every single step in my guide? Did you start with a clean raspberry installation?

Joy sticks are at the moment not supported due to directX not being supported on raspberry.

Please refer to Mission Planner on Raspberry Pi 4, no Luck for further help.

Cheers

Edit: surely, mission planner on a raspberry is not quite as fast as it could or should be on a 64bit system. However, we haven’t found a promising solution for this. It’s by no means unusable however.

The issue is known then. We are switching to qgc. And also having problems with Debian or Raspian. Version. I think v18.04 Debian will work however the rpi4b is a 1.5ghz quad core 64bit ARM CPU. We would like to do a clean install on Linux that works. So far we are not able to run the application form terminal. And can’t seems be allowed to run to finish the steps. It “Vers error”

joystick support coming soon

2 Likes

Being an absolute noob to Raspberry Pi and Linux in general installing Mission Planner seemed like a great place to start. I am pleased to say using this guide I was able to install Mission Planner 1.3.74 on Raspberry OS, Ubuntu 20.10 Desktop for Pi (Both on a Pi 4 4gb) and on Ubuntu 20.10 (On an old iMac). All three installations work, except for one problem: I can not get either of the Pi installs to actually connect to a flight controller. The old iMac will connect, but that’s not what I want to haul to the field. On Ubuntu I will get a connection error, and on Raspberry OS Mission Planner will crash.

Any hints or things to look for? Thanks!

Servers by jDrones