Mission Planner on Raspberry Pi4 - Windows 10

Hello, i just finished installing windows 10 on raspberry pi4. It works pretty good and runs MP natively. Best of all it supports hid joysticks for anyone interested.
Just go to https://discord.com/channels/711407999503302696/742586223247360121 and download the image on the downloads section and write it with balena etcher on an sd card.
At the moment the latest image supports up to 3 gb of ram and wifi&bt do not work.
Usb and ethernet do work.



Why did you choose for windows 10 instead of raspberry OS? Dus it run on 64 bit?

Because on rasp os the joystick doesn’t work, it is 10 times easier to install and can be updated to latest versions just as the regular windows 10 app.

It works perfect
raspberry pi 4, 4g ram, kernel 5.4, MissionPlanner 1.3.73, raspbian os

I Cannot download file. Cannot see where to find the download link at Discord.
Any idea ?


Did you overclock your PI 4 or are you on stock clocks. Also have you tried streaming video to MP?

hello Barry_Bolton

I liked missionplanner on raspberry pi 4 at first, after already connecting the drone with a navio2 + raspberry pi 4 too, it got slow.
Install Manjaro 21 minimal 64 Bits and add LXQT as desktop, install Qgroundcontrol and Mission Planner, it worked better than with raspbian OS.

In Manjaro with AUR you find everything:
qgroundcontrol and mission planner.

installing qgroundcontrol and mission planner in manjaro is child’s play.

You install everything with just 2 clicks

could someone point me in a little better direction? im trying to communicate with my drone from my ground station. . i have been able to connect/ with my drone via mavproxy and am able to send it to my pixhawk. ive been thinking about connecting over remote access and controling it likee that so then i can view my raspberry pi camera. but then im just unsure where to go from here. any support and help would be appreciated. thank you!

bro I couldn’t open the mp on raspberry 4 4gb . Can you help me

corrado, provided link leads to a “dead end”. Can you update it?

Thank you!