How to guide: Mission Planner on Raspberry Pi

How are you connecting to the flight controller? USB, Bluetooth, …

So far, just direct USB. I will be trying Wi-Fi later but I want to get this sorted first.

so looks like there is a way to make MP run without changing the opengl settings

LIBGL_ALWAYS_SOFTWARE=1 mono /home/pi/MissionPlanner-latest/MissionPlanner.exe
1 Like

Thanks! I’ll give that a shot next chance I get. I’ll let you know what happens.

Sorry I can not help here, I also used a RPI 4 (8G but with 32 bit OS) and installed MP 1.3.74 and it connects with USB to many different brand FCs running ArduPilo, ArduRover, ArduCopter. If the MP is crashing on RPI maybe try to get a log?
I would just redo the installation again and look for some suspect messages during that process…

Due to some bumbling of my own with another project my raspberry image was cleared, however I still have the Ubuntu Pi image running. I tried the command posted by @Michael_Oborne and I didn’t have any luck with that however I noticed in terminal that the Pi was recognizing the Matek FC.

I came across the instructions for installation of QGC onto Ubuntu and it mentions issues with the serial modem manager. I ran the suggested commands:

sudo usermod -a -G dialout $USER
sudo apt-get remove modemmanager -y
sudo apt install gstreamer1.0-plugins-bad gstreamer1.0-libav gstreamer1.0-gl -y

That seems to have everything working. I’ve now been able to connect a Matek F405 Arducopter build by USB to a Raspberry Pi Running Ubuntu 20.10 Pi Desktop.

Are you running Ubuntu or raspberry OS on the Pi?
There are cases where it is needed to add the user pi to the dialout group. However Normally it’s not necessary for a USB connection.

In any case: on raspberry OS it should be sufficient to just run sudo usermod -a -G dialout $USER where $user=pi

The code michael gave us does not have to so with your issue. It’s just a minor update to my guide. (Thanka for that information by the way michael)


I misunderstood his comment then. It didn’t hurt anything for me.

I’m currently running Ubuntu 20.10 Pi Desktop on the Pi.

I tried earlier with Raspberry OS, however that image was wiped out and I haven’t rebuilt it to try Mission Planner yet. So far it seems to be working well on Ubuntu so I may just run with that for a while.

Thank you @Holly918 for your instructions. I know you meant them for Raspberry OS, they were enough to get me going on Ubuntu. (Okay, I got a little mixed up on the OpenGL part but that’s my problem :slight_smile:)

1 Like

Massive thanks to Michael and Bastiaan here.

So I can report Pi4 8GB works well, I followed the document with the exception of .so file addition, running version.

OpenGL still needed to be disabled.

1 Like

Not sure this is good place to post this

Have Raspberry PI OS on a PI 4B (8G), followed the instructions here. It works but every time I start MP it launches a small window and halts, closing the window will make MP resume and launch.
The message in the window is:
Please upgrade your mono version to 6+

When I try upgrade it with command: sudo apt install mono-devel
it responds back:
mono-devel is already the newest version (

But over at they say latest version is 6… something, not 5…

Any idea how to upgrade mono?
I hope an upgrade will also resolve some issues with some windows not display correctly in MP.

just follow the instructions on the mono site for raspbian.

Thank you, that helped and also fixed all the other window display issues I had previously. I redid the whole installation but followed the instructions on the Mono site.

Great job and thank you very much. Installed MP on my Rpi 3b+ and its running quite well so thank you to everyone who made this possible. Can any one help me with creating a system service to start MP on start up. I created the system service file but its not starting up.

Haven’t tried it, but you may have luck running a shell script instead of trying to run the mono command directly from the system service file.

Thank you but how do i do that?

Instead of having the mono command on your EXEC line in the system service file, place the mono command in a shell script file that the EXEC line executes.

The voice of Mission Planner suddenly stopped working on my RPI 4.
I have uninstalled the package festival and reinstall it again but it will not speak.
The loudspeakers are work as before when using a browser with sound streaming etc.
Any tips?
Next is to try uninstalling MP and reinstall it. after that flashing a new SD card from scratch but this is many hours project to get to get working.
So just happy with any tips to try?

check that festival works manually.

That was helpful. more voices etc… nice
Yes, it works, he really say Hello World

So something else is broken in my installation?

Just unzipped the mission planner again and sounds work. Its when installing MP Beta version the sound is lost.

1 Like