How to guide: Mission Planner on Raspberry Pi

If I remember correctly, there is a minimum screen size for MP. I ran into this years ago trying to run it on an EeePC. Not sure what it is anymore, maybe check the docs?


min res as about 1000x600 ish.

so anything large than this would be ideal ie 720 is fine

any chance you can show me what you mean by tearing?

Like you get when you hold and drag but the pixels don’t get updated and smear. On release of the mouse, surrounding blocks would stay smeared while the ones around the mouse pointer would update correctly. Sometimes the window would only update one side, usually the right side only.

I’ve since prefetched, and it is working as expected. I just tried to run a clean install to get a screen shot without the prefetch, I moved the $HOME/‘Mission Planner’ folder to another name, and did a clean install of MP to a test directory. I had a few problems with no map data initially, but that has cleared up as I quit and restarted MP.


Anyone tried Mission Planner with windows 10 on raspberryPi ( ?

1 Like

discord is the worst way to share this image as we cant even enter the chat as it bugs all the time and the download section not visible.

Wrong topic maybe?
Did you mean the windows 10 image?

yes the win 10 img cant be found

i am trying to go from raspian to win 10 as we feel this linux version is not reliable . not as the pc version we been using.
we are trying to make mission planner live on rspi4 however its not really fast , the joystick does not work . ( maybe a kernel issue) and when we try to connect to model it crash and closes from the mono run
any idea why?

I never experienced the problems you are mentioning and feel like, Windows 10 would be less reliable and slower on a raspberry pi4 than raspbian.

Did you make sure to follow every single step in my guide? Did you start with a clean raspberry installation?

Joy sticks are at the moment not supported due to directX not being supported on raspberry.

Please refer to Mission Planner on Raspberry Pi 4, no Luck for further help.


Edit: surely, mission planner on a raspberry is not quite as fast as it could or should be on a 64bit system. However, we haven’t found a promising solution for this. It’s by no means unusable however.

The issue is known then. We are switching to qgc. And also having problems with Debian or Raspian. Version. I think v18.04 Debian will work however the rpi4b is a 1.5ghz quad core 64bit ARM CPU. We would like to do a clean install on Linux that works. So far we are not able to run the application form terminal. And can’t seems be allowed to run to finish the steps. It “Vers error”

joystick support coming soon


Being an absolute noob to Raspberry Pi and Linux in general installing Mission Planner seemed like a great place to start. I am pleased to say using this guide I was able to install Mission Planner 1.3.74 on Raspberry OS, Ubuntu 20.10 Desktop for Pi (Both on a Pi 4 4gb) and on Ubuntu 20.10 (On an old iMac). All three installations work, except for one problem: I can not get either of the Pi installs to actually connect to a flight controller. The old iMac will connect, but that’s not what I want to haul to the field. On Ubuntu I will get a connection error, and on Raspberry OS Mission Planner will crash.

Any hints or things to look for? Thanks!

How are you connecting to the flight controller? USB, Bluetooth, …

So far, just direct USB. I will be trying Wi-Fi later but I want to get this sorted first.

so looks like there is a way to make MP run without changing the opengl settings

LIBGL_ALWAYS_SOFTWARE=1 mono /home/pi/MissionPlanner-latest/MissionPlanner.exe
1 Like

Thanks! I’ll give that a shot next chance I get. I’ll let you know what happens.

Sorry I can not help here, I also used a RPI 4 (8G but with 32 bit OS) and installed MP 1.3.74 and it connects with USB to many different brand FCs running ArduPilo, ArduRover, ArduCopter. If the MP is crashing on RPI maybe try to get a log?
I would just redo the installation again and look for some suspect messages during that process…

Due to some bumbling of my own with another project my raspberry image was cleared, however I still have the Ubuntu Pi image running. I tried the command posted by @Michael_Oborne and I didn’t have any luck with that however I noticed in terminal that the Pi was recognizing the Matek FC.

I came across the instructions for installation of QGC onto Ubuntu and it mentions issues with the serial modem manager. I ran the suggested commands:

sudo usermod -a -G dialout $USER
sudo apt-get remove modemmanager -y
sudo apt install gstreamer1.0-plugins-bad gstreamer1.0-libav gstreamer1.0-gl -y

That seems to have everything working. I’ve now been able to connect a Matek F405 Arducopter build by USB to a Raspberry Pi Running Ubuntu 20.10 Pi Desktop.