How to get my servos moving?

I’m setting up my first plane with Ardupilot and i"m trying to get the servos moving. It’s a simply EasyStar 3 and I managed to bind my radio to the elrs receiver which is connected to my Pixhawk 6c. As you can see in the screenshots below I can see the bars moving in both Radio Calibration and Servo Output in Missionplanner when I move the sticks on my radio. The PWM values in Radio Calibration and Servo Output are not the same though, not sure if that is a (big) problem?

The Pixhawk 6c comes with two PWM blocks which can be connected to FMU PWM OUT and I/O PWM OUT. Since it’s such a simple plane I think I only need one PWM block, and I *think I need to connect it to I/O PWM OUT. Am I correct so far?

So as you can see in the picture below I connected the PWM block to I/O PWM OUT and to try it out I connected the servos of the rudder and the elevator to all of the different PWM connections in the PWM block and moved the sticks on my radio. However; none of them make my servos move. So I also tried all of the connections on FMU PWM OUT, but with the same result.

And from here I’m kinda lost. What am I missing? Is it because I expect the power to come from the Pixhawk? Should I power them separately? Is there a setting which I’m missing? All tips are welcome!

Have you pressed the hardware safety switch?

This is a good video on one potential aspect that could prevent servos from moving.

I had indeed not used the safety switch which is on the Holybro M8N GPS module I use. The led shows a triple blink in red, and after I pressed it, it lights in constant red. I’m not sure what those blinks or constant lights mean, but I tried moving everything with both (on all connections), and I still see nothing moving.

I then tried the trick in the video you suggested @rfriedman , but that also doesn’t work.

I then found out that the plane was in FBWA flight mode. I don’t know if it matters, but I changed it to manual just to be sure. I checked in QgroundControl, which shows me a couple errors and at the top it says “Not Ready”:

I also found some messages which tell me this:


I’m not sure what the cause of the errors are and whether the “Not Ready” is related. And I’m also unsure whether these errors relate to the fact that the servos don’t move. I would assume that you can always fly in manual mode, even if things like GPS and roll/pitch sensors fail, but I might be wrong in that.

Are there any other more detailed error logs which I can read?

I guess I could also test whether the connectors on the Pixhawk actually give PWM output. I once saw a video in which someone had a simple tester which he hooked up to the pixhawk instead of a servo to see what kind of PWM signal it gave, but I can’t find anything like it. I searched for things like “PWM tester”, but I only found things which give an output PWM signal, instead of having a PWM input and showing what kind of signal it gives. Does anyone know what kind of thing I can buy to test that?

I’m pretty stuck again. Any help would be greatly appreciated. :slight_smile:

Your servos need power and the Pixhawk does not provide it. You need a BEC or a battery pack matching your servos rated voltage to power them.

@count74 - Alright, thanks for the tip. I’m currently using a Holybro PM02 v3 Power Module (as shown below). The plug coming from this power module which I attach to the pixhawk supplies 5V. Can I split that plug so that I can draw power from that to the servos? Or do I need to attach a splitter to the XT60 so that one end goes to the motor, and the other end goes to a BEC (to 5V) for the servos? I can’t find any wiring instructions on how to do this, so tips on this are also welcome.

You will need to use a separate BEC. The autopilot power supply should always only be for the autopilot to minimize chance of power failure.

Does your plane have a motor? Many ESCs have a BEC built in. Be sure to confirm the ratings of the ESCs BEC with the power or better current required by the servos. Most people still use a seperate BEC, to be on the safe side. I have used multicopter power distribution boards or self soldered y-plug/cables to power BECs and other stuff on my planes and rovers. XT60 plugs are really easy to solder together as a y-connection. I glued two female plugs together with superglue and soldered the one going to the battery between them.Then I covered the metal parts with hotglue. Still holds together and works great.

That was it! I got everything moving now! WOOOHOOOOO!!!

I measured the voltage on the PWM block, and it indeed had nothing. So I just put a simple buck down converter I had laying around between the higher voltage power output of the Power Module and connected the other side to the + and - of the PWM block, and now everything works. It was a bit of fiddling with which channel was what, and reversing some sides. But now it works!

I still need to fix the GPS, but that’s for later.

Thanks for all your tips again!

Congrats. A helpful tip next time is to push on the servos and check if they provide any resistance. If they make no noise at all when the autopilot is on, they just don’t have power.