How to get back to NuttX

I flashed ChibiOS on my PixRacer to try it out and it worked just fine.

Now I wanted to go back to NuttX version 3.55.

Mission planner asks if it’s a Linux board or APM 2+ board or a PX4/PIXHAWK. Then it ask if it’s a PIXHAWK.

Get error Firmware not suitable for this board.

Do the firmware upload again and it load just fine and my PixRacer is back to it’s old self.


I think if you pick previous version it will roll back to Nutt


I think this awkwardness may come from the MP trying to recognise what kind of board it is and it hasn’t been enhanced yet to either upload or recognise the boards with ChibiOS on them (under ChibiOS the USB port is identified differently).

I’ve added a note to the MP issue to add support for uploading the ChibiOS versions of the firmware. I think @meee1 is actively working on it because I see this recent commit to mission planner.

I’ve just move to ChibiOS and back on one of my flight boards and it worked. The MP did ask a few questions regarding the type of board (i.e. “Is This Linux?”, “Is this APM?”, “Is this Pixhawk?”) but when I answered them all correctly it uploaded properly.

Anyway, hopefully MichaelO will sorted this out shortly.

please use the latest beta MP.

or use the force px4 bootloader option on the firmware screen.

Hi Micheal,
I am having a problem rolling back firmware versions. I accidentally installed ChibiOS (for Arduplane) and need to revert back, but keep getting an error when trying to load previous firmware versions. I keep getting an upload failed error. Would you know of a way to revert the pixhawk to a version before I accidentally installed ChibiOS? Thanks a ton!

Did you already solve the issue about the roll back?

Yes, loading either one is just a matter of picking what you want. ChibiOS comes up as a new device than Nuttx does.


You can try QGC.
It should work it out.

To go back to NutX I did install the latest Rover firmware from Mission Planner. When asked the question : Load ChiBios? I did answer NO. After erase and program done: Power off the PixXXX and back on. Now re-installing a Quad and arducopter 3.6 (with answering no to the Chibios question) did place Arducopter 3.6 on NutX.

Hope this help :slightly_smiling_face:

Hi @henrik04,

i tried out, but there was no question about bootloader. Which version did you use?

After it throws me an 0x13 Proto_invalid after update from px4fmu-v2 to v3. Only ardu v4.0.3 and ChibiOS works on my blackCube. The aim is to get px4fmu-v3_default.px4 on it. Any advice i miss?

Good day, just consider that chibios perform better than nuttx.
if you want to roll back to nuttx bootloader you can try to compile it using Ubuntu or find the correct binary file and flash it on the board