Home-made Heli 700mm Blades aluminum frames

HI every one here, after the big successful with my stretched Trex 600-700 Heli using the PIXhawk 2.1 and of course a big thanks to Bill, Chris, and all others with their inputs and experiences…

I decided to fit the old Pixhawk 1 to the newer home build 700mm Blades Heli!
I call it ; the Thur … its big heli and have CNC aluminum frames !

I need your help with the logs, specially if you see any vibration… I just not good enough to read the logs to find out what is the vibration level I am at…

I copied most of the setup from my previous heli since they both have same gears , voltages, blades, RPM etc…

and I did tuning the P and D but left the I as is…

the heli was stable on Stab but not that great on Loiter mode!

but there was no toilet bowl, but it was drifting little

here is a log of my new test flight with both Stab and Loiter Mode

Hopefully Bill Have some time to take a look at the logs

I appreciate all help!

Thur Heli OCT 14 2019.param (14.1 KB)![20191014_180423_crop_79|690x460]

Nice job on the helicopter. Looks good. Also nice job mounting the flight controller. Your vibes look great!

Well I have a few suggestions for you. First it appears that your 2/rev vibration is showing pretty badly in the Pitch and roll D term. The frequency is around 44 hz which means your rotor speed is around 22 hz. in order to make sure the notch is covering your 1/rev set INS_NOTCH_BW to 10. Next lets try to reduce the noise in your D terms from the 2/rev by setting INS_GYRO_FILTER and INS_ACCEL_FILTER to 10. Otherwise things look pretty good with signal quality.

So your log file parameter values and the parameter file values don’t match for the ATC_RAT_RLL_P and ATC_RAT_PIT_P. In the parameter file they are 0.005 and in the log file they are 0.0025. This seems awful low for P gains and I’m not seeing any oscillations at all. Are you sure the P gains aren’t suppose to be 0.025. that would make more sense to me. P gains are typically higher than D gains. I would suggest raising your P gains until you see oscillations and then halve the P gains and use them.

We’ll need to look at things again for loiter once you set your RATE P and D gains. I may have you increase your VFF gain as well once we get the P and D gains set.

Overall I think you are at a great starting point!

Thank you so much Bill, I learn new thing everyday, its grate place to be with!

yes I am sorry for the confusion, the P and D gains all of them for the Pitch and the RLL are .005 I connected the FC to the Mission planner and I double checked them and yap both for both RLL and PITCH are .005

do you think is better to reduce the D gain to let say .004 and keep the P to .005

I changed all other INS_NOTCH_BW to 10

I am going to hover it on Stab then Loiter and upload the file

Thank you VERY MUCH!

I really think you should try to raise the P gain for both pitch and roll. At what P gain value did the aircraft start oscillating when you raised the P gain in your tests?

EDIT: One last suggestion is to put your PSC_ACCZ_FILT to 10. you have a lot of vibration on your vertical accel at the 2/rev. This filter should help remove some of that.

I just flew it before I change the PSC_ACCZ_FILT to 10

the P gain was oscillating when I reached the .006 so I turned down to .005

but the D gain still can go more but like you said we can’t have the D gain higher than P

here is the flight just 10 min ago

next test will be after changing the PSC_ACCZ_FILT to 10

the Heli was doing grate at loiter mode!!
the very very little drift was maybe because the Compass Y= - 114 and need to go down to less than -50

I must calibrate the compass once again outside home… I was in rush to calibrated inside the house!

Thank you!

parameters Oct-15-2019.param (14.1 KB)


after changing the parameters, I flew it today… its stable but drifting little bit on loiter mode

not rock solid !
Edit: the tail is kicking little bit! I am thinking maybe because of the low RPM!! but the blades are 120mm !
I can try collective pre-comp to .0400 instead of .35
but do you think hover roll will be good to be at 4.00 instead of 3.5 ?

is there parameters to change regard the GPS lock ?

I calibrated the compass 20 times outside but never get better than X: -22 Y: -108 Z:34

the Y is never get under -106

do you think I am ready for some auto mission?
Thank you

do you think the Bin file will be enough?

parameters OCT-18-2019.param (14.1 KB)

I would recommend reducing the D gains for pitch and roll to 0.003 and try to raise the P gains for pitch and roll. Please send me a log that shows your oscillations with the P gains raised. I just want to see what you are seeing.

After you check the P gain, if you can’t get it any higher. Then I would fly it in loiter and and adjust the PSC_VELXY_D gain. Raise it in 0.05 increments. Be ready to take over in stabilize if you see any oscillations. You should see the hover become more stable as you raise this gain. Don’t go above 0.25 with this gain. Most others found 0.25 to be enough to provide better loiter station keeping.

Once you fly in loiter at speeds you plan to fly in auto to ensure there are no oscillations then I would say you are ready for auto.

Hi Bill,
I reduced the D gain for both RLL and Pitch to 0.003, and started increasing the P gain till I got 0.1 on both Pitch and RLL; I got very little oscillating not really noticeable… in fact I was able to do aggressive maneuvers I was almost going 3D!! with speed.

I also tried Loiter mode ( I know I not supposed to try Loiter, but at the end of the maneuvers told myself lets do the loiter in case if you need to see that!

on loiter mode the heli was kinda OK, but the tail didn’t hold it was yawing to the left and I had to keep my hand on the rudder to keep it there!

but it was drifting within few feets ( 5 feets)

edit: will change the PSC_VELXY_D gain like you said on your post, but will decrease the P gain to .09 just to reduce that little oscillating… and will post new logs

here is the logs and the bin
with the parameters, hope is ok!
thank you very much!

paramters after increasing P gain.param (14.1 KB)

here is I changed the PSC_VELXY_D gain to 2.5

and reduced the P gains to .08 just in case if there is any not noticeable oscillation…

Oh forget to tell you that I changed the mounting material from the furniture pad to a 4 layers of thick valcro
I also changed the Yaw P gain to 0.32 to get less tail throwing
but still not 100% solid tail. I believe its the tail RPM need to be higher.

I tried it on Loiter mode and it was drifting right within few feet
but it was nice! I think its due to the compass Y is high -109
or I may need to change ATC_HOVER_RLL_TRIM to 410

otherwise if you don’t see any issue, do you think we are good?

here is the newest logs
I appreciate your Help Bill.

changed PSC gain to .25 and P gains to .08.param (14.1 KB)

I’m still seeing some feedback oscillations even with the bringing P for pitch and roll down to 0.08. I recommend setting the ATC_RAT_PIT_P and ATC_RAT_RLL_P gains to 0.04.

I found two things wrong with your yaw setup. First you have no dead zone for the RC input
This should be at least 10 if not 20 for the deadzone. So that is why you are seeing the heading drift.

I peeked at your yaw axis PID signals. the integrator is saturating immediately which tells me that your mechanical trim is not set properly. The pwm where the stick is showing trim for a hover is 840 pwm. So use the status tab within the Flight Data Tab of mission planner. Look at CH4_out and you should be able to see realtime what the output is. So you can move your rudder stick until you see 840 and that should give you an idea of how far you have to adjust the link. The will help center the integrator and help make the yaw axis perform better. After you finish you can always fly and then pull the log and look at the PIDY.I signal to see if it moves about 0 instead of being saturated like shown below.

With loiter, the PSC_VELXY_D is helping. Keep the 0.25 and fly higher speeds that are more representative of your auto missions just to check to ensure there are no bad oscillations at higher speeds. If you don’t see any issues then you can start flying auto missions.

I just want to ask, sorry for my little info

when I go to Servo output page in mission planner, then I change the CH4 for motor4 I was able to set;
MIN: 890 trim: 1020 and Max:1150

if I change the Min to 840 it will bend the linkage no matter what I change
also will not get me same speed of servo respond in each direction…
the status page showing the Yaw 150.3
am I good?

Thank you!

I’m not sure why you are messing with the servo min, trim and max values. I just wanted you to use the status page to determine how far and in what direction that you needed to adjust the linkages mechanically to bring the integrator back toward zero.
That’s all.

I’m not sure what you are asking. You need to ask the question with a little more detail.

Sorry for the confusion
I just don’t know where to find the integrator value ?

I have attached pic below circle with yellow where I see the Yaw value…

the servo I am using is Xpert MM-3302T-HV
it works only at 760us narrow band
I had futaba servo, I didn’t have to do anything with it, its worked without any PWM settings
in this servo I had to change the Min, trim and max to get it to work!

in my futaba servo my trim was at 1500, my min is at 1000 and my max was around 1700
this one I have to lower the Min to 890 with trim to 1000 and max to 1200, but still I can see the servo not working as supposed to be;

when I push the stick to right ( Max on 1200) the servo linkage will not push the pitch to get full pitch, while when I push the stick to the left ( min 890) the servo will push the pitch to full left…

if I let say change the Min to 1000 trim to 1500 and max to 1900 the servo will not working only work in left direction and fast with little movement…
its different than my futaba servo I had; it was good right outside the box

also Attached pic for the radio calibration page…

Thank you

I have not used that type of servo and am not familiar with the PWM limits. I wasn’t asking you to change any servo parameters. I just wanted you to adjust your servo linkage as I described above. Do you not understand what I want you to do?

The servo linkage is correct as I see the servo arm 90 degree with the linkage
And the pitch at 0 degree when stick is on center position

I think the tail throw is because of low rpm! I will have to increase the tail RPM to see if I can get solid tail

Sorry for any confusion
I am sure the servo arm it’s on center when stick is on 0 and when I push the stick left or right its giving me 100% left and 100% right

I just don’t understand you when you say ( status page) and integrator value

Where to find the integrator value ? And does the status page I have it above with cyrcile by yellow ?
Thank you so much for the help

Ok that is fine. Just got to figure how to get the PIDY.I signal to be around zero. If you look at my post (post 10) I show the integrator signal (PIDY.I). So when you download your log, click on the PIDY message and select the I signal to show the integrator.

You could try increasing the H_COLYAW to see if that helps bring the integrator back toward zero.

A 760uS servo means that the center pwm value is 760. Set 760 as the trim value. I’m not familiar with these types of servos either, so I’m not sure what your upper and lower limits are. Could be as low as 400 and as high as 1100…

Bill, I am sure its RPM issue, as I have same type of servo on my previous Build, you helped me tuned it and never had problem with…

Chris, your right these servos are different from the standard old servos with high pules…

I read somewhere that the Ardupilot old versions had problems with these servos and never worked good with this system (ardupilots)
till they fix the bugs and added the 760 low Hz to work!
in my both Helis I have to set the Min to 760 in my other servo and this one is to 860~ and middle trim to 1000~ and max to 1200

but my futaba old servo work fine!

the thing I had to make the Min go under 900 by using the parameters page… as I couldn’t change using normal Heli setup or servo out page!
Thank you

I flew it in Auto today, was full auto mission…
when I look at the RATE R and P I see a lot of noise is that very bad low frequency oscillation ?

also when I look at the ATT I see the R and DesRoll not really tracing that good, but the P and DesPitch is for sure not tracing each other, and not sure how to fix it…

the DesYaw and Y are tracing each other nice but they looks weird in the graph! (big jumps), maybe that because of the kicks on the tail (tail throw)!!!?

the PIDY I see little better, what do you think? so the integrator getting close to 0?

I have uploaded the logs here, please tell me know if I need to change any parameters to fix the ATT to make the

do I have bad low frequency oscillation ?
I wish I can read the graphic like your guys! :frowning: still learning how to)

Thank you so Much

Auto mission parameters Oct-20-2019.param (14.1 KB)

If you set the Min to 760 that is wrong.
760 needs to be middle trim value.

Can someone please back me up on this? @ChrisOlson