Servers by jDrones

Holybro PM06 Battery Monitor Settings?

Hello all,

I’m currently configuring Pixhawk 4 Mini running ArduPlane 3.9.5 (I flashed the apj file). I am trying to calibrate the power module (PM06) but getting mixed results. I’m wondering if I’m selecting the wrong parameters in the optional hardware - Battery Monitor screen.

Right now I have selected:
Monitor - “Analog Voltage and Current”
Sensor - “Other”
APM Ver - “4: The Cube or Pixhawk”

I have tried multiple ways to get accurate readings in Mission Planner and QGroundControl to no avail.

The first way, I measured voltage using in-line power analyzer and input that figure into the measured battery voltage. Then ran the motor so that current was showing above 10A on the power analyzer and inputted the current into the “measured current” field. The voltage and amperage still do not show accurately.
I also followed the instructions from HolyBro here: https://shop.holybro.com/micro-power-module-pm06_p1036.html but still no good. Am I doing something wrong?

Thanks

I am having the same problem, followed the same steps also. I hope someone here can help.

Hi,
I had the same problem Pixhawk 4 mini, PM06 and copter 3.6…
The trik to resolve it is to configure like a standar one, not as holybro tell into manual…
Volt pin A0 and Amp pin A1. after that calibrate the measure with a volts and wattmeter…
For mi with a 2s 950mA the mod are:

  • Amp pet volt 38
  • Volt multiplier 10.20

Hope this can help you.
Bye Matteo
IMG_20190303_014741|666x500

Thanks, was able to get the voltage to work. Current is still messing with me. Tried every combination of pins. At least I can fly now, before it would shut down due to low battery voltage. I will keep plugging away at it.

Make a sreenshot of your setting… so i can compare with my… :wink:
If the voltage reading is ok also the Amp shuld read fine…

Thanks @Teos81 that did the trick!
@johnnie_w2 here’s a screenshot of my parameters. Same as Matteo and voltage and current measure accurately for 4S.

Thanks for sharing your settings. I tried above settings, but following worked best for my setup:
Holybro Pixhawk Mini with 5000mah 3S Lipo battery

I use PM06 with holybro pixhawk 4 mini + arducopter 4.0.3
It seems works with below setting

The picture show my disarmed situation with 4S battery. When I use 3S, it show 12.xV

Servers by jDrones