Servers by jDrones

Holybro Pixhawk 4 FMU-v5 Bootloader Erased

Hello; I bought the Holybro Pixhawk 4 Flight Controller, FMU-v5 was pre-loaded. I looked over QGC and Mission Planner, lot’s of flyers said Mission Planner was better than QGC…? I decided to try Mission Planner. MP will not Download Pixhawk 4 Firmware, only option is Arducopter, Arducopter is not Pixhawk 4 F/C…! For months I watched YouTube’s, PAINLESS360, Lee Schofield… most of what he did was on Mission Planner… In one of his video’s he showed how to change the Bootloader to Ardupilot with ChibiOS… which I followed and changed. Now I ton’s of problems…! I paid $227.94 for my Holybro Pixhawk 4 F/C now it’s a mess…! Since Ardupilot and I changed the Bootloader…is there any way of Flashing the FMU-v5 Pixhawk 4 Bootloader back on to the Pixhawk 4 F/C so that I have my Pixhawk 4 F/C back to it’s original factory self…? Thanks in Advance…! =)

Yes it can be a bit confusing.
Ardupilot is one type of firmware, PX4 is another type of firmware. Two separate projects with some common ancestry, and they both work on the same hardware, like your Pixhawk 4 for example.

  • QGC can install and work with either Ardupilot or PX4. Cleaner interface, easier to use.
  • MissionPlanner only works with Ardupilot. More features.

Ardupilot supports a range of hardware designs, like FMUv2, FMUv3 and so on… You generally dont need to know much about that. The groundstation software, QGC or MP, should recognise your board and offer the correct firmware install by default.
Early model pixhawks get a bit sketchy around the whole 1meg RAM limit thing, but nothing for you to be concerned about.

So the end result is:
You can stick with Ardupilot firmware and use either QGC or MP - or choose PX4 firmware and QGC.

  • PX4 firmware might be a bit easier to set up and get to a flying stage. https://discuss.px4.io/
  • Ardupilot takes longer to set up and there’s a steep learning curve, but there’s more features and scope for more uses, and it’s very satisfying when you get everything working

If you’re struggling at a particular stage or issue ask for more help and we’ll try to get through it.
You wont really be able to flash the wrong bootloader without doing some tricks, just decide whether to use PX4 or Ardupilot.

Good day, if you want focus with ardupilot i suggest you use MP and for all the settings better you use it, while if you want focus with px4 you can use qgroundcontrol.
if you want restore your flight controller as factory you can do it following two ways… flashing it using an st link… better version 3 or flash the firmware you can find looking px4 firmware releases corresponding to your fc.

Thanks Shawn; I pretty much understand the whole concept of the two different Firmwares being Ardupilot/ChibiOS Bootloader & the Pixhawk 4 FMU-v5 Bootloader. They’re also both Open Source…and I have heard complaints about both, but like I said earlier… I sure don’t want Ardupilot w/ChibiOS, I want the Pixhawk 4 FMU-v5 Bootloader back on board…! The whole problem now is, How do I go About getting the Pixhawk 4 FMU-v5 Bootloader Flashed back on to the Pixhawk 4 Flight Controller…? I’ve searched google, youtube, and some others but nothing ever comes up… is it a big secret…? I mean Mission Planner Erased “PX 4 FMU-v5” and then Flashed it with “Ardupilot w/ChibiOS”… So it can’t really be that bad is it…? Thanks in Advance…

James…

Thanks Dave84;

I pretty much for sure want Pixhawk 4 FMU-v5 Flashed back on the board, I don’t have any idea what an ST Link is…! As for looking for Firmware I’m not able to find much anywhere, I even asked Holybro about it here’s what they said:
“If you want to run Px4 stack, please flash the firmware with QGC, With QGC you can flash both ardupilot and Px4 firmwares, but with mission planner , only ardupilot firmware can be installed.” I can not see any Options in QGC to Flash Bootloader, and Mission Planner only offers Ardupilot with ChibiOS…!

Like I told Xfacta Shawn, who replied above you… Flashing the Bootloader to a Pixhawk 4 must be a secret… yet Mission Planner can do it with Ardupilot w/ChibiOS… so why can’t M/P reverse the whole process…? I paid a lot of $$ for the Holybro Pixhawk 4, why would I want Ardupilot on it…?

I’d like to know the Simplest way possible w/out having to buy any more parts…??? Thanks in Advance…

James…

Use QGC to flash PX4 back onto the board. PX4 still uses nuttix as the operating system.
That’s probably how the board came.

Ardupilot changed over to chibios a while back.
The FMU numbers are more about the overall hardware design or standard than which bootloader is installed.

Well, if you want restore your like before better you use qgroundcontrol… on the option firmware just connect the fc and follow the instructions… after this you can choose px4 stack. Flash the bootloader it’s not s secret…, but it’s useful if just in case during the firmware flash something goes wrong. Mission planner cannot do the reverse coz the codes of ardupilot and px4 is different. Just search on Google px4 firmware releases… on the page you can find the firmware version. Inside firmware file there is always a small part also for the bootloader.

Thanks again Shawn…However, I asked about How I go about that procedure…in QGC…I see nothing in QGC Doc’s about Flashing the Bootloader…?

If you’re not sure how to do it can you please direct me to someone who might or would know… ? Thanks in Advance, detailed instructions…please…?

James…

Hello Dave84; So is this Bootloader File the one that ends with an extension of .VLC …? Is it a .bin or ,Hex file…? Is it the one that I copy to the SD-Card and then initiate via QGC SD-card content display…? I have no idea how to compile any file, and Google has all sorts of files listed, Source Code, Binaries…?. You see, I am new to this stuff…this is my first ever Drone, except for the one I bought at Walmart for $50.00… and it said acrobatic drone…set on Demo and watch all the tricks…! I did that… it took off at full throttle, flew straight up in the air and out of sight in a few seconds… I said well, there’s $50.00 down the drain…! Eventually it came back down as I walked away… it crash landed in an evergreen tree at the side of an Arroyo… it didn’t break anything but I needed a 12 foot long branch to get it out of the tree… I gave it to a kid down the street… and decided I’d build my own much larger… the one from Walmart was palm size couldn’t see it if I wanted to…! Thanks in Advance,

James…

Have you installed PX4 via QGC and tried this bootloader update process?
https://docs.px4.io/master/en/config/firmware.html#bootloader

well, bootloader have the extension in. bin. while firmware is in .apj.
For no ardupilot boards you have a different extension coz the firmware have also the bootloader.
If you want flash as factory your fc, as previously said is flash the firmware in. px4 again with qgroundcontrol or use an stlink dongle

Shawn; Yes I’ve done that, but it’s not working…! Details, I tried to take a print Screen in Windows 10, I got nothing…! So here’s a verbal…

  1. I opened QGC, I went to Summary/Firmware, I selected Firmware, Please unplug your Pixhawk 4 &/or Radio from USB. I did that…!

  2. Now it says, Plug in your device via USB to start Firmware Upgrade (2 lines of that direction) I plugged in my Device…!

  3. Screen shows: FOUND DEVICE: ARDUPILOT ChibiOS

Connected to Bootloader

Version 5

Board ID: 50

Flash Size: 2064384

  1. Firmware Choices: 0 PX 4 PRO Stable Release" v1.11.3

0 Ardupilot

No firmware Available

0 Advanced Settings (I checked the box)

Standard Version (Stable)

Beta Testing (beta)

Developer Build Master)

Custom Firmware File…

First, I selected PX 4 Pro Stable Release v1.11.3… it loaded and re-Booted the Flight Controller. Then I selected the Developer Build (Master)…the device crashed and I got an Orange bar in QGC with "Vehicle not responding, if this continues, shut down QGC, restart Vehicle, restart QGC…!

I COULD FIND “SYS_BL_UPDATE” IN THE “SYSTEM” PART OF PARAMETERS… AND I ALSO COULD NOT ADD THAT LINE TO THE SYSTEM PART…!

Holybro Pixhawk 4 Flight Controller… LED’s; under FMU side: Fast Flashing GREEN, Blue came on for a bit, then went out…!

" " I/O " : PWR=Green Steady, B/E=Amber, Steady, ACT=BLUE, steady… That’s when the Orange Bar appeared… with “Vehicle not responding”…! My Holybro Pixhawk 4 is very NEW, just bought it this past Summer and it’s PX4FMU-v5…What the heck do I do Now…? Thanks in Advance, James…


Virus-free. www.avg.com

I suspect there’s some confusion happening here. Unless you deliberately changed the bootloader, it will still be what it shipped with. Flashing ArduPilot firmware does not force a bootloader update. So just use QGC to flash the firmware you want to use, as you’ve done above. As has been raised above, there’s more features in ArduPilot, but it’s up to you. I’m curious as to why you’re so deadset against it, but are asking for help here! For help with PX4 firmware, best to visit discuss.px4.io

I am dead set against it because Ardupilot/arducopter does NOT recognize the 2 MB Flash space and therefore lots of features in the Pixhawk vs. Ardupilot/Arducopter are not available for use… many Pilots are waiting for Ardupilot/Arducopter to release a new firmware that does recognize the Flash Space being 2MB…!

James…

I am so dead set on taking Ardupilot ChibiOS off because Ardupilot/Arducopter does NOT recognize the 2MB of Flash Space on the newer Boards. Ardupilot states this and some features are not available…

James…

That’s absolutely wrong. For Pixhawk 1, two firmwares are available (1MB and 2MB), due to the errata on some boards. For everything else the firmware is built for the available flash. The racing style boards (F405/F745) are limited to 1MB, as that’s what they have, but firmware for everything else (including Pixhawk4) takes advantage of the bigger flash space.

Where did you come up with that conclusion? I think you are confusing the fact that there are some features limited on 1Mb boards. Let’s take the newest board supported by Ardupilot for example, The iFlight H7 Beast, 2Mb Flash. And how about the oldest board? Pixhawk1, 2Mb. That has been supported since SEP 2013.

FROM ARDUPILOT.ORG “DOCUMENTATION”:

Firmware Limitations on AutoPilot Hardware

The ArduPilot firmware in some configurations exceeds 1 MB in size. Some autopilots may not have enough
flash memory to store the full firmware.

For the affected autopilots, a reduced firmware is generated. This firmware omits less-commonly used features
in order to reduce the firmware size to less than 1 MB.

The missing features are listed below.

The new LUA scripting feature requires a 2MB board, so none of the boards below have that capability.

  • Sparky2 and older versions of the Pixhawk (with the RevA, RevY and Rev1 of the STM32F427 chip)
    • Common to all vehicles
      • Aux function for testing IMU failover (KILL_IMU)
      • LTM, Devo and Hott telemetry formats
      • Piccolo CAN
      • Oreo LED lights
      • NCP5623 LED lights
      • NMEA output format
      • Solo Gimbal
      • DSP support
      • MTK, SIRF GPS support
      • EFI engine support
      • AK09916 on ICM20948 compass
      • Runcam
      • External I2C barometers
      • DLVR Airspeed sensors
    • Copter only
      • Sprayer
      • Visual Odometry
      • Gripper
      • RPM
      • ADSB
      • Guided, Follow, Sport, SystemID, Zigzag and Autorotate modes
      • Beacon
      • OAPathPlanner
      • Optical Flow
    • Plane Only
      • HIL
      • Gripper
      • Soaring
      • Landing Gear
      • Qautotune mode
    • Rover Only
      • N/A
    • Sub Only
      • N/A
  • KakuteF7, KakuteF7 Mini, OmnibusF7V2, Matek F405, Matek F405-Wing/ F405-SE,OmnibusF4/ F4Pro
    • SMBUS battery
    • Parachute
    • Sprayer
  • SuccexF4
    • Parachute
    • Sprayer

Exactly. The 1MB limitations apply only to those boards listed! Other boards get everything.

Im agree with Pattinson…, you are doing a little bit of confusion. Many boards now don’t have the problem about the limit of 1MB aside some boards.
ChibiOS perform better than nuttx… not only is more fast but also the size can permit developper to include more features

Servers by jDrones