Holybro Pixhawk 4 FMU-v5 Bootloader Erased

How is your statement here:

Supported by what you posted here from the Wiki::

Everybody’s getting off track here, I don’t want to freaking Argue about what this is or what that is…! I came here for HELP, NOT a bunch of back and forth chit chat about Px Ardupilot…! If ya CAN’T ANSWER THE FREAKING QUESTION JUST SAY SO, I’LL GO LOOK SOME WHERE ELSE…!

You were “dead set against it” based on a false premise, Don’t you want to know the facts so you can best assess what firmware platform is best for you? The link to the PX4 forum is posted above.

i think we already gave the solutions…, one was using qgroundcontrol and flash px4 and the one i gave is use an stlink so you can flash again the bootloader as factory.
i think that the topic can be close

I told you that QGC flash doesn’t work…and I got no idea what ST Link is…!

Virus-free. www.avg.com

well, stlink dongle(it’s like an usb key) its a swd/jtag programmer… with Stlink tool you can restore, flash and debug…and many others things.

Dave84, David; Thanks for the information, so how does one go about using it…? Is it going to create a Bootloader for the Pixhawk 4 and install it…? I know nothing about it or compiling any programs…etc…? And what is a swd/jtag programmer…? I am not an Electronics Engineer, or a Technician… I took Basic electronics in a Tech School Adult Ed program way back when CB Radios were popular, and I’ve built a few Computers… from scratch by assembling parts…mostly Windows Compatibles… Any good Sources I can check in to…?


Stlink dongle is simple but can be tricky.
with the tool you can flash the bootloader and after this the firmware with qgroundcontrol.
You don’t need build the bootloader… you can find it looking in www.github.com and search for px4.
You have to follow the pinout of the jtag port of your fc and connect it on the dongle.
stlink tool and guide must be downloaded from st.com

Well Dave84…If it’s like the rest of this screwy project I started over 2 years ago… It’ll be messed up also…4 to 5 failed ESC’s from Amazon, another PX4 F/C from Ebay.com that never would ARM…because the tiny I/O Reset Button decided it would simply fall apart and strew parts all over the inside of the case(reason for getting Holybro PX 4…Ton’s of Error messages on QGC, then flashing the PX4 w/Ardupilot with ChibiOS…biggest mistake…! Lord knows what’ll happen next… and I’ve got another bad ESC on M1 it doesn’t spin… but at least 2,3,&4 Motors work…! Then FAA brings out Remote ID…at least 30 months for that to get done, if I live that long…?

Virus-free. www.avg.com

1 Like

I, Absolutely have no interest in ArduPilot/Ardocopter… or Mission Planner…! QGroundControl is the only option…Yet, QGC has NO Option, NO Selection, NO Application, NO Choice and NO Ability to flash Pixhawk 4 FMU-v5 Bootloader anywhere in it’s contents…! I have downloaded and Installed both the current Stable Version and then I tried the latest Daily Build. I found some FMU-v5 Bootloader Files w/.bin, w/.elf, w/.hex file extensions… QGC goes through all the motions…but in the end, firmware update still reads "found ardupilot chibiOS’ and NOT “Pixhawk 4 FMU-v5”…! I know nothing about any ST-Link or it’s functions… I not in any position for buying more electronic garb(that I know nothing about) to try and further destroy my $227.94 Holybro Pixhawk 4 Flight Controller, I even offered to send it back to them(Holybro) and have them replace the FMU-v5 Bootloader, they said please don’t send it here it will get lost in Customs…! In my opinion… the Support people, Dev’s, and all the experienced so-called Technical people should, some where have a better solution to, enable one, anyone, to Flash a Pixhawk 4 FMU-v5, or any other Version, BOOTLOADER to a Flight Controller… in the simplest manner possible…
It is a simple request… Surely…some one some where knows the secret, and all the people who are guessing… should step up, man up and offer a Service to “Flash Pixhawk 4 Bootloaders”…

Then you are in the wrong forum. Your only other option for that Flight Controller is the PX4 flight stack. Go here for the support forum:

But let’s assume you did have interest in Arducopter and still no interest in Mission Planner. Go here and download the .apj file

Then go to QGC and on the firmware tab set:
Ardupilot/Multirotor/Advanced settings/Custom firmware file.
Pick the .apj file.

Then forget about the bootloader and configure the Flight Controller for your application.

Thanks Dave84…I’m out of here…!!!

Mate, good luck with your endeavors, if you don’t want to tinker and don’t want to take the considered advice of these kind developers, then go and buy some closed dji drone and be happy with that. I don’t really think you know enough/have experience enough with these systems to make a go of it (and overall the HB pixhawk4 is easy to get working with either px4 or ardu).

well l, we have try give some suggestions for fix your fc.
If you want follow the px4 road its ok…, but you have to consider that also px4 its open source…, open source hardware and software require a little bit of knowledge and practice… aside few hardware for the developments.