Holybro Pixhawk 4 and Radiomaster R161

Does anybody know how to connect both S.BUS and S.PORT ( to have both rc and telemetry down via frsky) when using The Radiomaster R161 and Holybro Pixhawk 4 ?
The pinout of the R161 is as follows:

And the holybro pixhawk 4 has a lot of pins, but the “DSM/SBUS RC” port has the following pinout:

Can I use VDD_3V3_SPEKTRUM as S.PORT somehow ?

Or do I need to use -,+,sbus from the “DSM/SBUS RC port” and connect the receiver S.PORT to one of the telem ports of the PX4 ?

Your 2nd suggestion is correct. Typically you would connect S.PORT to a telem port and set up SerialX_Protocol as 10 for frsky passthrough

SerialX_Protocol 10 and SerialX_Options 7, then run 1 wire from the Telem TX port to S-Port.

1 Like

Hi guys,

I´m trying to connect a receiver R161 sport to a PixRacer(I tried in frsky port and telem2 port).
I tried inverting, not inverting the signals, half duplex and all, but I can’t receive any data on my TX16S using Yaapu´s lua script.
Any clue what I´m missing ?


I have an R161 on my pixracer (R15) through the frsky port. Serial4_protocol 10.

hi @Allister,

is the same version of pixracer as mine. The radio is detecting the connection between the transmitter and the receiver - if I turn off the radio there is a message of lost telemetry, but I can’t see any data on the Yaapu’s script and in the sensors, I just see battery, rssi and other 2 items.
I was wondering to open the receiver and connect the uninverted sport to any serial bus but I understand that would not be necessary.
Have you had any option set on the serial4_option parameter? Would you mind to share your serial_option parameter value ?



I only used the single wire of the FS-OUT pin on the FRSKY port.

Thanks @Allister,

I was connecting both fs out and in together, but even using just fsout now I still cannot get telemetry on the radio.
I will try to update the firmware in both radio and receiver to check if can be something in the firmware.
When you bind,you have selected the channel + telemetry right ?

For reference, I’m running AC 4.0.7, and openTX 2.3.11. As for the receiver, it’s straight out of the package so I’ve never touched the firmware and I have no plans to start. (It ain’t broke, so I’m not going to fix it)

My radio was with opentx 2.3.9, I updated everything and, except by the telemetry, everything is working great.

I tried to soldering a wire on the uninverted signal sport - https://radiomasterrc.freshdesk.com/support/solutions/articles/64000256734-uninverted-and-inverted-sbus-s-port-r161-r81
And tried to connect to a serial port, but with no success.
I just can see 5 sensors (TRSS, TQly, RSSI, RxBt and A2) and this the sensors - connectect or not connected to pixhawk.

Thanks for all the help - I will still looking for a solution :slight_smile:

I got some updates.
First, I updated the firmware on my pixracer to 4.10 beta, and then tested with R168.
In 1 or 2 times, appear a new sensor, gps but after 10 seconds I got a message of “sensor lost” and the GPS values was not updated(black). This happened with both R161 and R168.
I have a X8R too, and after a time, I decided to test it. Using SERIAL4_PROTOCOL 10 I got the same GPS sensor and same behavior, coordinate value missing some seconds after .
With protocol 4 and X8R I got 16 sensors and updates. With that I know the PixRacer FRS port is working, so lets dig a little more to see that is the issue with R161.

To use this with Yaapu you don’t need to find sensors. I have seen the “sensor lost” message but it doesn’t seem to impact the telemetry stream.

Hi @Allister,

but as far I could understood, the Yaapu’s script read the sensors discovered by the radio on the telemetry.

Not as far as I know. I don’t fully understand the magic, but I’m sure it’s not dependent on the sensor discovery.

Perhaps @yaapu can set us straight and let us know once and for all if you need to discover sensors?

The PixRacers are F4 units. Unable to invert, duplex or other magic on their UARTs.
SERIALx_OPTIONS are only for F7 or H7-based FCs. So don’t bother with it.
Serial 4 on PixRacer is dedicated to the FrSky radios, employing hardware inverter and duplexer. One can build a hardware inverter and duplexer with a MAX3232 and a diode, and can try a different serial port to see if the issue at hand is with the FC or the RX.
Google for “some soldering required” :wink:

hI @ThePara,

thanks for your points, but I believe you hadn’t read all messages on this thread :stuck_out_tongue_winking_eye: ,
because me and @Allister have the same scenario - PixRacer R15 with R161 receiver from RadioMaster, meanwhile everything has working plug’n play with @Allister, mine don’t.
With that in mind, I believe your assumption is not true because we have a setup working and other not, the board and receiver is compatible and for some reason in one scenario is working and other is not working.
BTW, I made some tests with my receivers R161 with Betaflight on a F4 board, and I have betaflight telemetry working too, so now I know the R161 sport is alive, so I will put a scope in the connection between pixracer and the receiver, because with the 2 scenarios - PixRacer working with X8R, and R161 working with betaflight, I had everything tested and working separately.
And after 15 post, there are some guys with no sensor detected and Yaapu’s script working, and some with sensor detecteds, so I belive there is no one answer :rofl:

the answer is in the wiki since 2017 :slight_smile:

1 Like

Thank you @yaapu!

Sensor discovery is optional, the script works fine without this extra step

1 Like

now that you’ve read the docs I can explain further :slight_smile:

passthrough telemetry as the name implies uses frsky telemetry as a transport for custom payload (i.e. ardupilot telemetry info), so basically OpenTX ignores these telemetry packets and passes them up to lua for further decoding, that’s the reason why they do not show up as sensors.

BUT when my script is running it decodes the custom frames and creates “fake” sensors to let end users leverage OpenTX advanced features like functions, mixer scripts, logging, etc

1 Like

hi @yaapu,

thanks for your info :slight_smile:
and thanks for the amazing work.
I will look again and redo some of my tests :slight_smile: looking the script instead the telemetry sensors - but If my understood is correct, I should have seen sensors under the telemetry tab of my radio right ?