Holybro kakute h7 bt no gps arducopter 4.3

hi guys i am struggling to get gps working with arducopter 4.3 all i am getting is no gps on the dashboard
i am using the maytek m9n 5883 which works fine in inav

things i have tried is swapping rx and tx
tried all different baud rates
tried setting different gps types
tried different serial/uarts

wiring is the same as the pinout on the ardupilot page

quad is powered up with flight pack flight controller is a holybro kakute h7 bt
any help would be much appreciated


This may be a bit late but I have just had the same issue and found if I set GPS_TYPE2 = 1 the GPS came up as GPS2.

1 Like

I have same issue with M10 gps from Matek.
Led is blinking so have gps fix but in Mission planner show NO GPS.


GPS is on port 4 tx to rx and rx to tx
Mag is ok and can be calibrated

Make sure no other serial port is set to GPS (specifically, SERIAL3_PROTOCOL, but also check the others). Disable GPS_TYPE2.

The above discussion regarding GPS_TYPE2 indicates that user made several errors in setup.