HKPilot32 BLHeli_32 passthrough


I have seen other users having similar issues to mine, but I have not been able to find a solution to my problem, so here it goes. In short, I cannot configure my BLHeli_32 ESCs using an HKPilot32, the latest version of ChibiOS and BLHeliSuite32. Here is a more detailed explanation of my problem:

I have an HKPilot32 and a Lumenier 4-in-1 BLHeli_32 ESC. Since the HKPilot32 is based on the Pixhawk-project FMUv2, I figured I would configure my ESCs following the method described here. I first uploaded the latest ChibiOS firmware. I tried both uploading the default ArduCopter firmware and the .apj file downloaded from here. I connected the ESC signal wires to the auxiliary ports and set the corresponding SERVO#_FUNCTION parameters to run the motors. I initially set the PWM output type to DShot1200, since the ESC I use is compatible with it, but I later tried all different types (with no success). Finally, I set the SERVO_BLH_AUTO parameter to 1 and rebooted the FC.

Here is where things go wrong: after successfully connecting to BLHeliSuite32, attempting to read my ESC setup gives me the following errors:

I have tried connecting the battery before connecting to the software and after (i.e. before reading the setup), but the outcome is the same. I have also checked that the COM port and baudrate are correct. Finally, I have also managed to arm a multicopter with these ESCs, so the hardware definitely works.

Any ideas? I have tried every method I can think of!