Servers by jDrones

Hexcopter Flips on First Flight, and second


(Lee) #1

I built a Hexcopter on S500 frame using Pixhawk 1 (Arducopter 3.4.6), Hobbypower 2212-920KV motors, and SimonK 30A ESC, ReadytoSky Ublox GPS, Trannis Radio with X8R reciever, and 5500mah Lipo 3S.

When the motors start everything is really smooth, as I up the throttle there seems to be no motor response until 50%-60% i.e. motors do not even accel. As soon as they start to Accel I get an instant Flip to left, no lift off just a fast flip-over on the ground.

I replaced a broken prop and went through individual motor tests again to verify motor rotation and proper prop (CW, CCW) on the correct motor, everything was as it should be. I tried again and go the exact same result.
Bin Logs are 2019-01-06-11-04-59 and 2019-06-11-35-30

https://taylorcomputing-my.sharepoint.com/:f:/p/ltaylor/EnWG47nZNtVNvJ61GPoIYA4B2cDT2k3YMAMZcbvpIhehKQ?e=98xgCR

There is a video there as well.


(RickyG) #2

I had this issue,


Turned out the frame config was wrong. I had picked I think a quad and not a hexa. Not saying thats what wrong with yours but it’s what I had.

(Lee) #3

Thanks, mine is definitely setup as a Hexarotor-X. I would recommend that you put an e-stop on your radio so you can stop it immediately when you see it start to flip. It has saved me from some disasters.


(RickyG) #4

hahah ya did that ages ago. That happened years ago.


(Mike Boland) #5

A few observations:
You are in Sport Mode so no stabilisation is taking place. Any particular reason for this?
You have rudder trim in your Tx which is going to build up an error as you slowly increase throttle.


You also seem to be getting a lot of vibration building up when the props do get up to speed. This may not be helping.

Have you calibrated your ESC’s?
Did you see this motor behaviour when bench testing without the props?
Have you bench tested without the props?
Are the Tx stick controls operating in the correct sense?

The usual test cycle for new builds is Stabilise for the first test flights, followed by altitude hold and finally a GPS mode such as Loiter.
Then you move on to Autotune.


(Lee) #6

Thanks for taking the time to look, you are a wiz at the log, which one day I hopefully will be as well.

Sport Mode - I guess I did not read that into this description “Alt-hold, but holds pitch & roll when sticks centered”, I will try Stabilize, Altitude and Position to see any difference(s), with the goal to get to Auto Tune.

I was not aware I had applied any trims at all, I will recheck those, it was not my intention
All items were calibrated including ESC’s. I did notice when I was running the motors with the props off the lack of speed increase until the 50% mark and it seemed a bit limited in range. However being a newbie and inexperienced at builds; destructive testing sometimes is a side affect (LOL).

That being said, it looks like you might be using APM planner to view the logs? Or something different? I do not see the same labels as you do. I tried using APM planner to read the log but got “Log parsing ended with errors” message. I’ll see if there is a newer version.


(Mike Boland) #7

I have found that APM Planner sometimes get the modes wrong.
Are you saying you were in Alt-hold?
What flight mode were you in for those flights?

If you were in Alt-Hold then the behaviour of the motors was correct.


(Lee) #8

Sorry for the confusion. I was in Sport Mode.

I added a couple of pictures of the bird to the link above. I did try again in stablize and same thing happend only quicker. It had much better throttle response.


(Mike Boland) #9

You need to fix the rudder trim first.
Be in Stabilise and get it off the ground quickly.
I did not notice you trying to counteract the tip with stick input.
Any reason for this?


(Lee) #10

it happens so fast I did not have a chance, I guess I could anticipate and attempt to compensate that way.


(Lee) #11

Wen’t for another quick try after clearing trims, and on stabilize. Another flop over, hit E-Stop and tried again this time holding the right stick all the way to the left, this time it flipped forward, E-Stop, held right stick all the way down and left. Slowly increased speed and it wanted to fall forward, so I goosed it. It took off, but wanted to spin/circle and drift at the same time I had no way to bring it back so E-Stop at about 10-15 ft, fell to ground upside down— totaled! Thank goodness the ground was muddy or it would have been worse. Added log and after shock pic to link above. Maybe I am reading this all wrong but the IMU and IMU2 readings do not look too bad until forced to hit E-Stop,


(Dave) #12

Did you perform a radio calibration? RC1-4 Trim are all at 1000. All but throttle should be ~ mid position (~1500). Also, your RC chan map is non-standard. Why is that?


(Lee) #13

No I did not do another radio calibration, did not know I needed to. I was under the impression that trim was on the radio itself i.e. the trim buttons for each stick direction. Is there some other trim I don’t know about? I still have no idea how you even read that in a log.

Right now I’m not sure if I will even continue with this. I just lost 3 months worth of work waiting on parts from China, hours of assembly not to mention the cost. If I continue with this I guess I’ll have to spend a week learning how to read all of this log information before I take another step. I could have deciphered that in the burn in stage.

I have one more unit left, an Octocopter that I will finish this weekend, while it rains/snows outside. I actually got it to fly once fairly stable, but not enough to keep from crashing, but who knows? It;s been a depressing day.


(Dave) #14

You don’t need to read the logs but you do need to do all of the mandatory calibrations including radio calibration, accelerometer calibration and compass calibration. W/o radio calibration the FC does not know the channel ranges and center stick levels. This is all pretty much explained in the Wiki.
http://ardupilot.org/copter/docs/configuring-hardware.html

BTW-You should never use the transmitter trim buttons on a multirotor. Center them and don’t touch them again.

And what’s up with your RC channel mapping? Typical (default) radio setup is AETR but your parameter file does not reflect this. This isn’t absolutely required but it’s standard and will make things easier when asking for help.


(Lee) #15

Well aware of the setup procedures, done them in my sleep. I merely meant that I was unaware I needed to recalibrate the radio after fixing unintended trim switch movements, Thankfully my Trannis gives verbal confirmation of center.

I am unaware of any channel mapping anomalies. My radio is set to mode 2, beyond that, I have made no other channel mappings other than switches to channels 5, 6, and 7.


(Dave) #16

The parameter file you linked to shows this chanell mapping:

RCMAP_PITCH 3
RCMAP_ROLL 2
RCMAP_THROTTLE 1
RCMAP_YAW 4

And RC2_TRIM (Roll) shows 1000 which is indicative of no calibration. Or maybe you had the trim button all the way in one direction when you did the calibration which seems unlikely. RC3_TRIM (Pitch) and RC4_TRIM (Yaw) are also 1000 or also not calibrated. The stick center PWM levles should be showing here. Is this possibly an older parameter file before you did Radio calibration?

What channel order is your Taranis setup for? Apparently not AETR?


(Lee) #17

I have no idea how those got mapped that way. That being said I have noticed that after the latest firmware release, the radio calibration does not perform correctly, in that after doing a calibration for the first time I keep getting errors saying that the SERVOxx_min value is less than trim and to get the pre-arm warning to shut up I had to go and manually set the values for all Min and trims. Min was recommend at 1000 and if I remember I got warnings when Trim was not set at the same value. So this explains the Trim(s) referred to in previous posts. I had no idea what was in the .param file, now I do as well as lesson on how I set the value incorrectly. I did not change any of the channel mappings themselves just the min and trim. Hopefully others will have the same issues as I using the new firmware (its just not me) and it will get fixed. The APM is Pixhawk 1 on copter 3.4.6. I think I had the same Min/Trim issue with my Octo as well. I will go inspect those as well and reset all of the trims to 0. Its APM is Pixhawk 2.1 again with copter 3.4.6

Thanks, this most definitely will save my Octo from crashing, or at least from this reason.

I did nothing special in the Tarannis setup other than select mode 2 for operation. I have not changed any of the channel 1-4 mappings. So in looking at my Tarannis, going through radio setup I do see a default channel order that is NOT AETR, so I changed it to that.


(Dave) #18

I would re-flash the firmware to the Pixhawks with current Stable, which is 3.6.4, use the “reset to default” button on the Full Parameter List page and start over from scratch with configuration and calibrations.

After changing the channel order on the Taranis make sure the Inputs are correct for the models. Also, you will almost certainly have to invert the Elevator channel to get proper pitch control.


(Lee) #19

Sorry dyslexia, it is 3.6.4


(Dave) #20

I would still reset to default and start over.