Servers by jDrones

Hexacopter wont lift


(Christopher Seipt) #1

Hello, fellow members of the community,

I have a problem with lifting my copter from ground. My setup is an APM 2.6, a DJI F550 frame (clone), six (obviously) 2212/920KV motors, an FLYSKY FS-i6 controller with a FS- IA6B receiver, an 4000 mAh battery and an external gps module with external compas. I ordered everything (except battery) on aliexpress. link: https://goo.gl/o25fvd

The problem I am facing is similar to several cases on this forum thread. But the answers weren’t clear enough for me. Because I have an APM 2.6, I can only install AC 3.2.1. To set up my copter I use Initial Setup>Install Firmware and after choose the hexacopter icon. I follow the instructions step by step, but my copter wont arm (3D NoFix and much more strange things). I solved it once by going outside, where the GPS can get my location. But these settings wont save and therefore I am left with an disarmed hexacopter, which drifts right at liftoff.

Its really frustrating, because I can not find anywhere a solution for my setup. Many people have similar problems but they a PixHawk or a newer version of APM and another flight controller. For example one suggested to solve the problem by configuring the 7th channel. Yes, it would have been helpful, if i had channel 7 :smiley:

Please help me, because I dont know what to do. If necessary, I will show photos of my setup and videos of the incidents. All logs from today are here, if you need something else, please let me know.

Greetings,

Christopher

2017-07-15 17-56-39.tlog (27.4 KB)
2017-07-15 17-52-48.tlog (285.5 KB)


(Mike Boland) #2

Can you upload a .log file from the flight controller please?

It will have much more detailed information in it than the .tlog’s

And photos of your setup will help.
What size props are you using?
I assume from your motor specs that your battery is a 3S.


(Christopher Seipt) #3

Hi, thanks for your quick answer!

So, first of all, here is the link to the photos and 2 videos how that thing flips: https://cloud.mail.ru/public/LjXp/KkMZm1DEB

I hope that is the right .log file. Please tell me, if thats the fitting one.

Waiting for your answer,

greetings,

Chris.
2 01.01.1970 3-00-00.bin.log.param (5.0 KB)
7 01.01.1970 3-00-00.bin.log.param (5.0 KB)

Edit: the tape is of course temporary :smile: a gps mount etc. is coming. If you have any recommendations regarding the build I will be pleased to listen to your suggestions))))


(Mike Boland) #4

Those are just your parameters.
What is needed is the .log file from the Flight Controller.

The props are a bit small for the kv of the motors with a 3S battery.
I would be using 10" at the very least.

Taking off on grass and trying to do it gradually is not going to work very well.
You don’t seem to be trying to counter the tip over with stick input.
I would be able to tell this if I had the .log file to look at.
Generally for a takeoff, especially on grass, you need to “punch it” to get it into the air.
Not hard, just enough to get to half to one meter.
Even the big copters tend to tip on the first takeoffs, especially on grass.


(Christopher Seipt) #5

Ok, and where can i find the .log file for flight controller? Which directory? Its so strange, they are selling a set with to small props. So stupid.

So grass is no good? What do you mean by “punch”? Raising the rpm very fast?

Yes, I dont counter it by stick. Its true. Is it necessary? I mean, isnt the arducopter supposed to counter it automatically?


(cala2) #6

http://ardupilot.org/copter/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html
Be shure that copter movements are as expected before try to take off.


(Christopher Seipt) #7

So, I think I found the right ones this time. Actually, the files werent labeled “.log”. These are just Textfiles. Just in case I am going to throw in also the .bin file.

@cala2 what do you mean by that? How can I be sure about copter movements when I am not even able to get this thing into the sky >DDDDD Be more precise

@mboland hope these will be more explanatory. By 10" you mean inches, right? I am only familiar to the metric system. You didnt answer my question about the grass, the punch and the stick input. Waiting for your reponse))))

7 01.01.1970 3-00-00.bin (98.0 KB)
7 01.01.1970 3-00-00.bin.log (204.9 KB)


(Mike Boland) #8

Yes, those are the log files requested but they have very little in them.
Can you increase your logging level and try again?

As @cala2 mentioned, have you checked that the RC sticks produce movement in the correct direction?
Remove your props, arm, move the throttle up a bit so it won’t auto disarm, and try roll and pitch, and make sure the correct motors speed up and slow down.
Next, while the motors are still running, pick it up and tilt it, making sure the high motors slow down and the low motors speed up.

You don’t have you battery monitor hooked up.
Would be helpful to know what your battery and motors are doing.

There will always be a bit of lateral movement when taking off.
If you are on grass then one leg is going to dig in and you will get a tip over.
If you are trying to take off carefully (as you would for a first flight) then you need to moving the sticks to counter this tendency to tip.
So as it tips back you should be pushing forward on pitch to hold it level until it actually lifts off at which point you can ease off.


(Christopher Seipt) #9

How do I increase the logging level?


(Mike Boland) #10

Have a look here http://ardupilot.org/copter/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html#common-downloading-and-analyzing-data-logs-in-mission-planner


(Paul Kelly) #11

I see from the pictures your APM is not mounted properly, it should be level on the frame and as close to center as possible, it should also be mounted on foam or an anti vibration mount. Other than that you have to be more positive in take off as mboland said.


(Paul Kelly) #12

I also see from your picture the GPS module is not pointing exactly forward, it needs to precisely point forward in line with the APM - the GPS does not save your location but finds it in real time, mostly you need to be outdoors and away from tall buildings and electric pylons which can cause interference


(Paul Kelly) #13

you may need to re-do compass calibration after setting the APM correctly on the frame


(Christopher Seipt) #14

Hello to all,

I am sorry, that it took me so much. So, I tried it today again and followed your instructions. First of all, thanks @mboland for the link. I checked everything except the camera, because I dont have any. As suggested, I increased the data output for the logs. Hopefully that will help you.

And @Pkelly thanks for your advice. I know mounted the APM on an antivibration mount and the GPS is pointing directly forward as the APM does.

But here the good news take an end.

As @mboland suggested I didnt take off from grass today. I instead placed a big wooden board on the grass. I started the copter and tried to counter the tilt by stick input. The copter was still on the ground but the motors were pulling it straight upwards. That was the moment when I thought that I can do the “punch” as you said. I increased the throttle, the copter went up. I thought that was it, that I made it. Immidatly after that he made a backflip. Take a look at the two new photos: https://cloud.mail.ru/public/LjXp/KkMZm1DEB . Doesnt look really nice. I am not sad, I am just tired, really. Dont worry I have enough replacement parts, but that feeling that i didnt got any further frustrates me. But I hope that this time the logs are helpful. If not, I dont know what to do.

Here are the logs.

Waiting for your answers, its really nice to see that so many people are trying to help. Thank you!

2017-07-20 20-55-54.bin (39.2 KB)
2017-07-20 20-55-54.log (86.2 KB)


(Mike Boland) #15

No new photos in the link you gave.

Looking at the RCin v RCout everything follows quite well.
All your motor outputs are very consistent.

But you haven’t answered one of the questions.
Did you do a motor test for control and stabilisation?
Have been through the Wiki?
e.g.: http://ardupilot.org/copter/docs/flying-arducopter.html

There is plenty of information there to get it right for the first flight but you have to follow the steps.
No short cuts.

You still have no voltage or current sensing turned on.
Did you recalibrate everything after sorting the mounting issues as @Pkelly suggested?